none
Exchange Server 2003 - Backup eines Public Store Einbinden RRS feed

  • Frage

  • Hallo,

    ich habe folgendes Problem:
    Wir haben hier ein Produktiv System auf dem der Public Store funktioniert.
    Nun wollte ich den Public Store auf seine Integrität prüfen, dies wollte
    ich aber nicht in dem Produktiv System machen und habe darum eine VM aufgesetzt
    und bei der Installation des Exchange Servers darauf geachtet das er genau so
    aufgebaut ist wie das Produktiv System. Nachdem ich ein Backup vom Public Store
    auf dem Produktiv System gemacht hatte und nun versucht habe den Public Store
    in die VM einzubinden kommt nun immer eine Fehlermeldung beim Bereitstellen des
    Öffentlichen Ordners.

    Fehlermeldung: "Die Datenbankdateien in diesem Informationsspeicher sind inkonsistent."
            ID-Nr.:c1041739

    Nach langem Googlen und vielen Tests komme ich einfach nicht weiter.

    Meine Frage an dieser Stelle ist, gibt es noch Sachen zu beachten die man bei
    der Einbindung in ein neues System beachten muss /kann und ob vllt. der Fehler
    behoben werden kann?

    Viele Grüße und Vielen Dank 

    Artur

    Dienstag, 20. März 2012 15:35

Antworten

  • Moin,

    Auf der VM habe ich den Restore folgendermaßen versucht durchzuführen. Ich habe ein neu Datenbanken angelegt, daraufhin habe ich die Bereitstellung aufgehoben die neue Datenbank rauskopiert und meine alte vom Produktiv system eingefügt. Und beim versuch diese Bereitzustellen komme ich nicht weiter.

    Ok, dann muss ich Dich leider enttäuschen, denn so einfach geht es leider dann doch nicht. Datenbank Portabilität gibt es erst ab 2007 und dann auch nur für Postfachdatenbank. Bei 2003 sind die Datenbank an den Server+Speicher Gruppe+Exchange Organisation gebunden.

    (Bei Interesse findest Du hier ein paar Hintergründe: http://www.msexchange.org/tutorials/Understanding-LegacyExchangeDN.html)

    Wenn Du Dir beim Bereitstellen das Event-Log anschaust, solltest Du auch Einträge finden, die sinngemäß lauten, dass der Namen in der Datenbank nicht zu Namen in der Organisation passen.

    Die bleibt daher nichts anderes übrig als:
     - neues AD anlegen (muss soch heißen, wie das alte, oder Restore des AD in eine Laborumgebung
     - dort einen neuen Exchange in identischer SP-Version installieren, wobei: Name der Ex-Organisation, Name der Administrativen Gruppe und Name des Server identisch dem Original sein müssen
     - dann eine ÖO-DB anlegen, mit dem gleichen Namen in derf gleichen Speichergruppe, Dateinamen und Pfad sollten auch identisch sein

    Dann solltest Du die DB dort einbinden können.


    Grüße aus Berlin schickt Robert
    MVP Exchange Server
    • Als Antwort vorgeschlagen Alex Pitulice Montag, 26. März 2012 08:23
    • Als Antwort markiert Alex Pitulice Dienstag, 27. März 2012 08:46
    Mittwoch, 21. März 2012 11:50

Alle Antworten