none
SBS2011 und Outlook2011 auf Macs: Mails werden autom. gelöscht RRS feed

  • Frage

  • Hallo zusammen!

    Wir haben ein relativ vielschichtiges Problem mit Exchange2010 und/oder Outlook2011, daher packe ich das Ganze hier ins Exchange Forum da Crosspostings ja sicher nicht gewünscht sind.

    Unser Server ist ein SBS2011 auf dem zusätzlich noch für einige testzwecke ein Office/Outlook2007 installiert ist (war früher mit Exchange2003 ja nicht möglich, sollte aber nun nicht der Schuldige sein bzw. besteht das Problem auch wenn dieses Outlook nicht läuft).

    Im Netzwerk befinden sich gemischte Clients mit WinXP/7 (alle mit Office2007) und 2 iMacs (mit Office2011) und alle arbeiten mit einem eigenen Exchange Postfach (teilweise mehrfach verbunden auf verschiedenen Clients).

    Nun zum Problem: Bei einem der beiden Macs wurden plötzlich Mails gelöscht. Regeln usw. sind keine vorhanden, gesendete Mails wurden alle gelöscht, gehen aber ganz normal raus, der User bekam auch Mails, allerdings wurden da eben auch die meisten gelöscht (sobald sie gelesen waren, sonst ist nix passiert), manche blieben aber auch im Posteingang liegen. Hab alle vorhandenen Mails exportiert und konnte das Problem erstmal lösen indem ich das ganze Postfach samt User neu erstellt habe, ab da war erstmal wieder alles ok.

    Das ist etwa 2-3 Wochen her, jetzt hab ich den ganzen Spaß mit dem selben User wieder, nur dass jetzt nicht nur neue Nachrichten betroffen sind sondern wahllos Mails aus Posteingang sowie diversen Unterordnern rausgelöscht wurden!

    Gefunden habe ich die Mails glücklicherweise im Dumpster, habe eine testweise wiederhergestellt die im Posteingang lag, diese tauchte dann erstmal in den gelöschten Elementen auf was schon seltsam ist, denn es wurde vom User und Admin definitv nichts gelöscht! Also nahm ich die Mail und schob sie wieder in den Posteingang und eine knappe Minute später war die Mail WIEDER komplett weg und im Dumpster.

    Haben wir Geister in der Maschine oder was kann das sein? Das Postfach ist runde 11GB groß was zwar nicht schön, aber gewollt ist, die Postfachbegrenzungen der Datenbank sitzen und werden auch noch eingehalten.

    Das Verhalten lässt sich übrigens von einem Windowsclient der sich dieses Postfach verbindet nachstellen, auch dort werden also die Mails scheinbar willkürlich ohne Umwege direkt gelöscht. Ohne jetzt auf die falsche Fährte locken zu wollen, aber scheinbar verhielt sich das Postfach wieder normal, als die beiden iMacs angewiesen wurden zunächst nur mit OWA weiter zu arbeiten und ihr Outlook2011 geschlossen war, das konnte ich allerdings nicht mehr ausführlich prüfen wegen Feierabend...

    Ein New-MailboxRepairRequest über die Shell zeigte keine Probleme an. Wenn es an Outlook2011 liegen sollte was kann man dann noch machen? OnlineModus gibt es da nicht zur Auswahl, die Macs arbeiten gezwungenermaßen im CachedMode und über die lokale Datenbank im Mac die dann das Postfach verwaltet habe ich noch nicht allzuviel Gutes gehört. Die Größe kann im Prinzip auch nicht das Problem sein, das Postfach auf dem zweiten iMac (der das ProblemPostfach ebenfalls verbunden hat) ist mit 14GB noch größer. Oder liegt der Hund wo ganz anders begraben?

    Ich hoffe es kann mir irgendjemand Denkanstöße geben, danke!

    Sonntag, 6. Mai 2012 16:41

Alle Antworten

  • Ist die Autoarchivierung aktiv?

    Gibt es Regeln bzgl. Autoarchivierung in ein Archivpostfach?

    Gibt es Regeln im Exchange bzgl. Aufbewahrung?

    Sonntag, 6. Mai 2012 17:12
  • Hallo tsfct,

    kommen mobile Geräte zum Synchronisieren zum Einsatz ?

    Hast Du Pop3 als Clientprotokoll im Einsatz ? Wurde eventuell irgendwo ein POP3 Client an das Postfach gebunden ?

    Eventuell kannst Du, wenn Du keine POP3 Client-Unterstützung brauchst, das Ganze auf dem betroffenen Postfach temporär deaktivieren:

    Navigiere in der Exchange Management Console zum Postfach, Eigenschaften, Registerkarte Postfachfunktion - POP3 deaktivieren.

    Checke dann ob der Effekt noch immer auftritt.

    GGfs. gibt es irgendeine POP3 Anwendung die die Nachrichten abholt und dabei löscht (Fax-Drucker oder ähnliches)


    Grüße, Christoph


    Sonntag, 6. Mai 2012 17:13
  • Statusupdate:

    Eine Autoarchivierung gibt es bei Outlook2011 nicht.

    Ein Archivpostfach gibt es nicht bzw. ist nicht aktiviert am Exchange.

    Aufbewahrungsrichtlinien werden keine angewendet. Es sind 2 Richtlinien vorhanden ("ArbitrationMailbox" und "Default Archive and ...") standardmäßig die aber auf kein Postfach angewendet werden.

    Mobile Geräte kommen nicht zum Einsatz beim Problempostfach selbst, der zweite Macuser verwendet ein IPhone zum Abruf seines Exchangepostfachs, nicht aber für das zusätzlich verbundene Problempostfach (das nur zu "Überwachungszwecken" = Vorgesetzte verbunden ist).

    Irgendwelche ominösen POP-Anwendungen sind sonst nicht im Einsatz, pop3 könnte ich also deaktivieren.

    Meine weiteren Beobachtungen soweit: Am Freitag Mittag ließ ich Outlook2011 bei den MacUsern komplett schließen und sie sollten nur mit OWA arbeiten, die Folge: Bis Montag morgen um halb 10 wurden keine Mails mehr gelöscht die übers Wochenende kamen. Um halb 10 wurde durch einen Gewohnheitsklick Outlook vom betroffenen User geöffnet und Mails wurden wieder gekickt. Nachdem Outlook wieder geschlossen wurde war den ganzen Tag alles in Butter und ich habe mich gefreut mit Outlook2011 den Schuldigen gefunden zu haben, bis eben um 17 Uhr 2 empfangene und 2 gesendete Mails im Dumpster gelandet sind :(

    Ich dreh noch durch...ich könnte das ganze bei uns im Hause nachstellen nur ohne Mailverkehr macht das alles ja keinen allzugroßen Sinn fürchte ich...

    Montag, 7. Mai 2012 15:30
  • Ich bin mir nicht ganz sicher! Du hast oben geschrieben, dass du die Postfächer gelöscht hast. Hast du das Outlook Profil am Client gelöscht! Sofern dies bei der MAC Version möglich ist!

    Danke

    Montag, 7. Mai 2012 15:57
  • http://www.mac-forums.com/forums/os-x-apps-games/248721-outlook-2011-help-deletes-all-messages-exchange-server.html

    Check under Tools->Mailing Lists

    Old 03-08-2012, 11:40 AM
    It is easy to get a rule created that moves all Inbox mail to On My Computer... Took me a couple of days of searching to find this. The rule matches your own email address and moves everything just after it comes in. Delete/uncheck the rule and you will be fixed.

    Montag, 7. Mai 2012 16:01
  • Im Zuge der Löschung und Neuerstellung des Problempostfachs habe ich dessen iMac komplett von allem was zu Microsoft gehörte befreit laut Microsoft-KB-Artikel (Office2011 gelöscht, vorhergehendes Office2004 mit Deinstaller runtergeworfen und manuell alle weiteren Microsoft Systemeinträge rausgeworfen).

    Bzgl. Mailing List muss ich nachschaun, eine Regel gibt es aber definitiv nicht! Die Mails werden auch nicht in "Auf meinem Computer" verschoben sondern wie mit shift+Entf. direkt gelöscht. Und auch nur wenn sie gelesen sind.

    Für die Mails die rausgeflogen sind gibt es ja auch keine eindeutige Zuordnung, in einem Unterordner wurden z.B. ein paar Mails von Februar bis Mitte April behalten und alles was davor UND danach kam gelöscht...
    • Bearbeitet tsfct Dienstag, 8. Mai 2012 06:42
    Dienstag, 8. Mai 2012 06:40
  • Hi tsfct,

    Du solltest hier mal das Audit Logging aktivieren. Wie Du das aktivierst und Dir dann die Ergebnisse anschaust, ist unter http://exchangeserverpro.com/exchange-2010-mailbox-audit-logging ganz gut beschrieben. Da siehts Du dann auf jeden Fall wer hat es gelöscht, in welchem Benutzerkontext, etc.

    Viele Grüße

    Timo

    Dienstag, 8. Mai 2012 20:30
    Moderator
  • Hallo zusammen,

    erstmal danke für die bisherigen Antworten, ich kann leider nicht dauerhaft an dem Problem arbeiten, daher erst die späte Rückmeldung jetzt.

    Das Audit Logging hat mich nun zumindest mal einen Schritt weiter gebracht, indem es meine Vermutungen zumindest zum Teil bestätigt hat. Hier mal ein Auszug der letzten Aktion:

    RunspaceId               : b84aca7f-6a97-4fac-8da5-9907efcc44d8
    Operation                  : SoftDelete
    OperationResult         : Succeeded
    LogonType                 : Owner
    ExternalAccess           : False
    DestFolderId              :
    DestFolderPathName :
    FolderId                     : LgAAAAD2g8T/H37fT5mDNhzgJ5SZAQCNq/NIDI3KQrnWOwOgspNjAAAAWTYWAAAB
    FolderPathName        : \Gesendete Elemente
    ClientInfoString         : Client=WebServices;UserAgent=MacOutlook/14.14.0.111121 (Intel Mac OS X 10.5.8)
    ClientIPAddress         : X.X.X.X (hier stand die IP des Exchangeservers)
    ClientMachineName    :
    ClientProcessName     :
    ClientVersion              :
    InternalLogonType     : Owner
    MailboxOwnerUPN       : username@domänenname.local (die interne Mailadresse)
    MailboxOwnerSid         : S-1-5-21-2031027899-3036579000-1564907934-1193
    DestMailboxOwnerUPN :
    DestMailboxOwnerSid   :
    DestMailboxGuid           :
    CrossMailboxOperation : False
    LogonUserDisplayName : X (der vollständige Name wie er im System hinterlegt ist)
    LogonUserSid                 : S-1-5-21-2031027899-3036579000-1564907934-1193
    SourceItems                   : { RgAAAAD2g8T/H37fT5mDNhzgJ5SZBwCNq/NIDI3KQrnWOwOgspNjAAAAWTYWAACNq/NIDI3KQrnWOwOgspNjAAASXhAiAAAJ}
    SourceFolders                : {}
    ItemId                           :
    ItemSubject                   :
    DirtyProperties              :
    OriginatingServer        : EXCHANGE (14.02.0247.001)
    MailboxGuid                 : 328518df-92fe-49a0-a041-8cbbd29c5b16
    MailboxResolvedOwnerName : X (der vollständige Name wie er im System hinterlegt ist)
    LastAccessed             : 11.05.2012 13:44:38
    Identity                    : RgAAAAD2g8T/H37fT5mDNhzgJ5SZBwCNq/NIDI3KQrnWOwOgspNjAAASXl9xAACNq/NIDI3KQrnWOwOgspNjAAASXl+FAAAJ
    IsValid                  : True

    Für mich heißt das: die Aktion geht vom Outlook-Mac-Client aus und wird auf dem Server ausgeführt (siehe ClientIPAddress)

    Soweit so "gut", 2 Haken hat das Ganze also:

    1. Warum macht der Mac Client das und

    2. Warum macht das auch der Outlook 2007 Client auf dem Server ?! Da stand dann bei ClientStringInfo nichts vom Mac und bei den restlichen Clienteinträgen wie z.B. ClientProcessName stand dann die outlook.exe in der Version 12.0.6606.1000 (=2007, muss das vom Server sein weil das Postfach sonst nur auf den Macs verbunden ist). Outlook muss aber auf dem Server bleiben, damit wir mit BackupAssist eine Postfachsicherung vornehmen können weil die PSTs ja leider locker die 2GB-Grenze knacken.

    Updates haben die Clients alle, eine "Fehlkonfiguration" kann es ja eigtl nicht sein, da auf dem zweiten iMac die selben Komponenten im Einsatz sind und sich dieses Postfach/Client normal verhält... :( Nichtmal ein neues Anlegen des Postfachs hatte ja geholfen, Clientinstallation vom OfficePaket wurde ja ebenfalls schon durchgeführt.

    Die erste Symptombekämpfung könnte ich mir jetzt so vorstellen, dass ich dem Besitzer die Löschrechte entziehe, aber das ist ja keine endgültige Lösung des Problems. In einer Woche läuft die 30 Tage Aufbewahrungsfrist im Dumpster ab für die ersten Mails (oder kann ich diese Zeit im Nachhinein für die bereits im Dumpster liegenden Nachrichten gefahrlos (!) erhöhen?)

    Freitag, 11. Mai 2012 12:48
  • Hi,

    du solltest ein Ticket bei MS PSS aufmachen und dort einen Trace auswerten lassen. Das richt verdächtig nach einem Bug und der sollte kostenlos sein.

    just my 2 Cents.


    Viele Grüße Walter Steinsdorfer MVP Exchange Server http://msmvps.com/blogs/wstein/ Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer"; if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. If a answer or remark helps you to cope with your problem you can "mark it as helpful".

    Freitag, 11. Mai 2012 13:00
    Moderator
  • Aktueller Stand: Seit ich gestern Nachmittag beim Kunden war und erfahren habe, dass eben DOCH wider den Anweisungen immer mal wieder zwischendurch Outlook auf dem Mac verwendet wurde und sichergestellt habe, dass dies vorerst nicht mehr passiert war wieder Ruhe im Karton und es wurde keine Mail mehr gelöscht, weder wiederhergestellte, noch neue.

    Übrigens AUCH nicht vom Outlook 2007 auf dem Server, nachdem ich das testweise nochmal angeworfen und offen gelassen habe mit dem entsprechenden Postfach...

    Es scheint also definitv mit der Outlook 2011 Installation zusammenzuhängen. Warum der zweite Mac aber überhaupt keine Probleme hat ist eine andere Frage...

    Ich glaub ich erstell im Outlook Forum nochmal einen Beitrag und verlinke ihn hierher, wenn das gestattet ist.

    @Walter Steinsdorfer: Wir betreuen nur kleine Netzwerke und waren bisher kaum, jedenfalls ich nicht, auf direkte Microsoft Hilfe angewiesen, irgendwelche Ratschläge, Tipps zur Vorgehensweise etc? Wird wie bei jeder "anständigen" Hotline halt auch Pflaumen und Perlen geben, die man ans Telefon bekommen kann was? :)

    Samstag, 12. Mai 2012 16:10
  • Hi,

    konntest du das Problem finden und hast du noch einen weiteren Thread im Outlook-Fourm gestartet?

    Grüße

    Christian

    Montag, 20. August 2012 05:13
    Moderator
  • Hallo,

    gibt es hier Neuigkeiten oder eine Lösung, den wir haben hier ein ähnliches Problem.

    Donnerstag, 29. November 2012 09:45