none
Lokale Richtline wird trotz manueller deaktivierung immer wieder aktiviert RRS feed

  • Allgemeine Diskussion

  • Hallo zusammen,

    ich habe ein kleines Problem mit einer lokalen Richtline. Auf unseren Terminalservern wurde vor längerer Zeit in den lokalen Richtlinen der Eintrag "Menüeintrag "Ausführen" aus dem Startmenü entfernen" aktiviert, damit die User dies nicht verwenden können.

    Nun da wir GPOs einsetzen kann die lokale Richtline deaktivert bzw. auf nicht konfiguriert gesetzt werden. Wenn ich dies tue, dann ist auch der Ausführen Button unter dem Administrator zu sehen. Nach einiger Zeit (ca. 3-4 Stunden) ist plötzlich die lokale Ricthline wieder auf "atkiviert" gesetzt und der Ausführen Button verschwunden.

    Wie kann das sein? Es gibt zwar eine GPO welche nun den Ausführen button ausblendet aber die gilt nicht für den Admin und diese wird auch nicht mit gpresult angezeigt. Wenn ich mit rsop.msc prüfe, sehe ich auch nur die lokale Richtline die den Ausführen Button deaktiviert. Hat jemand eine Idee warum sich die lokale Richtline nach ein paar STunden von alleine wieder auf aktiviert setzt?

    Vielen Dank schon mal im voraus.

    Gruß

    Mittwoch, 4. Januar 2012 12:09

Alle Antworten

  • Hallo,

    >Hat jemand eine Idee warum sich die lokale Richtline nach ein paar STunden von alleine wieder auf aktiviert setzt?

    Die Einstellung muss eigentlich durch eine Domänen GPO kommen.
    Ist der Button nur ausgeblendet oder ist es auch laut gpedit.msc wirklich wieder auf aktiviert gesetzt?

    Um welches Betriebssystem handelt es sich?

    Hast du mehrere lokale Richtlinien konfiguriert?
    http://technet.microsoft.com/en-us/library/cc766291(WS.10).aspx




    MVP - Group Policy http://matthiaswolf.blogspot.com/
    Mittwoch, 4. Januar 2012 13:33
    Beantworter
  • Laut gpedit.msc ist er auf aktiviert gesetzt. Auch kann ich keine UNC Pfade in der Explorer Leiste eingeben z.b. C:\ oder \\Server\Freigabe

    Das deutet ja auch darauf hin das "ausführen" komplett ausgeschaltet ist.

    Wenn ich die lokale Gruppenrichtline wieder deaktiviere bzw. auf "nicht konfiguiert" setze dann ist der ausführen button sofort wieder da und ich kann auch UNC Pfade eingeben. Nach einiger Zeit ist dann plötzlich wieder alles beim alten.

    OS ist Windows Server 2003 mit SP2

    Das mit den mehreren lokalen Richtlinen habe ich nicht so ganz verstanden. Wenn ich in der mmc den Gruppenrichtlineneditor hinzufüge habe ich nur eine lokale Instanz. Wenn ich auf Durchsuchen klicke kann ich nur meine GPOs aus der Domäne auswählen...

     Wenn es durch eine Domänen GPO kommt, müsste dann bei rsop.msc nicht 2x die Richtline auftauchen - also einmal die lokale Richtline und einmal die Domänen GPO? Es steht ja immer dahinter woher er sich die Richtline zieht.


    • Bearbeitet phatair Mittwoch, 4. Januar 2012 15:07
    Mittwoch, 4. Januar 2012 15:06
  • Am 04.01.2012 16:06, schrieb phatair:

    Das mit den mehreren lokalen Richtlinen habe ich nicht so ganz verstanden

    Die hat ein 2003 auch garnicht.

    Lass das Spielen mit gpedit.msc sein. Lokale Richtlinien sind total
    sinnfrei. Nimm die GPMC, definiere alles in der Domäne.
    Lösche die lokalen registry.pol Dateien und starte den TS durch.

    Tschö
    Mark


    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage:       www.gruppenrichtlinien.de - deutsch
    GPO Tool:       www.reg2xml.com - Registry Export File Converter
    NetworkTrayTool www.gruppenrichtlinien.de/tools/Networktraytool.htm

    Donnerstag, 5. Januar 2012 18:50
  • > Wenn ich die lokale Gruppenrichtline wieder deaktiviere bzw. auf "nicht
    > konfiguiert" setze dann ist der ausführen button sofort wieder da und
    > ich kann auch UNC Pfade eingeben. Nach einiger Zeit ist dann plötzlich
    > wieder alles beim alten.
     
    Blöde Frage meinerseits (:
     
    "Lokale GPO" gibt es ja eigentlich nicht - wie änderst Du die? Durch
    Auführen von gpedit.msc? Wenn ja: Kann es sein, daß es einen Task oder
    einen anderen Mechanismus gibt, der eine bestimmte registry.pol in das
    GroupPolicy-Verzeichnis reinkopiert?
     
    mfg Martin
     

    A bissle "Experience", a bissle GMV... Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!
    Donnerstag, 5. Januar 2012 19:13
    Beantworter
  • >Die hat ein 2003 auch garnicht

    Bei 2003 hat sich das natürlich erledigt.
    Aber zum Zeitpunkt der Frage stand das OS noch nicht fest.

    Wenn du lokal nicht noch andere Settings definiert hast,
    gehe wie folgt vor:

    Datei "Registry.pol", welche unter %windir%\system32\grouppolicy\machine und unter %windir%\system32\grouppolicy\user  liegen löschen. => Reboot


    MVP - Group Policy http://matthiaswolf.blogspot.com/
    Donnerstag, 5. Januar 2012 20:42
    Beantworter
  • Hi,

    vielen Dank für eure Hilfe. Ich werde das morgen mal testen mit der registry.pol löschen.

    Es soll in Zukunft nichts mehr über lokale Richtlinen definiert werden, soll alles über GPOs laufen. Einen Task oder ähnliches der die Registy immer wieder "zurücksetzt" oder ähnliches ist nicht vorhanden.

    Werde morgen berichten ob es funktioniert hat.

    EDIT: Bin leider noch nicht zum testen gekommen da es bei uns etwas drüber und drunter geht. Ich habe das Thema aber nicht vergessen.

    • Bearbeitet phatair Donnerstag, 12. Januar 2012 14:09
    Montag, 9. Januar 2012 12:06
  • So, habe es doch noch geschafft.

    Ich habe nun die beiden pol Dateien gelöscht und nach einem Neustart war wieder das "Ausführen" ausgeblendet. Im Ordner GroupPolicy waren auch die beiden pol Dateien wieder vorhanden.

    MIr ist nun aufgefallen das ich noch 2 weitere Ordner habe -> GroupPolicy.WksCache und GroupPolicy.WMOriginal2

    Im Cache Order ist nichts vorhanden aber im WMOriginal2 ist das gleiche enthalten wie im GroupPolicy Ordner und es scheint mir so als würde er die pol Dateien jedes mal aus dem WMOriginal2 in den GroupPolicy Ordner kopieren.... Deswegen hat die Änderung wohl nie lange angehalten da dann die Daten wieder überschrieben wurden.

    Habe nun in beiden Ordnern die pol Dateien gelöscht und siehe da nach einem neustart ist keinen pol Datei mehr vorhanden und "Ausführen" ist eingeblendet... puh was ne einfache Lösung :)

    Kann man den Ordner WMOriginal2 eigentlich auch löschen, so das der mir nicht ständig Eisntellungen überschreibt? Ich werde jetzt ja keine lokalen Richtlinien mehr verwenden aber sicher ist sicher :)

    • Bearbeitet phatair Donnerstag, 12. Januar 2012 15:53
    Donnerstag, 12. Januar 2012 15:52
  • > MIr ist nun aufgefallen das ich noch 2 weitere Ordner habe ->
    > GroupPolicy.WksCache und GroupPolicy.WMOriginal2
     
    Quote meinerseits: "Kann es sein, daß es einen Task oder
    einen anderen Mechanismus gibt, der eine bestimmte registry.pol in das
    GroupPolicy-Verzeichnis reinkopiert?" (:
     
    Und "wer" kopiert da jetzt Dateien hin und her? Wäre mir persönlich
    nicht recht, wenn ich nicht wüßte, was genau auf meinen Computern passiert.
     
    Laut Suchmaschine hängt das irgendwie mit Novell/ZDM zusammen. Und ob Du
    das löschen kannst, kannst Du nur selbst beurteilen.
     
    mfg Martin
     

    A bissle "Experience", a bissle GMV... Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!
    Donnerstag, 12. Januar 2012 16:04
    Beantworter
  • Am 12.01.2012 16:52, schrieb phatair:

    GroupPolicy.WksCache und GroupPolicy.WMOriginal2

    Die sind nicht orginal. Da such dir mal jemanden, der eure Rechner
    installiert und frag ihn wozu die da sind/waren.

    Tschö
    Mark


    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage:       www.gruppenrichtlinien.de - deutsch
    GPO Tool:       www.reg2xml.com - Registry Export File Converter
    NetworkTrayTool www.gruppenrichtlinien.de/tools/Networktraytool.htm

    Donnerstag, 12. Januar 2012 16:10