none
Clientanbindung nach FQDN-Wechsel

    Frage

  • Moin Moin,

    das ist meine erste Frage, bitte habt Nachsicht.. :)

    Umgebung:

    Exchange 2010 SP3 UR24, Outlook 2010 und 2013 (jeweils 32 Bit) - Clients verbinden sich via RPC

    Zum Problem:

    Das Zertifikat stand vor dem Ablauf. In diesem Zuge dachte ich mir, ich zieh die Konfiguration mal glatt, wie ichs schon tausend Mal gemacht habe... :)

    • Split DNS angelegt, geprüft, getestet
    • Public Cert bei GlobalSign gekauft - beinhaltet hostnamen, autodiscover.domain.de
    • Virtual Directories angepasst
    • Autodiscover URLs angepasst
    • CAS Array angelegt und FQDN gesetzt
    • Outlook Anywhere konfiguriert und aktiviert
    • Proxyausnahmen für hostnamen.tld und autodiscover via GPO verteilt

    Exchange an sich tut was es soll und alles funktioniert.

    Das Problem sind die Outlook Clients. Diese wollen sich gegen den alten Hostnamen (interne Domain) verbinden und lassen sich schwer dazu bewegen sich selbst glatt zu ziehen. Also erhalten die User eine Zertifikatmeldung kurz nach dem Outlookstart, dass der Hostname nicht zum Zertifikat passt.

    Ich habe nun unterschiedliche Dinge ausprobiert. Einige davon funktionieren bei einigen Maschinen (aber nicht bei allen) und die anderen Dinge dann bei anderen Maschinen:

    • Warten - Weil Autodiscover zieht das ja eigentlich glatt
    • Outlook Anywhere samt Einstellungen via GPO verteilt
    • %localappdata%\Microsoft\Outlook\xxx_autodiscover.xml gelöscht

    Nach diesen 3 Maßnahmen ging es bei ein paar Clients dann auch. verbleiben noch mehr als ich bereit bin einzeln abzulaufen. :)

    Bei einigen Clients habe ich auch händisch auf Profil reparieren geklickt -> bei einigen hats geholfen, bei anderen nicht

    Das einzige, dass IMMER hilft ist ein neues Outlook Profil. Ich kann jetzt aber nicht flächendeckend ein neues Profilausrollen, es sei denn, jemand von euch hat eine Idee, wie ich persönliche Einstellungen und Ansichten beibehalten kann.


    Ich bin viel mobil unterwegs. Verzeiht die manchmal mangelnde Rechtschreibung. :-)


    Mittwoch, 10. Oktober 2018 06:24

Alle Antworten

  • Weitere (erfolglose) Tests:

    • PRF File generieren und am Outlook importieren -> Clienteinstellungen gehen verloren :(
    • 3-4 Reg Keys aus der Registry im Outlook Profil löschen um Autoermittlung zu erzwingen
    • Postfach auf eine andere (bestehende) Datenbank schieben

    Als nächstes schaue ich, dass ich eine Datenbank leer bekomme um eine neue frische anlegen zu können um eines der Postfächer darauf zu schieben.


    Ich bin viel mobil unterwegs. Verzeiht die manchmal mangelnde Rechtschreibung. :-)

    Donnerstag, 11. Oktober 2018 07:57
  • Moin,

    hast Du auch schon den Registry Key

    HKEY_CURRENT_USER\Software\Microsoft\Office\x.0\Outlook\AutoDiscover\ExcludeLastKnownGoodURL DWORD=1

    probiert? Nebenfrage: Ist bei Dir evtl. ein SRV-Record für Autodiscover gesetzt? Das müsstest Du vielleicht noch anpassen...


    Evgenij Smirnov

    I work @ msg services ag, Berlin -> http://www.msg-services.de
    I blog (in German) @ http://it-pro-berlin.de
    my stuff in PSGallery --> https://www.powershellgallery.com/profiles/it-pro-berlin.de/
    Exchange User Group, Berlin -> https://exusg.de
    Windows Server User Group, Berlin -> http://www.winsvr-berlin.de
    Mark Minasi Technical Forum, reloaded -> http://newforum.minasi.com


    In theory, there is no difference between theory and practice. In practice, there is.

    Donnerstag, 11. Oktober 2018 20:27
  • Moin, danke für die Hinweise. Den Registrierungsschlüssel kannte ich noch garnicht. Aber bewirkt der nicht auch nur, dass erneut ein autodiscover ausgeführt wird, ähnlich wie wenn ich die autodiscover xml im userprofil lösche? wie gesagt ich verstehe nicht, warum es bei einem frischen outlook profil problemlos funktioniert und sich outlook gegen den public fqdn verbindet, jedoch beim neu triggern eines bestehenden profils weiterhin versucht wird auf den alten internen fqdn zu verbinden. srv record haben wir weder intern noch extern für autodiscover.

    Ich bin viel mobil unterwegs. Verzeiht die manchmal mangelnde Rechtschreibung. :-)

    Donnerstag, 11. Oktober 2018 20:41
  • Hab den Registry Key an 2 Clients händisch gesetzt und es funktioniert augenscheinlich erstmal. -> Sehr vielversprechender Ansatz.

    Ich baue jetzt ne GPO um die Einstellungen aufs Netz zu pushen. Das könnt tatsächlich ein gerettetes Wochenende sein. Danke. :)


    Ich bin viel mobil unterwegs. Verzeiht die manchmal mangelnde Rechtschreibung. :-)

    Freitag, 12. Oktober 2018 08:09