none
Offline-Dateien - Probleme mit Offline gehen nach aktuellen Updates RRS feed

  • Frage

  • Hallo,

    wir setzen seit geraumer Zeit Offline-Dateien relativ problemlos für mobile Clients (alles W10) ein. Die Serverstruktur bietet DFS auf verschiedenen jeweils lokalen Storages an, 2 AD mit DFS-Host, 3 lokale RODC mit DFS-Host.

    Es werden automatisch das Homedrive der User und nur lesend Vorlagen für diverse Programme offline verfügbar gehalten.
    Dazu haben die User auch die Möglichkeit, einzelne Projektdaten offline verfügbar zu machen, wissen aber um die Probleme der Mehrfachbearbeitung.
    Gelegentlich gab es mal Probleme Einzelner, dass sich der Rechner über VPN offline schaltete, wozu den Usern auch erklärt wurde, dass der Schalter "Offline Arbeiten" unter "Einfache Bedienung" innerhalb der betroffenen Datenstruktur den Rechner wieder online bringt.
    So weit lief das

    Zum Problem:
    Mit einem der letzten Updates kam eine zunächst recht unspektakuläre Änderung, dass der Schalter nun wieder sein Aussehen wechselt: Ist der Rechner Online, steht da "Offline arbeiten", ist er offline, "Onlinebetrieb".

    Aber:
    Es stellte sich nach Beschwerden einiger User raus, dass die Rechner auch bei guten Verbindungen ständig auf Offline schalten, zudem häufig der Schalter dann ausgegraut bleibt. Parallel dazu konnte ich feststellen, dass dann zwar die Server noch pingbar sind, aber zB. nslookup "Unknown" für den Server ausgibt, während es bei Onlinebetrieb den korrekten Server angibt.
    In diesem Offlinebetrieb sind dann weder das DFS noch die Zielstorages erreichbar.
    Bekommt man das wieder Online, läuft wieder alles problemlos für eine kurze Zeit.

    Das Verhalten ist völlig lastunabhängig, passiert auch, wenn nur ein einziger Client über VPN auf das System zugreift.

    Ich konnte das auch auf einer Testmaschine reproduzieren.

    Ich versuche nun, das zu stabilisieren, derzeit mit folgenden Einstellungen über die GPO:
    Gruppenrichtlinie zur Erkennung von langsamen Verbindungen - Aktiviert - Geschwindigkeit 0 (nach Beschreibung als immer Online) eigestellt unter Computer und Benutzer
    Dazu ist die Sync beim Anmelden und Abmelden aktiviert, zugewiesene Offlinedateien konfiguriert und eine Standardcachegröße definiert.

    Etwas Stabilität brachte die Abschaltung des Transparenten Zwischenspeicherns

    Dennoch schalten die Clients immer wieder offline.

    Gibt es dazu aktuelle Erfahrungen und Ideen?
    Wie gesagt, bisheriger Zustand war bis vor ca. 2 Wochen über Jahre stabil.



    Dienstag, 7. April 2020 07:19

Antworten

  • Auch hier könnte es zu Verbindungstimeouts kommen, da ja real ggf. nichts getan wird. Durch die Offlineverfügbarkeit besteht ja kein Grund auf die Verbindung zuzugreifen.
    Vielleicht hilft ja diese Einstellung:
    https://www.consic.de/de/einstellung-der-tcp-keepalive-zeit-fuer-windows-server

    Zumal der Windows-Standard her auf 2 Stunden steht. Der Parameter kann sicherlich per GPO auch auf den Clients eingestellt werden, denn es gilt auch für diese.
    Ein Versuch ist es wert und unschädlich ist es auch, den Keepalive mal auf 5 Minuten runter zu schrauben.
    In vielen vergleichbaren Fällen fahre ich gut damit (z.B. VPN-Abbrüche).

    Dienstag, 7. April 2020 07:28