locked
File Association with specific filetype isn't working RRS feed

  • Frage

  • I have a client (Win 7 Enterprise x64) here which is meant to open NetCDF files (.nc) with a software called "Panoply."

    If you launch the Software it prompts you to choose a NetCDF file you want to open, what works fine. But my customer wants to determine this software as default program for NetCDF files, which seems to be impossible with his computer.

    If you try with the default programs wizard you can choose your program for this certain filetype, but if you hit "ok" and doubleclick a NetCDF file, it seems like Windows discarded the system setting you've just performed and windows tells you that it can't find a program to open this file with.

    Performing this setting with the commands "assoc and ftype" or with a third-party-tool (filetypesman) doesn't help either. 

    The affected registry entries look as follows:

    [HKEY_CURRENT_USER\Software\Classes\NCFiles\shell\open\command]
    @="c:\path\to\panoply.exe \"%1\""
    [HKEY_CURRENT_USER\Software\Classes\.nc]
    @="NCFiles"

    Have I overseen or forgotten anything?

    With other systems already the first attempt with the default programs wizard worked. 

    PS: There is no Panoply Forum, so I have to annoy you with this in here. Sorry for that.

    Mittwoch, 10. Januar 2018 16:12

Alle Antworten

  • I think this will also work with windows 10:
    http://www.nirsoft.net/utils/file_types_manager.html
    Mittwoch, 10. Januar 2018 17:28
  • Thank you for your answer, but like I already mentioned, I've already tried to solve the Problem with this software. Without success.
    Donnerstag, 11. Januar 2018 08:19