none
HyperV 2012 - SBS 2011 Domäne - Fehler 14050 Dienstprinzipalname RRS feed

  • Frage

  • Hallo zusammen,

    Versuche gerade die Möglichkeitne mit HyperV2012 auszuloten und bin auf ein Problem mit SBS2011 Domänen gestoßen. Primär geht es um die Features von HyperV2012 mit verschieben und replizieren.

    Wenn HyperV2012 Server in eine Domäne mit SBS 2011 gehängt werden, strotzt das Ereignisprotokoll von 14050 Fehlern Microsoft-Windows-Hyper-V-VMMS: Fehler beim Registrieren des Dienstprinzipalnamens "Microsoft Virtual System Migration Service". Diese treten im Schnitt alle 2 Minuten auf.

    Getestet mit cleaninstalled und "gebrauchten" Domänen (die DC's sind nicht auf dem HyperV2012 virtualisiert sondern auf anderen physicals):

    HyperV2012 - Domäne 2008R2 funktioniert (keine Fehler, verschieben funktioniert)
    HyperV2012 - Domäne 2012 funktioniert (na no na ned)
    HyperV2012 - Domäne SBS2011 ohne und mit SP1, Domänenstruktur 2003, 2008, 2008R2, clean oder gebraucht: funktioniert nie, immer die Fehler 14050 im 3er Pärchen

    Lösungsansatz von MS für 14050 lt Knowledgebase: Dienst stoppen und neu starten. Im Fall mit SBS2011 geht es aber nicht um ein Zeitdelay, dass sich mit verzögertem Dienststart leicht beheben lässt, sondern um ???Berechtigung???Kerberus ????Schemaerweiterung???

    Hat jemand Lösungsansätze, ich steh auf der Leitung, was am SBS aktiviert/geändert werdne muss, damit die HyperV2012 sich registrieren können.
    Mir ist aufgefallen, das HyperV2008R2 mit SBS2011 keine Probleme hat. Also die Registrierung des Dienstprinzipalnamens funktioniert, ausser wenn der SBS am HyperV erstellt/virtualisiert wird, was klar ist, da zum Zeitpunkt des Starts des HyperV keine Domäe vorhanden ist.

    Donnerstag, 11. Oktober 2012 02:47

Antworten

  • @DAFotil

    So habe eine Lösung gefunden! Du must in der AD unter dem Attribut-Editor direkt die Dienstprinzipalnamen eingeben, nach einem Neustart vom HYPER-V geht dann das Verschieben der Maschinen ;-)

    Server 1:
    Hyper-V Replica Service/HYPER-V
    Hyper-V Replica Service/Hyper-V.deinedomain.local
    Microsoft Virtual System Migration Service/HYPER-V
    Microsoft Virtual System Migration Service/Hyper-V.deinedomain.local
    Microsoft Virtual Console Service/HYPER-V
    Microsoft Virtual Console Service/Hyper-V.deinedomain.local

    Server 2:
    Hyper-V Replica Service/HYPER-V-2
    Hyper-V Replica Service/Hyper-V-2.deinedomain.local
    Microsoft Virtual System Migration Service/HYPER-V-2
    Microsoft Virtual System Migration Service/Hyper-V-2.deinedomain.local
    Microsoft Virtual Console Service/HYPER-V-2
    Microsoft Virtual Console Service/Hyper-V-2.deinedomain.local

    Deine Einträge mit einem 2008R2 DC haben mich auf die Lösung gebracht! :-)


    Microsoft Certified IT Professional - Enterprise Administrator Microsoft Certified IT Professional - Server Administrator Microsoft Certified Systems Administrator Microsoft Certified IT Professional - Enterprise Support Technician Microsoft Certified Professional Microsoft Certified Technology Specialist

    Dienstag, 23. Oktober 2012 21:28

Alle Antworten

  • Hast du dir dies schon angesehen: http://social.technet.microsoft.com/Forums/is/winserver8gen/thread/de342a1a-75df-4960-92ad-fdc5bdc36837 ?

    Guido Over MCITP Server Administrator 2008 & MCSA Windows 2008 & MCITP Enterprise Administrator 2008

    Donnerstag, 11. Oktober 2012 06:19
  • Hallo Guido Over, vielen Dank für den Link, ja hab schon probiert bzw gecheckt.

    Im Serverkonto des HyperV2012 sind die Berechtiungen für Self gesetzt, dass Regestrierungen von Prizipalen erlaubt sind.

    Die Liste von  setspn -l <NetBIOSName> ist interessant. Zur Info Domäne ist SBS2011, HyperV3 ist ein 2012 mit Fehler 14050, HyperV2 ist ein 2008R2 ohne Fehler:

    C:\Windows\system32>setspn -l hyperv3
    Registrierte Dienstprinzipalnamen (SPN) für CN=HYPERV3,OU=SBSServers,OU=Computers,OU=MyBusiness,DC=it-system,DC=local:
            TERMSRV/HYPERV3
            TERMSRV/HyperV3.it-system.local
            WSMAN/HyperV3
            WSMAN/HyperV3.it-system.local
            RestrictedKrbHost/HYPERV3
            HOST/HYPERV3
            RestrictedKrbHost/HYPERV3.it-system.local
            HOST/HYPERV3.it-system.local

    C:\Windows\system32>setspn -l hyperv2
    Registrierte Dienstprinzipalnamen (SPN) für CN=HYPERV2,OU=SBSServers,OU=Computers,OU=MyBusiness,DC=it-system,DC=local:
            WSMAN/HyperV2
            WSMAN/HyperV2.it-system.local
            Microsoft Virtual System Migration Service/HYPERV2
            Microsoft Virtual System Migration Service/HyperV2.it-system.local
            Microsoft Virtual Console Service/HYPERV2
            Microsoft Virtual Console Service/HyperV2.it-system.local
            TERMSRV/HYPERV2
            TERMSRV/HyperV2.it-system.local
            RestrictedKrbHost/HYPERV2
            HOST/HYPERV2
            RestrictedKrbHost/HYPERV2.it-system.local
            HOST/HYPERV2.it-system.local

    Der letzte Eintrag von ctumbels berichtet von dem gleichen Problem mit SBS2011!

    Der Eintrag von madmax2012 schildert ebenfalls das problem:

    Hi,

    I get the error in the event viewer. The server is a German version so I hope that I translated correctly.
    The event viewer protocol showing the error is under Application and Services protocols ->Microsoft->Windows->Hyper-V-VMMS->Admin.
    Error code is 14050.
    Error messages
    Could not register the Service Principal Name for "Hyper-V Replica Service"
    Could not register the Service Principal Name for "Microsoft Virtual System Migration Service"
    Could not register the Service Principal Name for "Microsoft Virtual Console Service"

    For the first server the process of joing the domain did not raise an error. They started afterwards. The 14050 errors are Kerberos issues.
    Thanks madmax

    Donnerstag, 11. Oktober 2012 08:30
  • Nachtrag, so sieht der setspn - hyperv3 mit einem 2008R2 DC, auf dem jedoch noch keine HyperV2008R2 registriert wurden. Aber auch beim Test mit einem cleaninstalled SBS2011 hat das registrieren von hyperV2012 nicht funktioniert:

    C:\Users\Administrator>setspn -l hyperv3
    Registrierte Dienstprinzipalnamen (SPN) für CN=HYPERV3,CN=Computers,DC=test2008R2,DC=local:
            Hyper-V Replica Service/HYPERV3
            Hyper-V Replica Service/HyperV3.test2008R2.local
            Microsoft Virtual System Migration Service/HYPERV3
            Microsoft Virtual System Migration Service/HyperV3.test2008R2.local
            Microsoft Virtual Console Service/HYPERV3
            Microsoft Virtual Console Service/HyperV3.test2008R2.local
            TERMSRV/HYPERV3
            TERMSRV/HyperV3.test2008R2.local
            WSMAN/HyperV3
            WSMAN/HyperV3.test2008R2.local
            RestrictedKrbHost/HYPERV3
            HOST/HYPERV3
            RestrictedKrbHost/HYPERV3.test2008R2.local
            HOST/HYPERV3.test2008R2.local

     
    Donnerstag, 11. Oktober 2012 08:46
  • Neue Testergebnisse, auch wenn die SPN's manuell registriert werden, bleiben trotzdem die Fehler 14050 alle 2 Minuten in den HyperV Servern.

    Als Lösung oder zumindest als akzeptablen Workaround: Wenn dem SBS2011 ein zusätzlicher Domäncontroller (2008R2) zur Seite gestellt wird, dann funktioniert die Registrierung der DSP sofort!!! Der 2. DC muss erreichbar sein bzw als Anmeldeserver fungieren. Ein Test mit einem 2. HyperV2012 mit gestartetem SBS und ausgeschaltetem DC hatte keinen Erfolg auch nachdem der 1. schon registriert war. Fazit: HyperV2012 registriert beim 2. DC 2008R2 und der repliziert das AD mit dem SBS2011. Mindestens einen 2. DC sollte es ohnehin in jedem Netzwerk auch bei SBS geben, also ist der Workaround für mich akzeptabel.

    Ups, dass war ein kurzer Spass. Ergebnis: HyperV2012 hat zwar die SPN registriert, aber wenn (auf jeden Fall beim booten bzw beim start des Dienstes VMMS) der 2. DC nicht als Anmeldeserver vorhanden ist oder der/die HyperV2012 den SBS als Anmeldeserver zu fassen bekommen, kommen die Fehler wieder alle 2 Minuten. Das bedeutet ja wohl, dass der HyperV2012 die SPN's bei jedem Start zu registrieren versucht. Auch wenn die Registrierung nicht funktioniert, die Features (verschieben getestet) funktioniert. Die Frage bleibt, was nicht funktioniert bzw warum die Fehler kommen.

    Hat jemand Ideen warum der SBS keine SPN Registrierungen der HyperV2012 akzeptiert? obwohl der Computer mit seinen SPN's ohne Probleme registriert wird (siehe weiter oben).
    Vorschläge für weitere Tests?
    Gegenfrage, gibt es jemanden, bei dem HyperV2012 mit SBS2011 Domäne ohne 14050 Fehler funktioniert?

    Samstag, 13. Oktober 2012 18:26
  • Ich habe zu dem Thema hier etwas gefunden: http://support.microsoft.com/kb/2761899

    Microsoft Certified IT Professional - Enterprise Administrator Microsoft Certified IT Professional - Server Administrator Microsoft Certified Systems Administrator Microsoft Certified IT Professional - Enterprise Support Technician Microsoft Certified Professional Microsoft Certified Technology Specialist

    Sonntag, 14. Oktober 2012 11:13
  • @Rene, danke für den Link, hatte ich noch nicht gefunden, guter Ansatz, löst aber das Problem 14050 mit dem SBS2011 nicht (in meinem Szenario gibt es keinen SCVMM).

    Alle Server und Clients zeigen mit netsh int ipv4 show dynamicportrange tcp: Start Port 49152 und Number of Ports 16384, nur der SBS nicht der zeigt Start Port 6005 und Number of Ports 59530 was beiden Male in Summe 65535 ergibt. Hab das Script trotzdem ausgeführt, aber keine Veränderung.

    Nur zur Vollständigkeit, habe alle Variationen mit Firewall ein/aus/Default durchgespielt.

    Montag, 15. Oktober 2012 03:21
  • Also ich habe das heute den ganzen Tag ausgetestet mit verschiedenen SBS 2011 Installationen und überall habe ich das gleiche Problem 14050. Es liegt zu 100 % am SBS 2011. Denke Microsoft muss hier dringend nachbessern!!!

    Habe auch mal in den Englischen Foren gesucht und die haben auch alles das gleiche Problem. Mit dem 2008R2 langt es wohl wenn man den Hyper-V kurz aus der Domain entfernt und dann wieder rein nimmt. Funktioniert aber auch nicht beim SBS 2011...


    Microsoft Certified IT Professional - Enterprise Administrator Microsoft Certified IT Professional - Server Administrator Microsoft Certified Systems Administrator Microsoft Certified IT Professional - Enterprise Support Technician Microsoft Certified Professional Microsoft Certified Technology Specialist

    Montag, 15. Oktober 2012 21:21
  • Hallo,

    ich wage zu bezweifeln, dass sich da noch viel tun wird, da der SBS auslaufen wird. In der 2012-er Familie gibt es bekanntlich neben den "großen" (Standard und Datacenter) nur noch die Foundation und Essentials sowie den Storage Server, also stark zusammengestrichen die ehemals große Produktpalette.


    Guido Over MCITP Server Administrator 2008 & MCSA Windows 2008 & MCITP Enterprise Administrator 2008

    Dienstag, 16. Oktober 2012 06:05
  • @DAFotil

    So habe eine Lösung gefunden! Du must in der AD unter dem Attribut-Editor direkt die Dienstprinzipalnamen eingeben, nach einem Neustart vom HYPER-V geht dann das Verschieben der Maschinen ;-)

    Server 1:
    Hyper-V Replica Service/HYPER-V
    Hyper-V Replica Service/Hyper-V.deinedomain.local
    Microsoft Virtual System Migration Service/HYPER-V
    Microsoft Virtual System Migration Service/Hyper-V.deinedomain.local
    Microsoft Virtual Console Service/HYPER-V
    Microsoft Virtual Console Service/Hyper-V.deinedomain.local

    Server 2:
    Hyper-V Replica Service/HYPER-V-2
    Hyper-V Replica Service/Hyper-V-2.deinedomain.local
    Microsoft Virtual System Migration Service/HYPER-V-2
    Microsoft Virtual System Migration Service/Hyper-V-2.deinedomain.local
    Microsoft Virtual Console Service/HYPER-V-2
    Microsoft Virtual Console Service/Hyper-V-2.deinedomain.local

    Deine Einträge mit einem 2008R2 DC haben mich auf die Lösung gebracht! :-)


    Microsoft Certified IT Professional - Enterprise Administrator Microsoft Certified IT Professional - Server Administrator Microsoft Certified Systems Administrator Microsoft Certified IT Professional - Enterprise Support Technician Microsoft Certified Professional Microsoft Certified Technology Specialist

    Dienstag, 23. Oktober 2012 21:28
  • Danke Rene!

    Hat funktioniert...

    Mittwoch, 24. Oktober 2012 12:17
  • Stimmt, dass hatte ich auch schon getestet. Ist im Prinzip das gleiche Ergebnis als wenn der HyperV2012 über einen 2. DC die Einträge im AD des SBS registriert,
    ABER die Fehler am Hyperv2012 alle 2 Minuten bleiben und daher schon im Eintrag am 13.10.2012 18:26: "Die Frage bleibt, was dann nicht funktioniert, wo die Probleme liegen". Das Verschieben funktioniert aber die Fehler bleiben, sauber ist es nicht.

    Die einzig wirklich brauchbare Lösung ist einen zusätzlichen physischen 2. DC im Netz zu haben welchen die HyperV2012 fix als Anmeldeserver verwenden (oder eine eigene HyperV2012 Domäne) und somit von den HyperV2012 immer erreichbar ist oder wenn die HyperV2012 vollständige Server sind, alle HyperV2012 als sekundäre DC zu betreiben

    Donnerstag, 25. Oktober 2012 05:58
  • @DAFotil

    Da hast du Recht! Sauber ist es nicht, aber im Moment die einzige Lösung bis Microsoft ein Patch für den SBS 2011 raus bringt, wenn einer kommen sollte ...

    Replikation funktioniert und Verschieben geht auch. Fehler sind weiterhin da.


    MCP, MCSA, MCTS, MCITP, MCSA 2012, MCSE 2012, MCT2009, MCT2010, MCT2011, MCT2012


    • Bearbeitet Rene Wiedemann Donnerstag, 25. Oktober 2012 09:06 Wer Rechtschreibfehler findet darf diese behalten...
    • Als Antwort vorgeschlagen Klaus Hahn Dienstag, 2. Juli 2013 18:52
    • Nicht als Antwort vorgeschlagen Klaus Hahn Dienstag, 2. Juli 2013 18:52
    Donnerstag, 25. Oktober 2012 09:06
  • Hallo Zusammen,

    hat sich hier bis heute was getan?

    Ich würde gerne die 14050 Fehler aus den 2012 Server Event Logs entfernt haben.

    Gruß
    Klaus

    Dienstag, 2. Juli 2013 18:54
  • Hallo,

    ich hatte ebenfalls das oben beschriebene Problem, die Lösung hat mir auch weitergeholfen.
    Vielen Dank dafür!
    Die Replikation an sich funktioniert nun auch bei mir, allerdings gibt es Authentifizierungsprobleme, wenn ich ein geplantes Failover durchführen will.

    Funktioniert das geplante Failover in einer SBS 2011 Domain bei euch problemlos?
    Mir geht es darum das Problem abzugrenzen...

    Das eigentliche Problem ist hier beschrieben:
    http://social.technet.microsoft.com/Forums/windowsserver/en-US/af8704b3-6623-40ba-af78-567f69a9eca1/hyperv-2012-replication-planed-failover-failed-to-resolve-the-replica-server

    Wie dort zu lesen ist, wird der Domain-Suffix vergessen bei der Namensauflösung anzuhängen. Über einen Eintrag in der Host Datei habe ich die Domainnamen fest auf die IP's umgeleitet. Nun bekomme ich allerdings einen Authentifizierungsfehler.

    Dankeschön!

    Montag, 4. November 2013 16:55
  • Auch wenn ich jetzt den Uralt-Thread nochmal aufwärme.....

    Mir ist es grad auch passiert mit einem Windows Server 2016 als Testserver.

    Das Script nach https://support.microsoft.com/en-us/kb/2761899 hat aber sofort funktioniert, nichtmal ein reboot war nötig. Ich habe statt dem Anfangsport 9000 die 6000 genommen damit der Port 6005 des SBS mit im Bereich liegt. Und weils so gut lief auch grad noch mit einem Windows Server 2012 R2 Hyper-V getestet, läuft genauso gut.

    /Klaus

    • Als Antwort vorgeschlagen Lieb EDV Donnerstag, 4. Mai 2017 11:56
    Samstag, 13. Februar 2016 23:14
  • Perfekt Klaus. Habe auch schon ewig mit den Fehlern in einer SBS2011 Domäne gekämpft. Anfangsport im Skript auf 600 setzen hat nun endlich das Problem gelöst

    Danke!

    Sonntag, 10. März 2019 09:11