none
++ NIC Anbieterreihenfolger / VMQ / SR-IOV ++ RRS feed

  • Frage

  • Hallo,

    wir haben 2x Dell R730 mit Server 2012R2 als Hyper-V Host Cluster mit ca. 20 VM in Betrieb. Die Netzwerkkarten sind alle Broadcom 1Gb Karten, welche in Teams in folgender Konstellation laufen. Domäne 2x1GB, Hyper-V 4x1Gb und LM 2x1Gb). Aktuell ist VMQ und SR-IOV deaktiviert und RSS ist bei den VM auf "Numa Skalierung statisch" eingestellt.
    Das Storage ist per SAS direkt angebunden. Treiber und Firmware ist aktuell und Panda Endpoint wurden von beiden Hosts entfernt.

    Wir haben seit zwei Wochen Performance-Probleme. Es läuft alles, nur sehr langsam. Die Benutzer arbeiten auf 3 RDSH. Habt ihr Verbesserungsvorschläge?

    NIC Anbieterreihenfolge steht 1. "MS Windows-Netzwerk" 2. "MS Remotedesktop Hostserver Netzwerk Anbieter", passt das so?
    VMQ aktivieren, obwohl es nur 1Gb Karten sind?
    SR-IOV auf VSwitch und in VM aktivieren?

    Vielen Dank für Hinweise

    Montag, 20. Februar 2017 15:32

Antworten

Alle Antworten

  • Hallo Astra-Captain,

    an welcher stelle ist es hier denn langsam? sind die RDSHs langsam oder das allgemeine Netz (Datenverkehr).

    Was für einen Storage habt ihr dahinter, wie sieht es hier mit IOPs aus?

    Gruß

    Carsten


    http://www.ms-fabric.de/ Wenn Dir eine Forenantwort weiter geholfen hat dann markiere sie doch bitte als Antwort, dies hilft anderen bei der Lösung von Problemen! LG Carsten

    Montag, 20. Februar 2017 15:35
  • Hallo Carsten,

    das Arbeiten auf den jeweiligen RDSH ist sehr langsam. Anwendungen frieren ein, Reiter wechsel dauert lange.
    Dell MD3420 ist in Benutzung.

    Current IOs/sec 96
    Max IOs/sec 284
    Min IOs/sec 59
    Total IOs/sec 18938

    Gruß

    Jens

    Montag, 20. Februar 2017 16:19
  • VMQ bei 1 Gb würde ich außen vor lassen, wäre wahrscheinlich auch nicht der richtige Effekt. Du berichtest von Performance Problemen seit zwei Wochen. Der Verbund steht doch sicher schon länger und lief performanter, höre ich heraus. Darum jetzt Offload-Schrauben stellen, naja. Habt Ihr schon mal einen Perfmon angeschmissen und diverse Daten gesammelt, beispielsweise:

    Logischer Datenträger(*)\Mittlere Sek./Lesevorgänge
    Logischer Daten­träger(*)\Mitt­lere Sek./Schreibvorgänge

    CPU, RAM, CSV usw.

    Welche RAID Level liegen hier vor, prüfe die Storage Appliance (HDD Ausfälle, RAID degraded, etc.)

    Was bedeutet es läuft alles, nur sehr langsam? Wie macht sich das für die User bemerkbar. Diese Frage sollte eigentlich an den Anfang. <- Hat sich überschnitten


    https://www.windowspro.de/marcel-kueppers

    I write here only in private interest

    Disclaimer: This posting is provided AS IS with no warranties or guarantees, and confers no rights.



    Montag, 20. Februar 2017 16:29

  • Current IOs/sec 96
    Max IOs/sec 284
    Min IOs/sec 59
    Total IOs/sec 18938

    Womit misst Du hier die IOPS? Wo? Welche Blockgröße etc. Das geht alles nicht aus diesen Werten hervor.

    https://www.windowspro.de/marcel-kueppers

    I write here only in private interest

    Disclaimer: This posting is provided AS IS with no warranties or guarantees, and confers no rights.

    Montag, 20. Februar 2017 16:39
  • Der Verbund läuft seit Ende 10/2016 ohne Schwierigkeiten.
    Die genannten IOPs waren zu dem Zeitpunkt Momentaufnahmen aus dem Dell Powervault Modular Disk Storage Manager / Real-time Perf Mon.
    Host 1, 2x E5-2660 v2, 256GB RAM, 2x 300GB SSD als RAID1
    Host 2, 2x E5-2660 v2, 256GB RAM, 2x 300GB SSD als RAID1
    MD3420:
    RAID5 10k (ERP 2048GB, SYSTEM 3072GB, Quorum 1GB)
    RAID10 15k (3320GB Ex2016)
    Diskausfälle oder Rebuilds hatten wir seit Einführung 10/2016 nicht.

    Den Perfmon werde ich gleich anwerfen...

    Dienstag, 21. Februar 2017 08:23
  • Wie groß ist denn die CSV und wieviel VMs liegen dadrauf? Sind hier in der letzten Zeit einige hinzu gekommen?

    Gruß

    Carsten


    http://www.ms-fabric.de/ Wenn Dir eine Forenantwort weiter geholfen hat dann markiere sie doch bitte als Antwort, dies hilft anderen bei der Lösung von Problemen! LG Carsten

    Dienstag, 21. Februar 2017 08:32
  • Kontrolliere auch am CSV den Block Cache, doch zuvor sind ein paar Perfmon Werte wichtig:

    https://www.windowspro.de/marcel-kueppers/hyper-v-cluster-shared-volumes-anlegen-konfigurieren

    https://www.windowspro.de/marcel-kueppers

    I write here only in private interest

    Disclaimer: This posting is provided AS IS with no warranties or guarantees, and confers no rights.

    Dienstag, 21. Februar 2017 08:34
  • Hallo,

    in der Zwischenzeit wurde ein Controller der SAN, sowie ein SAS Anschlusskabel getauscht. Danach lief alles wieder stabil und performanter.
    Außerdem haben wir den Virenscanner von beiden Hosts deinstalliert.

    Grüße

    • Als Antwort markiert Astra-Captain Dienstag, 7. März 2017 13:02
    Dienstag, 7. März 2017 13:02
  • Danke für die Rückmeldung.

    Gruß,
    Marcel


    https://www.windowspro.de/marcel-kueppers

    I write here only in private interest

    Disclaimer: This posting is provided AS IS with no warranties or guarantees, and confers no rights.

    Dienstag, 7. März 2017 15:16