none
automatische antworten nicht für alle User setzbar / sichtbar RRS feed

  • Frage

  • Hallo,

    auf dem Exchange 2016 habe ich das Problem, dass ich nicht für alle User unter

    ECP -> anderer Benutzer -> E-mail organisieren -> automatische antworten

    finden kann. Der Button ist einfach nicht da.

    Bei vielen Usern finde ich nur noch "Zustellberichte", "Posteingangsregeln" ist auch nicht dabei.

    Zudem scheint nach dem Update von Ex13 auf Ex16 bei einigen Postfächern einfach die Quota verschwunden zu sein.

    Die Quota kann ich ja wieder herstellen, welcher Befehl oder welche Richtlinie mir die auto replies wiederherstellt, ist mir allerdings unbekannt.

    Kann mir jemand sagen, wie ich als Admin wieder die "automatische antworten" finde?

    Danke!

    Montag, 17. Dezember 2018 08:25

Antworten

  • Hi,

    hast du OWA Policies im Einsatz?
    Get-OwaMailboxPolicy

    Kann der Benutzer selber per OWA die Abwesenheit konfigurieren (gleicher Browser verwenden)?

    Wir hatten schon eine ähnliche Problematik, dann eher auf OWA bezogen, auch Browser spezifisch.
    Die Settings für OOF und Signaturen konnten nicht mehr modifiziert werden. Grund dafür war der Text, welcher per Copy/Paste aus anderen Programmen eingeführt wurde, und im Hintergrund schlecht formatierter HTML Code erzeugte. Mit einigen Browsern konnten die Settings noch bearbeitet werden, mit anderen Browsern sah man die Settings gar nicht mehr.

    Da könnte man die Texte mal löschen.

    Set-MailboxAutoReplyConfiguration -Identity user -InternalMessage $null
    Set-MailboxAutoReplyConfiguration -Identity user -ExternalMessage $null


    Georg


    Hallo Georg,

    Ich habe die Internal und External Messages mal genullt, jedoch brachte das keine Änderung.

    Verschiedene Browser habe ich schon getestet. Die User setzen die Abwesenheit per Outlook, nicht jeder hat die Berechtigung, OWA zu nutzen. Habe OWA bei einem User bei dem es nicht geht mal aktiviert, geht trotzdem nicht.

    Der User hat sich jetzt im OWA angemeldet und sieht die Einstellungen für Abwesenheit und kann sie auch setzen.

    Browser ECP habe ich schon FF, Chrome, IE und Edge getestet. Geht überall nicht :-(

    Owapolicy ist im Einsatz (kriege nur eine RunspaceID zurück, also nur eine existent?), nach welchem Wert müsste ich denn Ausschau halten?
    Mir würde nur das auf fallen: WebPartsFrameOptionsType                             : SameOrigin

    User bei dem es geht und einer bei dem es nicht geht sind in der selben Datenbank

    EDIT:

    Kommando zurück, plötzlich geht es. Ich versuche jetzt noch heraus zu finden, ob es am deaktivierten OWA lag oder an der Internal/External Msg

    Edit2: nach einigen Tests festgestellt, dass ich immer den Browser komplett schließen muss, sonst machen die sehr wirre Sachen (in einigen ist es da, in anderen nicht)

    Scheint eine Sache zu sein, ob OWA aktiviert ist oder nicht. Mit aktiven OWA kann ich die Einstellung setzen


    • Bearbeitet KrisTheMan Donnerstag, 20. Dezember 2018 13:34 info ergänzt
    • Als Antwort markiert KrisTheMan Donnerstag, 20. Dezember 2018 13:34
    Donnerstag, 20. Dezember 2018 13:16

Alle Antworten

  • Hi,

    zum Thema Quotas kann ich nur empfehlen die Quotas auf die Datenbanken zu setzen. Individuelle quotas für Benutzer sind unhandlich.

    Zum Thema Autoreply : Wie schauts denn aus wenn du über die Schell abfragst?


    Get-MailboxAutoReplyConfiguration -Identity a


    Montag, 17. Dezember 2018 12:17
  • zum Thema Quotas kann ich nur empfehlen die Quotas auf die Datenbanken zu setzen. Individuelle quotas für Benutzer sind unhandlich.

    ...das aber nur, wenn man alles  mit Bordmitteln verwaltet. Ab einer bestimmten Anzahl von Mailboxen sind 1. die Bordmitteln eh nicht mehr zu gebrauchen, und 2. kommen alle Entitlements wie Postfächer, Quotas usw. aus vorgelagerten Systemen, und da sind gerade Quotas auf Datenbanken unhandlich, denn eine Quota-Änderung bedeutet jedes Mal eine Postfach-Migration. Und dann wachsen Datenbanken mit großen Quotas auch noch überproportional...


    Evgenij Smirnov

    I work @ msg services ag, Berlin -> http://www.msg-services.de
    I blog (in German) @ http://it-pro-berlin.de
    my stuff in PSGallery --> https://www.powershellgallery.com/profiles/it-pro-berlin.de/
    Exchange User Group, Berlin -> https://exusg.de
    Windows Server User Group, Berlin -> http://www.winsvr-berlin.de
    Mark Minasi Technical Forum, reloaded -> http://newforum.minasi.com


    In theory, there is no difference between theory and practice. In practice, there is.

    Montag, 17. Dezember 2018 12:43
  • Evgenij,

    wie ist das zuverstehen

    ...."denn eine Quota-Änderung bedeutet jedes Mal eine Postfach-Migration."

    ich habe vor kurzen bei einigen Archivmailboxen die Quota verändert. Werden dadurch die Mailboxen migriert? 


    Chris

    Dienstag, 18. Dezember 2018 18:04
  • Nee, aber wenn Du Quota strikt per Datenbank vergibst wie der Kollege empfohlen hat, bedeutet eine Änderung des Quotas ja eine Verschiebung in eine andere Datenbank, wo das zukünftig zu geltende Quota gesetzt ist.

    Da stellen sich viele Fragen - wieviele verschiedene Quotas sind in solch einem Konstrukt überhaupt verwaltbar? Was passiert mit der Datenbankgröße, wenn ich viele große Mailboxen habe? usw. usw.

    Und Archiv-Quota kann man auf die Art und Weise schon gar nicht pflegen...


    Evgenij Smirnov

    I work @ msg services ag, Berlin -> http://www.msg-services.de
    I blog (in German) @ http://it-pro-berlin.de
    my stuff in PSGallery --> https://www.powershellgallery.com/profiles/it-pro-berlin.de/
    Exchange User Group, Berlin -> https://exusg.de
    Windows Server User Group, Berlin -> http://www.winsvr-berlin.de
    Mark Minasi Technical Forum, reloaded -> http://newforum.minasi.com


    In theory, there is no difference between theory and practice. In practice, there is.

    Dienstag, 18. Dezember 2018 18:11
  • Der Vorteil bei dem setzen von Quotas über die Datenbank besteht darin, das kein Benutzer "vergessen" wird und dann unendlich Platz hat.

    Ich handhabe das ganze so, dass ich Datenbanken für Normalbenutzer, Poweruser und VIP User habe. Wenn eine Datenbank irgendwann einmal zu voll wird mach ich einfach eine neue auf, die die gleichen Quotas hat. Beispielsweise VIP und VIP2.

    Eine änderung der Quota für einen einzelnen Benutzer beduetet dann tatsächlich eine Postfachmigration. Das ist ein Aufwand von 5 Minuten get-Mailbox | new-moverequest.

    Kann schon sein das dieses Konstrukt irgendwann unhandlich werden kann und man mit Boardmitteln da nicht mehr klar kommt. Ich habe aktuell Knapp 8K Mailboxen und habe keine da (noch) keine Probleme.

    Aber viele Wege führen zum Römer - ich bin dennoch der Meinung das das Setzen von Qoutas auf einzelne Mailboxen seine Schattenseiten haben kann...

    Mittwoch, 19. Dezember 2018 07:08
  • Hi,

    zum Thema Quotas kann ich nur empfehlen die Quotas auf die Datenbanken zu setzen. Individuelle quotas für Benutzer sind unhandlich.

    Zum Thema Autoreply : Wie schauts denn aus wenn du über die Schell abfragst?


    Get-MailboxAutoReplyConfiguration -Identity a


    Hi,


    sorry für die späte antwort :-)

    also wenn ich Get-MailboxAutoReplyConfiguration ausführe auf ein entsprechendes Konto, bei dem in ECP die Buttons nicht da sind, bekomme ich die passenden Informationen zurück. Ich sehe jetzt auch zu einem Konto, bei dem im ECP die Buttons da sind,  keine Unterschiede (von der ExternalAudience, ExternalMessage und InternalMessage mal abgesehen)

    Hier mal die Ausgabe bereinigt

    geht

    RunspaceId                       : eineID
    AutoDeclineFutureRequestsWhenOOF : False
    AutoReplyState                   : Disabled
    CreateOOFEvent                   : False
    DeclineAllEventsForScheduledOOF  : False
    DeclineEventsForScheduledOOF     : False
    EventsToDeleteIDs                :
    EndTime                          : 12/20/2018 9:00:00 AM
    ExternalAudience                 : All
    ExternalMessage                  : externe abwesenheitsnachricht
    InternalMessage                  : interne abwesenheitsnachricht
    DeclineMeetingMessage            :
    OOFEventSubject                  :
    StartTime                        : 12/19/2018 9:00:00 AM
    MailboxOwnerId                   : Bestimmer Nutzer1
    Identity                         : Bestimmer Nutzer1
    IsValid                          : True
    ObjectState                      : Unchanged



    geht nicht

    RunspaceId                       : eineID
    AutoDeclineFutureRequestsWhenOOF : False
    AutoReplyState                   : Disabled
    CreateOOFEvent                   : False
    DeclineAllEventsForScheduledOOF  : False
    DeclineEventsForScheduledOOF     : False
    EventsToDeleteIDs                :
    EndTime                          : 12/20/2018 9:00:00 AM
    ExternalAudience                 : None
    ExternalMessage                  : externe abwesenheitsnachricht
    InternalMessage                  : interne abwesenheitsnachricht
    DeclineMeetingMessage            :
    OOFEventSubject                  :
    StartTime                        : 12/19/2018 9:00:00 AM
    MailboxOwnerId                   : Bestimmer Nutzer2
    Identity                         : Bestimmer Nutzer2
    IsValid                          : True
    ObjectState                      : Unchanged

    das mit der Quota hab ich rausgefunden, warum auch immer hat die Mailbox Database (nur eine von 3) die Einstellungen zurück auf unlimited gesetzt.


    Mittwoch, 19. Dezember 2018 08:59
  • Okay, das bedeutet ja zumindest schonmal das die Berechtigung in beiden Fällen da ist. Sehen die Benutzer selbst die Autoreply Einstellungen wenn sie im OWA angemeldet sind?
    Mittwoch, 19. Dezember 2018 10:09
  • Hi,

    hast du OWA Policies im Einsatz?
    Get-OwaMailboxPolicy

    Kann der Benutzer selber per OWA die Abwesenheit konfigurieren (gleicher Browser verwenden)?

    Wir hatten schon eine ähnliche Problematik, dann eher auf OWA bezogen, auch Browser spezifisch.
    Die Settings für OOF und Signaturen konnten nicht mehr modifiziert werden. Grund dafür war der Text, welcher per Copy/Paste aus anderen Programmen eingeführt wurde, und im Hintergrund schlecht formatierter HTML Code erzeugte. Mit einigen Browsern konnten die Settings noch bearbeitet werden, mit anderen Browsern sah man die Settings gar nicht mehr.

    Da könnte man die Texte mal löschen.

    Set-MailboxAutoReplyConfiguration -Identity user -InternalMessage $null
    Set-MailboxAutoReplyConfiguration -Identity user -ExternalMessage $null


    Georg


    • Bearbeitet fgeo-ch Mittwoch, 19. Dezember 2018 10:14
    Mittwoch, 19. Dezember 2018 10:13
  • Hi,

    hast du OWA Policies im Einsatz?
    Get-OwaMailboxPolicy

    Kann der Benutzer selber per OWA die Abwesenheit konfigurieren (gleicher Browser verwenden)?

    Wir hatten schon eine ähnliche Problematik, dann eher auf OWA bezogen, auch Browser spezifisch.
    Die Settings für OOF und Signaturen konnten nicht mehr modifiziert werden. Grund dafür war der Text, welcher per Copy/Paste aus anderen Programmen eingeführt wurde, und im Hintergrund schlecht formatierter HTML Code erzeugte. Mit einigen Browsern konnten die Settings noch bearbeitet werden, mit anderen Browsern sah man die Settings gar nicht mehr.

    Da könnte man die Texte mal löschen.

    Set-MailboxAutoReplyConfiguration -Identity user -InternalMessage $null
    Set-MailboxAutoReplyConfiguration -Identity user -ExternalMessage $null


    Georg


    Hallo Georg,

    Ich habe die Internal und External Messages mal genullt, jedoch brachte das keine Änderung.

    Verschiedene Browser habe ich schon getestet. Die User setzen die Abwesenheit per Outlook, nicht jeder hat die Berechtigung, OWA zu nutzen. Habe OWA bei einem User bei dem es nicht geht mal aktiviert, geht trotzdem nicht.

    Der User hat sich jetzt im OWA angemeldet und sieht die Einstellungen für Abwesenheit und kann sie auch setzen.

    Browser ECP habe ich schon FF, Chrome, IE und Edge getestet. Geht überall nicht :-(

    Owapolicy ist im Einsatz (kriege nur eine RunspaceID zurück, also nur eine existent?), nach welchem Wert müsste ich denn Ausschau halten?
    Mir würde nur das auf fallen: WebPartsFrameOptionsType                             : SameOrigin

    User bei dem es geht und einer bei dem es nicht geht sind in der selben Datenbank

    EDIT:

    Kommando zurück, plötzlich geht es. Ich versuche jetzt noch heraus zu finden, ob es am deaktivierten OWA lag oder an der Internal/External Msg

    Edit2: nach einigen Tests festgestellt, dass ich immer den Browser komplett schließen muss, sonst machen die sehr wirre Sachen (in einigen ist es da, in anderen nicht)

    Scheint eine Sache zu sein, ob OWA aktiviert ist oder nicht. Mit aktiven OWA kann ich die Einstellung setzen


    • Bearbeitet KrisTheMan Donnerstag, 20. Dezember 2018 13:34 info ergänzt
    • Als Antwort markiert KrisTheMan Donnerstag, 20. Dezember 2018 13:34
    Donnerstag, 20. Dezember 2018 13:16
  • Okay, das bedeutet ja zumindest schonmal das die Berechtigung in beiden Fällen da ist. Sehen die Benutzer selbst die Autoreply Einstellungen wenn sie im OWA angemeldet sind?

    ja, die sehen Sie, wenn bei dem User OWA denn aktiviert ist.

    siehe auch die andere Antwort an Georg
    Leider scheint man nicht multiple Zitate auswählen zu können, muss man extra posten O_o

    Donnerstag, 20. Dezember 2018 13:17
  • Hi,

    hast du OWA Policies im Einsatz?
    Get-OwaMailboxPolicy

    Kann der Benutzer selber per OWA die Abwesenheit konfigurieren (gleicher Browser verwenden)?

    Wir hatten schon eine ähnliche Problematik, dann eher auf OWA bezogen, auch Browser spezifisch.
    Die Settings für OOF und Signaturen konnten nicht mehr modifiziert werden. Grund dafür war der Text, welcher per Copy/Paste aus anderen Programmen eingeführt wurde, und im Hintergrund schlecht formatierter HTML Code erzeugte. Mit einigen Browsern konnten die Settings noch bearbeitet werden, mit anderen Browsern sah man die Settings gar nicht mehr.

    Da könnte man die Texte mal löschen.

    Set-MailboxAutoReplyConfiguration -Identity user -InternalMessage $null
    Set-MailboxAutoReplyConfiguration -Identity user -ExternalMessage $null


    Georg


    Hallo Georg,

    Ich habe die Internal und External Messages mal genullt, jedoch brachte das keine Änderung.

    Verschiedene Browser habe ich schon getestet. Die User setzen die Abwesenheit per Outlook, nicht jeder hat die Berechtigung, OWA zu nutzen. Habe OWA bei einem User bei dem es nicht geht mal aktiviert, geht trotzdem nicht.

    Der User hat sich jetzt im OWA angemeldet und sieht die Einstellungen für Abwesenheit und kann sie auch setzen.

    Browser ECP habe ich schon FF, Chrome, IE und Edge getestet. Geht überall nicht :-(

    Owapolicy ist im Einsatz (kriege nur eine RunspaceID zurück, also nur eine existent?), nach welchem Wert müsste ich denn Ausschau halten?
    Mir würde nur das auf fallen: WebPartsFrameOptionsType                             : SameOrigin

    User bei dem es geht und einer bei dem es nicht geht sind in der selben Datenbank

    EDIT:

    Kommando zurück, plötzlich geht es. Ich versuche jetzt noch heraus zu finden, ob es am deaktivierten OWA lag oder an der Internal/External Msg

    Edit2: nach einigen Tests festgestellt, dass ich immer den Browser komplett schließen muss, sonst machen die sehr wirre Sachen (in einigen ist es da, in anderen nicht)

    Scheint eine Sache zu sein, ob OWA aktiviert ist oder nicht. Mit aktiven OWA kann ich die Einstellung setzen

    OWA für den User aktivieren war die Lösung bei mir. Vielen Dank



    Mittwoch, 24. April 2019 12:07