none
DNS Revers Lookup Probleme RRS feed

  • Frage

  • Hallo,

    ich habe einen Exchange Server 2013 aufgesetzt, hab in in eine Domäne integriert. Leider kann ich keine Mails versenden, da ich diese Meldung bekomme: reverse DNS problem 527 

    Der Server meldet sich als exchange.sam01.local, schätz aber er sollte sich als exchange.sam-architekten.de melden, da der mx Eintragsam-architekten heißt.

    Oder hab ich da einen Denkfehler. Was muss ich im DNS einstellen, dass es funktioniert?

    Mittwoch, 15. Juli 2015 09:17

Antworten

  • ich verstehe dich nicht falsch :)

    Reverse = ip in Namen umwandeln

    forward = Name in ip umwandeln

    du kannst/solltest jetzt 2 Dinge tun:

    den Connectoren in deinem Exchange sagen sie sollen sich mit .de und nicht mit .local melden

    UND dennoch den Reverse dns Eintrag aquivavelt zu deinem mx Record setzen (lassen)



    was grad deine Fehlermeldung verursacht ist; der Server an den du ne Mail schickst sieht die ip von dem die Mail kommt. macht eine Reverse abfrage:
    heißt er versucht die ip in einen Namen zu verwandeln und gleicht das wiederum damit ab, wie dein exchange Server sich meldet. als Antwort je nach Provider bekommt er sowas wie "Static-ipadresse.provider.de" oder sowas.

    das stimmt natürlich nicht mit dem überein, was dein Exchange behauptet zu sein :-)
    als Fazit kurz gesagt musst du also darauf achten das alles an und für sich übereinstimmt:
    - mx = das was der Exchange im empfangsconnector auch antwortet
    - ip Reverse Auflösung = was im mx steht


    und wenn du schon aktiv beim dns eintrage setzen bist kannst du auch einen spf-Record setzen. das ist quasi das Gegenstück zum mx.
    dieser Record listet alle Mailserver für deine Domain auf, denen es erlaubt ist im Namen deiner Domain Mails zu schreiben.
    besonders wichtig, wenn du Ausgehende Mails über einen smarthost leitest
    es gibt spam Filter Mechanismen die Fragen einen sogenannten spf ab.
    alle Microsoft mailkonten machen das zum Beispiel. da landet man ohne im spam Ordner.

    Ich bin viel mobil unterwegs. Verzeiht die manchmal mangelnde Rechtschreibung. :-)


    Mittwoch, 15. Juli 2015 17:08

Alle Antworten

  • Moin,

    wenn du Split-DNS verwendest, sollte der MX usw. auflösbar sein.

    Du kannst auch einstellen, das er für externe Mails eine externe DNS-Auflösung verwenden soll.

    ;)


    Gruß Norbert

    Mittwoch, 15. Juli 2015 09:28
    Moderator
  • Moin,

    wie der Exchange sich meldet (domain.local oder domain.tld) stellst du am Exchange ein.

    Wichtig ist nur, dass wenn er sich als domain.tld meldet, du auch genau diesen Eintrag besitzt:

    bsp:

    Exchange meldet sich als "mail.firma.de", dann musst du zu deinem DNS Server gehen der für firma.de (meist beim Domainprovider) zuständig ist und einen Eintrag mail.firma.de setzen, der auf deine Public IP zeigt.

    ggf. solltest du noch zu deinem Leitungsprovider gehen und für die IP die du bekommen hast (hoffentlich statisch) den Reverse DNS mail.firma.de beantragen.

    Damit du vorwärts wie rückwärts eine bindung zwischen mail.firma.de <---> xxx.xxx.xxx.xxx (IP) hast.

    Exchange Zertifikat muss natürlich dementsprechend passen.


    Ich bin viel mobil unterwegs. Verzeiht die manchmal mangelnde Rechtschreibung. :-)

    Mittwoch, 15. Juli 2015 10:45
  • Danke Teste ich gleich. Der Domain name zeigt schon auf die IP ;-)
    Mittwoch, 15. Juli 2015 11:41
  • Sehr gut. dann musst du im Umkehrschluss nur noch Fürsorge tragen, dass die IP auch auf den Namen zeigt :-)


    Ich bin viel mobil unterwegs. Verzeiht die manchmal mangelnde Rechtschreibung. :-)

    Mittwoch, 15. Juli 2015 12:28
  • Blöde Frage, wo stell ich das ein?
    Mittwoch, 15. Juli 2015 12:38
  • Moin,

    wie der Exchange sich meldet (domain.local oder domain.tld) stellst du am Exchange ein.

    Wichtig ist nur, dass wenn er sich als domain.tld meldet, du auch genau diesen Eintrag besitzt:

    bsp:

    Exchange meldet sich als "mail.firma.de", dann musst du zu deinem DNS Server gehen der für firma.de (meist beim Domainprovider) zuständig ist und einen Eintrag mail.firma.de setzen, der auf deine Public IP zeigt.

    ggf. solltest du noch zu deinem Leitungsprovider gehen und für die IP die du bekommen hast (hoffentlich statisch) den Reverse DNS mail.firma.de beantragen.

    Damit du vorwärts wie rückwärts eine bindung zwischen mail.firma.de <---> xxx.xxx.xxx.xxx (IP) hast.

    Exchange Zertifikat muss natürlich dementsprechend passen.


    Ich bin viel mobil unterwegs. Verzeiht die manchmal mangelnde Rechtschreibung. :-)

    Das kannst du in den meisten Fällen nicht selbst machen.

    Musst du beim Provider machen (lassen)


    Ich bin viel mobil unterwegs. Verzeiht die manchmal mangelnde Rechtschreibung. :-)

    Mittwoch, 15. Juli 2015 12:42
  • Ich glaube du verstehst mich falsch, der MX eintrag und der Hsot Name zeigt schon auf die öffentliche IP.

    Wenn ich von dem Exchange Server eine Email verschicken will, kommt fehler zurück vom Empfänger Mail Server: 527-ICIR27 - sender IP reverse DNS problem 527

    wenn ich ein telnet auf den Exchange auf Port 25 und ein helo abschicke, medlet sich der Server mit exchange.exampel.local, aber wenn ich es richtig verstehe müsste er sich doch mit exchange.firma-firman.de melden, da die Email Adressen test@firma-firman.de (beispiel) lauten.

    Wo kann ich es umstellen,. dass der Exchange sich mit dem richtigen namen meldet?

    Mittwoch, 15. Juli 2015 12:56
  • ich verstehe dich nicht falsch :)

    Reverse = ip in Namen umwandeln

    forward = Name in ip umwandeln

    du kannst/solltest jetzt 2 Dinge tun:

    den Connectoren in deinem Exchange sagen sie sollen sich mit .de und nicht mit .local melden

    UND dennoch den Reverse dns Eintrag aquivavelt zu deinem mx Record setzen (lassen)



    was grad deine Fehlermeldung verursacht ist; der Server an den du ne Mail schickst sieht die ip von dem die Mail kommt. macht eine Reverse abfrage:
    heißt er versucht die ip in einen Namen zu verwandeln und gleicht das wiederum damit ab, wie dein exchange Server sich meldet. als Antwort je nach Provider bekommt er sowas wie "Static-ipadresse.provider.de" oder sowas.

    das stimmt natürlich nicht mit dem überein, was dein Exchange behauptet zu sein :-)
    als Fazit kurz gesagt musst du also darauf achten das alles an und für sich übereinstimmt:
    - mx = das was der Exchange im empfangsconnector auch antwortet
    - ip Reverse Auflösung = was im mx steht


    und wenn du schon aktiv beim dns eintrage setzen bist kannst du auch einen spf-Record setzen. das ist quasi das Gegenstück zum mx.
    dieser Record listet alle Mailserver für deine Domain auf, denen es erlaubt ist im Namen deiner Domain Mails zu schreiben.
    besonders wichtig, wenn du Ausgehende Mails über einen smarthost leitest
    es gibt spam Filter Mechanismen die Fragen einen sogenannten spf ab.
    alle Microsoft mailkonten machen das zum Beispiel. da landet man ohne im spam Ordner.

    Ich bin viel mobil unterwegs. Verzeiht die manchmal mangelnde Rechtschreibung. :-)


    Mittwoch, 15. Juli 2015 17:08
  • Okay, danke, das Problem ist, ich habe ja schon im Sendekonector eingesellt, dass er sich als mail.firma.de melden soll, meldet sich aber immer noch als .local... das kapier ich halt ned, warum er das trotzdem macht
    Donnerstag, 16. Juli 2015 11:20
  • Moin,

    wer meldet sich mit .local der Send - oder der Receive?

    Wie prüfst du das?

    Man kann beide Meldungen ändern...

    ;)


    Gruß Norbert

    Donnerstag, 16. Juli 2015 11:45
    Moderator
  • Du musst das im empfangsconnector definieren.

    Denn der Server an den du schickst macht die abfrage an deinem Server. Die Antwort erhält er dann von deinem Empfangsconnector, der mit "mail.firma.local" antwortet.

    Ich würde es auch schön finden, wenn du auf die Tips die man gibt eingehen würdest. In der Regel bekommst du hier Antworten von Menschen, die wissen was Sie erzählen.

    So kann ich nur mutmaßen, ob du meine empfohlenen Schritte durchgeführt hast und das Problem immernoch existent ist oder nicht.

    Dein Problem hätte quasi gestern schon gelöst sein können ;)


    Ich bin viel mobil unterwegs. Verzeiht die manchmal mangelnde Rechtschreibung. :-)


    Donnerstag, 16. Juli 2015 12:07
  • Ok,

    sorry, also ich habe es im Empfangconnecter geändert und im Sende... in mail.firma.de so meldet sich auch der MX eintrag unter nslookup und so meldet sich der alte Notes Server.

    Stimmt, da könnte auch ein Fehler sein, ein Denkfehler von mir, ich prüfe es mit telnet port 25.... und dann helo

    oder dass ich email raussende und der meldet mir ja, was in meiner Mail als Server steht. Blöde Frage, es gibt ja viele empfangsconnectoren, welcher ist der wichtigste, ist es normal, dass ich die meisten nicht ändern kann, da er meint, den Namen darf man nicht ändern

    Donnerstag, 16. Juli 2015 13:00
  • Du sollst ja auch nicht den Namen ändern, sondern den HELO /EHLO für den Connector.

    Send:
    http://blog.mreza.info/post/2008/10/27/pow-4-send-connector-external-fqdn-in-helo-ehlo-banner.aspx

    Receive:
    https://technet.microsoft.com/de-de/library/bb124740%28v=exchg.150%29.aspx

    Wobei der sich gemäß RFC mit dem Namen des MX / PTR melden sollte

    ;)

    Das hat aber alles eigentlich nichts mit deinem Ursprungs-Post zu tun?


    Gruß Norbert



    Donnerstag, 16. Juli 2015 13:11
    Moderator
  • Hallo,

    danke, ich meinte ja auch, das ich den Helo geändert habe, aber auch das geht nicht bei allen Empfangsconnectoren, ich werde jetzt mal das system, was zum glück nicht produktiv ist (vorerst) gerade ziehen und werde mich melden. auf alle fälle mal vielen dank für eure Hilfe

    Donnerstag, 16. Juli 2015 13:22
  • Moin,

    du hast nur einen Empfangsconnector für das Internet, die anderen sind intern.

    Wie viele hast du denn? (Screenshot)

    Und ich kann es nur noch mal wiederholen - wenn das mal eine Produktiv-Umgebung werden soll, hole dir einen Dienstleister dazu!

    ;)


    Gruß Norbert

    Donnerstag, 16. Juli 2015 14:13
    Moderator
  • nicht vergessen hilfreiche beiträge und die Lösung zu markieren. ;)

    Ich bin viel mobil unterwegs. Verzeiht die manchmal mangelnde Rechtschreibung. :-)

    Donnerstag, 16. Juli 2015 16:08