none
Migration Windows Server 2012 auf Windows Server 2012 R2 schlägt fehl RRS feed

  • Frage

  • Hallo,

    ich habe einen "Windows Server 2012 Essentials" umgestellt auf "Windows Server 2012 Standard". Soweit so gut.
    Jetzt soll dieser Server auf "Windows Server 2012 R2" aktualisiert werden. Das ADPREP lief problemlos durch.
    Starte ich das Setup, werden ich nach dem Lizenz-Key gefragt und dann läuft dieses auch los, jedoch stoppt es plötzlich.
    Im Seutupact.log habe ich folgende Fehlermeldung gefunden:

    2016-04-01 03:58:11, Warning    [0x0803db] MIG    IndirectKeyMapper: RegLoadKey(HKEY_USERS,S-1-5-21-4119957046-4156035964-1225351571-1115 (1),C:\Users\Wa) failed; giving up (32)
    2016-04-01 03:58:11, Error      [0x08039d] MIG    Cannot add mapping for user profile C:\Users\Admin.002. Error: 32: Win32Exception: Der Prozess kann nicht auf die Datei zugreifen, da sie von einem anderen Prozess verwendet wird. [0x00000020] __cdecl Mig::CIndirectKeyMapper::CIndirectKeyMapper(class UnBCL::String *,struct HKEY__ *,class UnBCL::String *,class UnBCL::String *,int,int,const Mig::HiveLoadRetryOptions *)[gle=0x000000cb]
    2016-04-01 03:58:11, Error      [0x080801] MIG    User profile loading error. Aborting due to external request.[gle=0x000000cb]
    2016-04-01 03:58:11, Warning    [0x0803de] MIG    Failed to unload hive at HKEY_LOCAL_MACHINE\$ONLINE_RW$ELAM (error 1314)
    2016-04-01 03:58:11, Warning    [0x0809d4] MIG    Failed to close keymapper 'ELAM': error 1314
    2016-04-01 03:58:11, Warning    [0x0803de] MIG    Failed to unload hive at HKEY_LOCAL_MACHINE\$ONLINE_RW$ELAM (error 1314)
    2016-04-01 03:58:11, Error                        MigStartupOnline caught exception: Win32Exception: User profile loading error. Aborting due to external request.: Der angegebene Benutzer hat kein g�ltiges Profil. [0x000004E5] void __cdecl Mig::COnlineWinNTPlatform::ProcessUser(class Mig::CRegistryDataStore *,class Mig::CRegistryDataUnit *,class UnBCL::String *,class UnBCL::String *,int,int)
    2016-04-01 03:58:11, Info                         Leaving MigStartupOnline method
    2016-04-01 03:58:11, Error                 MIG    pDoOnlineGather: Engine initialization failed with error: 0x00000004
    2016-04-01 03:58:11, Error      [0x0800ad] MIG    Callback_GatherOldSys: Migration phase failed.

    Auch mit einem anderen User bekomme ich diese Fehlermeldung.
    Was mache ich falsch? Ich installiere von einem lokalen Verzeichnis, auf dem die R2-Install CD kopiert ist.
    Das die "ntuser.dat" im Zugriff ist, ist aus meiner Sicht logisch. Kann das aber der Grund sein, weshalb die Installation scheitert?
    Wenn ja, wie soll man dann installieren?

    Der Server hat die Rollen:
    AD
    AD-CA
    DNS
    DHCP
    RAS-VPN
    Remote Desktop Apps

    Vielen Dank




     
    Freitag, 1. April 2016 10:49

Antworten

  • Das Problem ist gelöst:
    Für die Remote Desktop Apps war der Server so konfiguriert, dass die Benutzerprofile auf virtuellen Disk gespeichert werden. Diese Funktion muss deaktiviert werden (über den Servermanager).
    Danach mit dem "Build IN" Admin anmelden (ACHTUNG: Mit einem temporären Benutzerprofil funktioniert es nicht!). Danach habe ich wie bei einem "Inplace Upgrade" verfahren.
    Freitag, 1. April 2016 18:10

Alle Antworten

  • das sieht mir nach einem inplace upgrade und nicht nach einer migration aus die du da versuchst.

    Ich denke wie du es versuchst, wirst du es nicht hinbekommen.

    Du wirst dir einen 2. Windowsserver parallel stellen müssen und deine Dienste sauber migrieren müssen.


    Ich bin viel mobil unterwegs. Verzeiht die manchmal mangelnde Rechtschreibung. :-)

    Freitag, 1. April 2016 12:03
  • Hmmm ... Wenn ich die TechNet Artikel richtig verstehe, sollte es aber eigentlich so funktionieren.
    Meine "früheren" Windows Server habe ich alle so migriert. Deswegen wundert es mich ja, dass ich jetzt diese Probleme habe ....
    Freitag, 1. April 2016 13:46
  • Das Problem ist gelöst:
    Für die Remote Desktop Apps war der Server so konfiguriert, dass die Benutzerprofile auf virtuellen Disk gespeichert werden. Diese Funktion muss deaktiviert werden (über den Servermanager).
    Danach mit dem "Build IN" Admin anmelden (ACHTUNG: Mit einem temporären Benutzerprofil funktioniert es nicht!). Danach habe ich wie bei einem "Inplace Upgrade" verfahren.
    Freitag, 1. April 2016 18:10