none
Windows Server 2008 R2 - x64 und x86 Druckertreiber installieren RRS feed

  • Allgemeine Diskussion

  • Hallo,

    ich habe auf Windows Server 2008 R2 zwei Drucker hinzugefügt. Dies funktioniert auch ohne Probleme und der x64 Treiber wurde direkt angenommen.

    Wenn ich allerdings einen x86 Treiber von einem x86 Clienten installieren möchte, tritt folgende Fehlermeldung auf:

    "Der Treiber Lexmark C772 PS (MS), x86, Typ 3 - Benutzermodus konnte nicht installiert werden. Dieser Vorgang wird nicht unterstützt"

    Bei dem zweitem Drucker werden anfangs noch Treiberdaten kopiert, allerdings tritt nach kurzer Zeit die selbe Fehlermeldung auf:

    "Der Treiber Brother DCP-6690CW Printer, x86, Typ 3 - Benutzermodus konnte nicht installiert werden. Dieser Vorgang wird nicht unterstützt"

     

    Ich habe schon viele verschiedene Treiber getestet. Leider brachten diese auch keinen Erfolg. Google konnte mir auch nicht weiterhelfen.

    Habt ihr noch eine Lösung für mich?

     

    Danke im voraus.

     

    Montag, 20. Juni 2011 15:07

Alle Antworten

  • Hallo,

    möchstest du die Treiber am Client installieren oder möchtest du über den Client den Treiber auf dem Server hinterlegen?
    (was ja auch möglich ist)

    Montag, 20. Juni 2011 15:19
  • Ich möchte den Treiber vom Client auf dem Server installieren.
    Montag, 20. Juni 2011 15:22
  • Versuche einmal den Treiber direkt am Server zu hinterlegen,
    (als zusätzlicher Treiber in den Freigabeeigenschaften des Druckers).

    Wichtig ist, dass sowohl der x64 als auch der x86 Treiber die folgenden Eigenschaften besitzen:

    - gleiche Version
    - gleicher Druckername in den inf-Dateien des Treibers
    - gleicher Treibertyp (z.B. PCL6 ..)

    Montag, 20. Juni 2011 20:31
  • Hallo, ich glaube der folgende Artikel könnte Dir die Lösung bringen:

     

    http://technikblog.rachfahl.de/technik/windows-server-2008-r2-als-druckserver-client-druckertreiber/

     

    Gruß
    Armin

    Dienstag, 21. Juni 2011 06:53
  • So haben wir es auch gemacht. Lexmark war zwischenzeitlich etwas tränig, was x64 überhaupt und Windows-7-Treiber im Speziellen angeht. Unsere NAleitung dazu sieht so aus:

    1. Man benötigt erstmal die neusten Treiber des Druckers für das Server- und das Client-Betriebssystem (also z.B. den Treiber für Windows 2003 R2 x64 und Windows XP Pro x86)
    2. Die Installation des Server-Druckertreibers (x64) läuft ganz normal über das Setup.
    3. Den Windows XP Pro Treiber entpackt man entweder direkt in einem Verzeichnis auf dem Server oder muss die Installationsdatei - wegen Inkompatibilität - kurzfristig auf einem XP-Client entpacken und sich dort aus dem TEMP-Verzeichnis oder Installationsverzeichnis kopieren.
    4. Im Eigenschaftsdialog des Druckers auf dem Server wählt man nun (s.o.) "Zusätzliche Treiber" aus, macht einen Hacken bei "x86 - Windows XP, 98, 2000" und wird dann gefragt, wo sich die *.inf (Installations-INI) für den Treiber befindet. Man verweist auf den Ordner mit den x86 Windows XP Pro-Treibern. Die Installation beginnt ...
    5. .... und stoppt jäh, weil die Datei "ntprint.inf" fehlt. Bitte den Dialog genau lesen. Wahrscheinlich möchte die Server-Installation die "ntprint.inf" des entsprechenden Server-x86-Betriebssystems haben, also in unserem Beispiel die "ntprint.inf" auf der Windows 2003 R2 x86-CD. Diesen Datenträger einlegen und weiter geht es. (Bei x64-Treibern ist es wahrscheinlich wieder die Server-CD x64; bei 2008 x86 oder x64 die entsprechene DVD).
      Hintergrund: Die "ntprint.inf" ist keine Treiberdatei, sondern die Basisdruckerinstallationsdatei des Serverbetriebssystems. Die "ntprint.inf" der x86 ist auf der x64-Server-Installation nicht vorhanden, wird aber zur Bereitstellung des Treibers für die XP-Clients (x86) benötigt. Deshalb wird sie nachinstalliert.
    6. Die Installation läuft zuende. Der Treiber wird nun auch für Clients ohne Nachfrage nach Treibern über den Befehl "Verbinden" in der Netzwerkumgebung hinzugefügt.

     

    (Ist also fast so wie unter Armins Link beschrieben.)

     

    Gruß,

    H.

    Dienstag, 21. Juni 2011 12:10
  • Hallo,

    haben die Tipps weitergeholfen?

    Gruss,
    Raul

    Donnerstag, 23. Juni 2011 14:21
  • Hallo!

    Ich habe nach einigen Muehen am Freitag den aktuellen Lexmark Universaltreiber 2.1.1
    auf einem Windows 2008 R2- Printserver installiert.
    Unsere User-PCs sind mit Windows XP SP3 x86 installiert, so dass noch eine
    x86-Treibervariante bereitgestellt werden muesste.

    1) Mir fiel leider erst spaet auf, dass vom alten 1.4er-Universaltreiber von Lexmark
    auf diesem Server nur die x64-Variante vorhanden ist - die User aber die Drucker
    trotzdem problemlos einbinden koennen.
    Beim Test zeigte sich dann auch prompt, dass es offenbar genuegt, auf dem Server
    den x64-Treiber von Lexmark zu installieren, welcher anscheinend 'im Schlepptau'
    auch die x86-Variante mitbringt!

    2) Beim Versuch, den x86-Treiber explizit einzubinden, stiess ich auch immer wieder
    auf die Aufforderung, aus einem i386-Verzeichnis eine Datei bereitzustellen.
    Wie so viele andere versuchte ich es mit verschiedenen Quellen - bis mich ein
    beilaeufiger Hinweis des Lexmark- Supports auf die einfache Loesung brachte: Im
    (entpackten) Treiberpaket ist auch ein solcher i368-Ordner enthalten und mit dem
    klappte es dann auch sofort!
    Nun habe ich auf dem Printserver den x64- und den x86- Treiber in der Version 2.1.1
    (Ich verweise aber nochmals auf Punkt 1: Mir scheint, dass dies bei diesem Treiber
    von Lexmark gar nicht erforderlich ist).

    Gruesse

    Bernd Leutenecker
    Montag, 26. September 2011 21:09