none
Outlook 2010 benutzerdefinierte Formulare mit VBScript laufen nicht RRS feed

  • Frage

  • Hallo in die Runde,

    im September hat es ja durch das Security Update für Outlook eine Veränderung für eigene Formular mit integrierten Scripten gegeben.

    Wir haben die dazu passenden Registry-Schlüssel auch wie folgt angepasst:

    [HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Office\14.0\Outlook\Forms\TrustedFormScriptList]
    "IPM.Note"=""
    "IPM.Note.Urlaubsantrag"=""

    [HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Office\14.0\Outlook\Security]
    "DisableCustomFormItemScript"=dword:00000000

    Leider funktionieren die Scripte immer noch nicht richtig.

    Wird das Script in die Bibliothek für Persönliche Formular veröffentlicht, so laufen die Scripte. Wird das Formular aus einem freigegebenen Ordern geöffnet, so wird kein Script ausgeführt. Fehlermeldungen werden nicht ausgegeben.

    In den E-Mail-Sicherheitsoptionen sind beide Optionen für "Script in Ordnern" aktiviert.

    Ich habe mal einen Procmon mitlaufen lassen und sehe auch, dass das RegElement "DisableCustomFormItemScript" abgefragt wird. Der RegSchlüssel "TrustedFormScriptList" wird aber überhaupt nicht abgefragt.

    Nun bin ich etwas ratlos.

    Der Kundenwunsch ist, dass die Formulare aus einem freigegebenen Ordner auf dem Fileserver aufgerufen werden sollen.

    Umgebung:
    Terminalserver 2008 R2, Outlook 2010, letzter Patchstand, Exchange 2016 ohne öffentliche Ordner.

    Ich wäre für eine Idee aus Euren Reihen sehr dankbar.

    Viele Grüße

    André Diekmann

    Freitag, 5. Januar 2018 11:11