none
Server 2003: Keine Freigabe funktioniert mehr nach Ausfall einer Festplatte, was tun? RRS feed

  • Frage

  • Liebe Forengemeinde,

    zunächst die Ausgangslage:

    Windows Server 2003 mit einem Raid 5, was C: abbildet, und vorher drei weiteren Festplatten mit unterschiedlichen Inhalten.

    Nachdem eine der drei weiteren Festplatten (nicht Raid) physisch zerstört war, musste ich sie ausbauen, weil sonst der Server im 2003-Startbild (wandernder Balken) hängen blieb.
    Danach sind nun vorhanden die Laufwerke C: (Primäre Partition), E: (logisches L., erweiterte P.) und W: (primäre P.).

    • Keine Fehler werden in der Ereignisanzeige gebracht,
    • der Server läuft wieder rund,
    • der IIS läuft und ist von außen erreichbar,
    • per Remote Desktop komme ich auf den Server,
    • der Server wird auch auf den anderen Rechnern angezeigt, aber nun das Problem:

    Trotz vorhandener korrekter Freigaben (z.B. E:\Daten) und Berechtigungen, die vorher den Zugriff problemlos ermöglichten, ist kein Zugriff mehr möglich. Es wird jedes Mal gemeldet, das Kennwort sei falsch.

    Ich habe bereits eine Freigabe und einen Nutzer neu angelegt, dennoch funktioniert der Zugriff nicht, weder auf das logische Laufwerk E: noch auf das primäre W:

    Über eine rettende Idee würde ich mich freuen!
    Herzliche Grüße

    Wurstfinger

    Mittwoch, 18. Juni 2014 16:12

Antworten

  • Wie waren die Laufwerksbuchstaben vor und nach dem Crash?

    nur zum Testen: kannst du den 3 weiteren Platten neue Laufwerksbuchstaben geben, die bisher (auch vor dem Crash) nicht auf dem Server nicht benutzt wurden und dann eine (neue) Freigabe testen?

    MfG

    Donnerstag, 19. Juni 2014 07:12
  • Den Laufwerksbuchstaben des anderen Laufwerkes kenne ich nicht, da ich das System nicht eingerichtet habe und der Einrichter vor Erstellen der Doku Insolvenz anmeldete :-/

    Den Freigaben nach war dort auch keine eingerichtet.

    Aber:

    Ich habe dem Laufwerk nun mal einen neuen Buchstaben zugewiesen, eine Freigabe damit eingerichtet und ES GEHT!

    Ich hätte zwar lieber eine weniger symptomatische Lösung gefunden (insbesondere, weil ich u.U. jetzt einige Freigaben auf allen Rechnern erneuern muss, doch lieber umständlich als gar nicht :-)

    Vielen Dank, Jan-Gerd!

    Leider habe ich keine Zeit mehr, werde aber Mo testen, was passiert, wenn ich den Buchstaben erneut nutze, ob dann die Freigaben wieder gehen. Ich werde dann nochmals berichten.

    Wenn noch jemand eine Idee für die mögliche Ursache hätte bzw. wo im System da was schiefgelaufen ist, würde ich mich rein aus Neugier freuen.

    @Kevin: Danke auch Dir. Da hatte ich schon geschaut und keine anderen Einträge gefunden als in der Computerverwaltung, aber wäre ja eine Möglichkeit gewesen.

    Donnerstag, 19. Juni 2014 18:50

Alle Antworten

  • Wie waren die Laufwerksbuchstaben vor und nach dem Crash?

    nur zum Testen: kannst du den 3 weiteren Platten neue Laufwerksbuchstaben geben, die bisher (auch vor dem Crash) nicht auf dem Server nicht benutzt wurden und dann eine (neue) Freigabe testen?

    MfG

    Donnerstag, 19. Juni 2014 07:12
  • Hi,

    die Konfiguration der Shares, wie diese waren, kannst Du unter folgendem Registry Schlüssel prüfen:

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\LanmanServer\Shares]

    Hier wären auch Anpassungen auf Basis der Registry möglich, um das ganze wieder ans laufen zu kriegen.

    Gruß
    Kevin

    Donnerstag, 19. Juni 2014 08:36
  • Den Laufwerksbuchstaben des anderen Laufwerkes kenne ich nicht, da ich das System nicht eingerichtet habe und der Einrichter vor Erstellen der Doku Insolvenz anmeldete :-/

    Den Freigaben nach war dort auch keine eingerichtet.

    Aber:

    Ich habe dem Laufwerk nun mal einen neuen Buchstaben zugewiesen, eine Freigabe damit eingerichtet und ES GEHT!

    Ich hätte zwar lieber eine weniger symptomatische Lösung gefunden (insbesondere, weil ich u.U. jetzt einige Freigaben auf allen Rechnern erneuern muss, doch lieber umständlich als gar nicht :-)

    Vielen Dank, Jan-Gerd!

    Leider habe ich keine Zeit mehr, werde aber Mo testen, was passiert, wenn ich den Buchstaben erneut nutze, ob dann die Freigaben wieder gehen. Ich werde dann nochmals berichten.

    Wenn noch jemand eine Idee für die mögliche Ursache hätte bzw. wo im System da was schiefgelaufen ist, würde ich mich rein aus Neugier freuen.

    @Kevin: Danke auch Dir. Da hatte ich schon geschaut und keine anderen Einträge gefunden als in der Computerverwaltung, aber wäre ja eine Möglichkeit gewesen.

    Donnerstag, 19. Juni 2014 18:50