locked
PPTP VPN von W8 nicht möglich RRS feed

  • Frage

  • Ich habe dasselbe Problem seit Installation eines reinen W8 pro auf einem Dell XPS.

    Das VPN wird aufgebaut, der Client erhält korrekte Werte für IP DNS Gateway vom W2k12 RAS

    PPTP mit erzwungener Verschlüsselung; nur MS-Chap v2; IP und DNS automatisch beziehen; VPN nicht als Standardgateway benutzen. automatische Metrik

    Routingtabelle (es geht um das Zielnetz 192.168.10.10

    --------------------------
    Aktive Routen:
         Netzwerkziel    Netzwerkmaske          Gateway    Schnittstelle Metrik
              0.0.0.0          0.0.0.0       172.18.1.1     172.18.3.122     20
        84.190.77.238  255.255.255.255       172.18.1.1     172.18.3.122     21
            127.0.0.0        255.0.0.0   Auf Verbindung         127.0.0.1    306
            127.0.0.1  255.255.255.255   Auf Verbindung         127.0.0.1    306
      127.255.255.255  255.255.255.255   Auf Verbindung         127.0.0.1    306
           172.18.0.0      255.255.0.0   Auf Verbindung      172.18.3.122    276
         172.18.3.122  255.255.255.255   Auf Verbindung      172.18.3.122    276
       172.18.255.255  255.255.255.255   Auf Verbindung      172.18.3.122    276
         192.168.10.0    255.255.255.0   192.168.10.209   192.168.10.204    221
       192.168.10.204  255.255.255.255   Auf Verbindung    192.168.10.204    476
            224.0.0.0        240.0.0.0   Auf Verbindung         127.0.0.1    306
            224.0.0.0        240.0.0.0   Auf Verbindung      172.18.3.122    276
            224.0.0.0        240.0.0.0   Auf Verbindung    192.168.10.204    476
      255.255.255.255  255.255.255.255   Auf Verbindung         127.0.0.1    306
      255.255.255.255  255.255.255.255   Auf Verbindung      172.18.3.122    276
      255.255.255.255  255.255.255.255   Auf Verbindung    192.168.10.204    476
    ==================================================
    ständige Routen:
      Keine 

    ----------------------------

    In das Netzwerk des VPN wird ausschließlich die dem Client zugewiesene IP per ping erreicht. Das Netzwerk bleibt jedoch verborgen. Es gibt keine weitere Firewall und das abschalten der Windows Firewall brachte ebenfallskeinen Erfolg. Auf allen W7 Clients arbeitet diese VPN Verbindung normal. Windows 8 Clients ist keine Kommunikation möglich.

    Die Ereignisanzeige meldet die VPN Verbindung als positiv Ereignis 20226 20221, 20222, 2223, 20224 und 20225. Mit letzter Ereignis-ID wird die Verbindung als Erfolgreich aufgebaut gemeldet.

    Gibt es hier schon Fortschritte? 

    LG

    Klaus-D. Dittmer

    Dienstag, 9. April 2013 07:09

Alle Antworten

  • Hallo Klaus,

    nur als Idee - Du hast auf dem Win8 Client nicht evtl. die Fritz VPN Software installiert? Bei mir war diese Software die Ursache für genau dieses Problem. Der installierte Treiber blockiert den Datenaustausch per PPTP. AVM hat sucht noch nach einer Lösung, ich muss fallweise die Software installieren und danach wieder deinstallieren, damit anschließend die VPN Verbindungen arbeiten.

    Gruß Martin

    Dienstag, 23. April 2013 13:29
  • Hallo Klaus,

    teste bei PPTP oder L2TP Verbdinungen über MS-CHAPv2 bitte folgendes:

    1.    VPN-Client (ab Windows Vista) hinter einer NAT-T Firewall für L2TP/IPSec Verbindungen mit MS-CHAPv2 aktivieren

    1. Registry-Einstellungen wie folgt setzen (nähere Informationen unter Microsoft Support ID KB926179 - http://support.microsoft.com/kb/926179)
    2. Registry-Editor (regedit.exe) mit erhöhten Rechten starten („Als Administrator ausführen“)
    3. Nach folgendem Registrierungsschlüssel suchen: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\PolicyAgent
    4. Anschließend einen neuen Schlüssel DWORD-Wert (32-Bit) anlegen und mit AssumeUDPEncapsulationContextOnSendRule benennen
    5. Den Wert auf „2“ festlegen und den Computer neu starten

    kind regards Jochen Reinecke - MCITP Enterprise Administrator 2008

    Mittwoch, 24. April 2013 07:36
  • Hallo Martin,

    danke für diese Idee; nach Deinstallation des AVM-VPN-Clients arbeiten die verschiedenen MS-PPTP-VPN wieder einwandfrei.

    Zwar meine ich als Frustreaktion erst nach der Einrichtung der MS-PPTP-VPN den AVM-VPN-Client installiert zu haben, aber das war nur die halbe Wahrheit.

    Der AVM-VPN-Client war installiert, es gab jedoch keine aktive Konfiguration für eine Verbindung. Die hatte ich erst nach der Fehlfunktion der MS-VPN-Clients konfiguriert.

    Woher weißt du dass AVM davon weiß? Ich habe dazu weder bei AVM noch in anderen Foren etwas gefunden.

    Vielen Dank und lieben Gruß
    Klaus


    Freitag, 10. Mai 2013 13:15
  • Hallo Jochen,

    danke für den Hinweis, aber es ist/war offensichtlich der Fritz-VPN-Client, der den Verkehr der MS-VPNs blockiert.

    Außerdem gilt der Artikel/Patch ja nur der IPSec bzw. IPSec via L2TP Problematik. In meinem Fall handelt es sich um ein PPTP VPN, das die NAT Problematik nicht kennt bzw. durch eine einfache Portweiterleitung von PPTP (Port 1723) und GRE (Port 47) zum Server stets korrekt arbeitet.

    lg
    Klaus


    Freitag, 10. Mai 2013 13:56
  • Du hast auf dem Win8 Client nicht evtl. die Fritz VPN Software installiert? Bei mir war diese Software die Ursache für genau dieses Problem. .... AVM hat sucht noch nach einer Lösung, ...

    @All

    AVM will davon nichts wissen. Ich erhielt folgende Antwort:

    Guten Tag Herr Dittmer,

    vielen Dank für Ihre Rückmeldung.

    Eine Diagnosemöglichkeit gibt es hier seitens FRITZ!Fernzugang leider wirklich nicht. Wenn eine UMTS-Verbindung dort ebenfalls nicht funktioniert, deutet das auf einen Fehler in der Netzwerkkonfiguration hin.

    Solange Sie den FRITZ!Fernzugang nur installieren, aber keine Verbindung darüber aufbauen, hat er aber abgesehen von der bereits überprüften Protokollbindung keinen Einfluss auf Ihr Netzwerk. Einen Fehler, der durch die reine Installation verursacht wird, können wir daher schon einmal ausschließen.

    Es ist natürlich möglich, dass ein grundsätzlicher Konfigurationsfehler vorhanden ist, der durch die Installation einer weiteren Netzwerkkomponente erst sichtbar wird. Das ist aber nur eine Vermutung meinerseits, sicher ließe sich das nur direkt am Rechner feststellen.

    Aus meiner Sicht ist wirklich der AVM Treiber das Problem. Auch wenn er scheinbar nur an eine Netzwerkkarte gebunden zu sein scheint, wird jeglicher PPTP VPN Verkehr blockiert, obwohl die VPN-Verbindung selbst aufgebaut sind.

    Ist die AVM Software deinstalliert, arbeiten die VPNs korrekt. Ein Fehler in meiner Netzwerk-Konfiguration kann ich nicht feststellen.

    MfG

    Klaus-D. Dittmer

    Sonntag, 19. Mai 2013 17:28
  • Hallo Klaus,

    nach meinen Recherchen ist das Problem sehr wohl der AVM Treiber, ich habe bei AVM vor ca. 3 Monaten einen Case aufgemacht und alle Informationen gesammelt, die verlangt wurden. Bisher wurden immer wieder Daten nachgefragt, eine Lösung habe ich aber noch nicht.

    Ich habe mehrfach auf einem neu aufgesetztem Win8 den Fehler mit/ohne AVM VPN Software deutlich nachvollziehen können:

    - neues System ohne AVM: PPTP geht

    - AVM Installation: PPTP geht nicht mehr

    - AVM Deinstallation: PPTP geht wieder

    Man kann dies x-mal wiederholen und bekommt immer wieder den gleichen Fehler. "Einen Fehler, der durch die reine Installation verursacht wird, können wir daher schon einmal ausschließen." - das wäre damit widerlegt.

    Viele Grüße

    Martin

    Dienstag, 28. Mai 2013 05:33