locked
Win7 - Netzlaufwerke (net use Befehl im Login-Skript) werden nicht verbunden.. RRS feed

  • Frage

  • Hallo!

    Unsere Loginskripts laufen wie gewünscht auf WinXP und auch auf WinVista.
    Bei Win7 gibt es Probleme mit den Netzlaufwerken die per net use Befehl eingebunden werden.
    Das LoginSkript wird ohne Fehler abgearbeitet, jedoch sind die Netzlaufwerke bei Win7 dann nicht vorhanden.

    Das LoginSkript wird ausgeführt, da die Drucker (auch im LoginSkript) erfolgreich verbunden werden. Also kann dies ausgeschlossen werden.
    Einen Fehler im LoginSkript kann ich ebenfalls ausschließen, da ein manueller Aufruf des LoginSkript erfolgreich ist.

    Als Übergangslösung lege ich eine Verknüpfung zum LoginSkript zusätzlich in den Autostartordner und somit wird das LoginSkript nochmals abgearbeitet und die Netzlaufwerke erscheinen.

    Hat jemand eine Idee dazu?

    Schöne Grüße
    Florian

    Donnerstag, 24. Juni 2010 10:09

Antworten

Alle Antworten

  • Am 24.06.2010 schrieb florinho:

    Unsere Loginskripts laufen wie gewünscht auf WinXP und auch auf WinVista.
    Bei Win7 gibt es Probleme mit den Netzlaufwerken die per net use Befehl eingebunden werden.
    Das LoginSkript wird ohne Fehler abgearbeitet, jedoch sind die Netzlaufwerke bei Win7 dann nicht vorhanden.

    GPO-FAQ No. 36, beide Einstellungen setzen und die Clients zweimal neu
    starten: http://www.gruppenrichtlinien.de/Grundlagen/faq.htm

    Servus
    Winfried


    Connect2WSUS: http://www.grurili.de/tools/Connect2WSUS.exe
    GPO's: http://www.gruppenrichtlinien.de
    Community Forums NNTP Bridge: http://communitybridge.codeplex.com/

    Donnerstag, 24. Juni 2010 10:36
  • Moin,

    UAC.

    http://www.faq-o-matic.net/2008/02/22/benutzerkontensteuerung-uac-richtig-einsetzen/

    Gruß, Nils

     


    Nils Kaczenski
    MVP Directory Services
    Hannover, Germany
    • Als Antwort markiert florinho Montag, 28. Juni 2010 08:19
    Donnerstag, 24. Juni 2010 11:36
  • Danke, aber diese beiden Einstellungen haben wir bereits aktiviert.
    Donnerstag, 24. Juni 2010 13:04
  • Hi,

    UAC habe ich auf Standard-Einstellungen.

    Habe UAC testweise deaktiviert.

    Macht aber auch keinen Unterschied.

    Hat noch wer eine Idee?

    Donnerstag, 24. Juni 2010 13:41
  • Moin,

    sind deine User lokale Admins? Dann bleibt UAC auf der Liste.

    Die von Winfried genannte Einstellung ist sinnvoll, scheidet als Ursache aber aus, weil sonst das ganze Loginskript fehlschlagen würde.

    Gruß, Nils

     


    Nils Kaczenski
    MVP Directory Services
    Hannover, Germany
    Donnerstag, 24. Juni 2010 13:59
  • Am 24.06.2010 schrieb florinho:

    Danke, aber diese beiden Einstellungen haben wir bereits aktiviert.

    Kommen die auch wirklich auf dem betroffenen Client an? Prüf es mit
    RSOP.MSC direkt am Client. Und kontrollier in der Registry, ob die
    Einstellungen auch wirklich da sind. Und ins Ereignisprotokoll schauen
    hat auch noch nie geschadet. ;)

    Servus
    Winfried


    Connect2WSUS: http://www.grurili.de/tools/Connect2WSUS.exe
    GPO's: http://www.gruppenrichtlinien.de
    Community Forums NNTP Bridge: http://communitybridge.codeplex.com/

    Donnerstag, 24. Juni 2010 14:08
  • Hallo,

    gemischt. Lokale Admins oder Hauptbenutzer.

    Wie soll ich die UAC stellen?

    Schöne Grüße

    Freitag, 25. Juni 2010 06:22
  • Servus Winfried,

    ja die Einstellungen kommen bei den Clients an. Haben wir ja schon seit XP-Zeiten so eingestellt.

    In der RSOP.MSC sind die Einstellungen gesetzt. Das Ereignisprotokoll ist sauber.

    Die Registry habe ich nicht geprüft, da ich nicht genau weiß wo ich nachsehen soll.

    Wie gesagt, das Skript wird ausgeführt, da die Drucker verbunden werden.

    Wenn das gleiche Skript dann nochmals manuell oder über Autostart ausgeführt wird, läuft alles.

    Schöne Grüße

    Freitag, 25. Juni 2010 06:29
  • Am 25.06.2010 schrieb florinho:

    gemischt. Lokale Admins oder Hauptbenutzer.

    Mach sie zu normalen Benutzern und alles ist gut.

    Wie soll ich die UAC stellen?

    Wenn Du den geposteten Artikel von Nils gelesen hättest, würdest Du
    die Lösung jetzt schon im Einsatz haben.

    Servus
    Winfried


    Connect2WSUS: http://www.grurili.de/tools/Connect2WSUS.exe
    GPO's: http://www.gruppenrichtlinien.de
    Community Forums NNTP Bridge: http://communitybridge.codeplex.com/

    Freitag, 25. Juni 2010 09:20
  • Am 25.06.2010 schrieb florinho:

    ja die Einstellungen kommen bei den Clients an. Haben wir ja schon seit XP-Zeiten so eingestellt.

    Das sagt gar nichts aus.

    In der RSOP.MSC sind die Einstellungen gesetzt. Das Ereignisprotokoll ist sauber.

    OK.

    Die Registry habe ich nicht geprüft, da ich nicht genau weiß wo ich nachsehen soll.

    Such im SYSTEM.ADM nach den Strings aus GPEDIT.MSC. Mit der
    Stringbezeichnung kommst Du zum Key.

    Wie gesagt, das Skript wird ausgeführt, da die Drucker verbunden werden.

    Wenn das gleiche Skript dann nochmals manuell oder über Autostart ausgeführt wird, läuft alles.

    UAC lässt grüßen.

    Servus
    Winfried


    Connect2WSUS: http://www.grurili.de/tools/Connect2WSUS.exe
    GPO's: http://www.gruppenrichtlinien.de
    Community Forums NNTP Bridge: http://communitybridge.codeplex.com/

    Freitag, 25. Juni 2010 09:25
  • gemischt. Lokale Admins oder Hauptbenutzer.

    1. glaub ich nicht. ;)

    (Windows 7 kennt keine Hauptbenutzer mehr.)

    2. schlechte Idee.

    3. da hast du dein Problem.

    Gruß, Nils

     


    Nils Kaczenski
    MVP Directory Services
    Hannover, Germany
    Freitag, 25. Juni 2010 20:35
  • 1. glaub ich nicht. ;)

    (Windows 7 kennt keine Hauptbenutzer mehr.)

    Irgendwie scheint es die Hauptbenutzer auch in Win7 noch zu geben:

    "Hauptbenutzer" sind eingeschlossen aus Gründen der Rückwärtskompatibilität, sie besitzen eingeschränkte administrative Rechte.

    In dieser lokalen Gruppe hatte ich die Benutzer eingetragen. Dadurch funktionierte das zuweisen der Laufwerke nicht!

    Montag, 28. Juni 2010 08:19
  • Danke für eure Hilfe.

    Ich hatte den UAC-Artikel nicht genau genug gelesen ;-)

    Montag, 28. Juni 2010 08:20