none
Kerberos Konfiguration auf Sharepoint 2013 Foundation RRS feed

  • Frage

  • Hallo

    ich versuche seit einer Woche, den SharePoint 2013 Foundation dazu zu bringen, die
    Authentifizierung über Kerberos laufen zu lassen. Trotz verschiedener Anleitungen und Recherche im Netz habe ich immer den gleichen Fehler.

    Wir benötigen Kerberos um auf Daten unseres SQL Servers zurückzugreifen. Da meiner Info nach der Secure Store bei der Foundation Version nicht enthalten ist, schien mir die Kerberos Authentifizierung sinnvoll.

    Nach Erstellung einer Webanwendung (Std. Einstellungen - nur Änderung auf Kerberos Auth.) durch die SharePoint Administration bekomme ich an meinem Client aber nur die Aufforderung, Benutzername und Kennwort anzugeben.

    Ich fang mal vorne an:

    Basierend auf dem Blog von  Thomas Balkeståhl habe ich die beschriebenen Einstellungen vorgenommen. http://blog.blksthl.com/2012/09/26/the-first-kerberos-guide-for-sharepoint-2013-technicians/

    Wenn ich eine Webanwendung ohne Kerberos erstelle, wird die Seite aufgerufen und ich bekomme per klist.exe auch die erwähnten SPNs angezeigt. Stelle ich den Modus auf Kerberos um und prüfe die Einstellungen die im IIS geändert werden, komme ich nicht mehr auf die Seite.

    Ich habe wirklich lange gesucht, Blogs und Foren durchforstet, habe aber nichts gefunden, was mich weiter bringt.

    Im den Kommentaren ist davon die Rede, dass man die Web Anwendung per PS erstellen muss damit die Windows Authentifizierung gewählt wird und nicht die Anspruchsbasierte Authentifizierung. Wenn ich dies tue, wird aber dauf hingewiesen, dass diese Funktion veraltet ist.

    Ich hoffe, dass jemand einen Tipp hat und bedanke mich im voraus!

    Mfg

    D.Bölling



    • Bearbeitet D. Bölling Montag, 10. März 2014 08:02
    • Typ geändert Alex Pitulice Donnerstag, 13. März 2014 08:40 Warten auf Feedback
    • Typ geändert Alex Pitulice Dienstag, 1. April 2014 11:54
    Montag, 10. März 2014 08:01

Antworten

  • Hi D.!

    Ich habe den Guide nur überflogen, für den SharePoint Server steht da auch alles drin ... Aber für die Kerberos Authentifizierung am SQL fehlt da was.

    Gehe bitte wie folgt vor:

    1. Prüfe, dass der Account, welcher den SQL Server Dienst ausführt einen SPN MsSQL\hostname.firma.lan registriert hat
    2. Prüfe, dass der DNS Eintrag der Web Application (Beispiel: portal.firma.lan) auf den SharePoint Webserver zeigt
    3. Registriere die SPN's HTTP/portal und HTTP/portal.firma.lan für den Account unter welchem die Web Application ausgeführt wird (Beispiel: firma\Portal_AppPool
    4. Stell die Delegierung am Account des Application Pool Kontos auf den SQL Dienst SPN ein. Dazu klicke wie unter Punkt 3.4 in dem Guide den Punkt "Trust this computer for delegation to specified services only", klick darunter auf "Any authentication Protocol" und suche dir mit Klick auf "Add" den Account raus wofür der SQL SPN registriert worden ist.
    5. Stelle jetzt in der Web Application die Authentifizierung auf Kerberos

    Wenn alles passt solltest du danach den Content in SharePoint aufrufen können.

    Gruß Thomas


    Sonntag, 30. März 2014 07:19

Alle Antworten