locked
Probleme beim Zugriff auf Freigaben einer Windows 8.1 VM RRS feed

  • Frage

  • Hallo alle miteinander,

    wir haben seit 3 Tagen ein recht unschönes Problem. Wir betreiben bei einem Kunden einen Windows Server 2008R2 Hyper-V, auf dem zwei VMs laufen. Einmal ein Small Business Server und eine Windows 8.1 VM. Letztere hat seit einem Reboot vor wenigen Tage das Problem, dass der Zugriff auf die darauf befindlichen Dateifreigaben nicht mehr möglich ist. Außerdem läuft auf der Windows 8.1 VM ein SQL Server Express, welcher seit dem ebenfalls nicht mehr von außen erreichbar ist. Sowohl der Hyper-V, als auch die Windows 8.1 VM sind auf dem neusten Patchstand. Man kann sich an der VM auch via RDP anmelden und z.B. auf Dateifreigaben auf dem SBS zugreifen. Die Konnektivität ist also nicht komplett gestört. Versucht man jedoch per Telnet auf Port 445 und 1433 zuzugreifen, klappt das nicht. Die VM hört aber laut netstat auf Port 445 und 1433 zu. Die Windowsfirewall ist deaktiviert. Greift man auf der Windows 8.1 VM auf die eigenen Freigaben zu, sind diese auch vorhanden. Leider gehen uns die Ideen aus, da wir wie gesagt, die Maschine nur rebootet haben. Patch (KB2744129) ist installiert.

    Gruß


    Greetings/Grüße Gernot

    Freitag, 27. Juni 2014 08:44

Antworten

  • Ah! Die böse GPO vom SBS2011 ist's gewesen: Siehe u.a. auch hier:

    http://social.technet.microsoft.com/Forums/en-US/799851b3-49ad-4a19-810a-01b4a0889d63/sbs-2011-blocking-smbnetbiosrdp-on-domain-profile-by-group-policy-from-unkown-gpo?forum=smallbusinessserver

    Da muss man mal darauf kommen...


    Greetings/Grüße Gernot

    • Als Antwort markiert Gernot Meyer Dienstag, 1. Juli 2014 09:45
    Dienstag, 1. Juli 2014 09:45

Alle Antworten

  • Am 27.06.2014 schrieb Gernot Meyer:

    wir haben seit 3 Tagen ein recht unschönes Problem. Wir betreiben bei einem Kunden einen Windows Server 2008R2 Hyper-V, auf dem zwei VMs laufen. Einmal ein Small Business Server und eine Windows 8.1 VM. Letztere hat seit einem Reboot vor wenigen Tage das Problem, dass der Zugriff auf die darauf befindlichen Dateifreigaben nicht mehr möglich ist.

    Ist denn der Client für Microsoft Netzwerke in den Eigenschaften der
    verwendeten NIC angehakt? Welches Netzwerk wird auf dem W8.1 angezeigt
    im Netzwerk- und Freigabcenter?

    BTW: Windows Firewall abschalten bzw. deaktivieren ist seit VISTA
    kontraproduktiv.


    Servus
    Winfried

    Gruppenrichtlinien
    WSUS Package Publisher
    HowTos zum WSUS Package Publisher
    NNTP-Bridge für MS-Foren

    Freitag, 27. Juni 2014 14:13
  • Hi Winfried,

    danke für deine Antwort. Ja "Client für Microsoft Netzwerke" ist natürlich eingeschaltet. Die Maschine ist übrigends Domänenclient. Es wird auch das Domänennetzwerk im Netzwerk und Freigabecenter erkannt. Wie gesagt, es wurde nichts geändert. Die VM wurde nur rebootet. Die Firewall wurde auch nur temporär deaktiviert. Normal ist die mit entsprechenden Portfreigaben eingeschaltet und es hat so auch alles bis vor kurzem funktioniert.


    Greetings/Grüße Gernot

    Freitag, 27. Juni 2014 15:07
  • Schon die üblichen Diagnosen gemacht?

    perfmon /rel (wird nicht funktionieren, wenn der Task nicht aktiviert wurde -> KB 983386)

    eventvwr.msc

    nltest /sc_query:<deine Domäne>

    Freigabeberechtigungen

    NTFS-Berechtigungen

    Gruppenmitgliedschaften im AD von den Benutzern, die zugreifen sollen

    der Zugriff auf die darauf befindlichen Dateifreigaben nicht mehr möglich

    Welche Fehlermeldung erscheint?

    per Telnet auf Port 445 und 1433 zuzugreifen, klappt das nicht

    Wieder, welche Fehlermeldung erscheint?

    Freitag, 27. Juni 2014 15:21
  • Am 27.06.2014 schrieb Gernot Meyer:

    danke für deine Antwort. Ja "Client für Microsoft Netzwerke" ist natürlich eingeschaltet. Die Maschine ist übrigends Domänenclient. Es wird auch das Domänennetzwerk im Netzwerk und Freigabecenter erkannt. Wie gesagt, es wurde nichts geändert. Die VM wurde nur rebootet. Die Firewall wurde auch nur temporär deaktiviert. Normal ist die mit entsprechenden Portfreigaben eingeschaltet und es hat so auch alles bis vor kurzem funktioniert.

    Du kannst vom Host + von einem anderen Client/Server (der nicht als VM
    auf dem Host läuft) nicht auf diese Maschine zugreifen? Einen
    weiteren Neustart hast Du bereits ausgeführt? Welche Fehlermeldungen
    bekommst Du in der VM und auf den Server/Clients wenn Du auf die VM
    zugreifen willst?


    Servus
    Winfried

    Gruppenrichtlinien
    WSUS Package Publisher
    HowTos zum WSUS Package Publisher
    NNTP-Bridge für MS-Foren

    Freitag, 27. Juni 2014 20:39
  • Richtig. Der Zugriff auf die Windows 8 VM ist weder von einer anderen VM, dem Hyper-V Host oder einem anderen physischen Client möglich. Als Fehlermeldung bekomme ich einen gewöhnlichen Timeoutmeldung, dass er die Adresse nicht erreichen kann (0x80004005 Unspecified error). Die Konnektivität ist aber gegeben. RDP funktioniert zb. Neustarts sowohl vom physischen Host als auch der VM habe ich auch mehrfach gemacht.

    Ich habe jetzt mal paralell eine frische Windows 8 VM aufgesetzt und out of the Box eine Freigabe eingerichtet. Funktioniert.


    Greetings/Grüße Gernot




    Montag, 30. Juni 2014 07:35
  • > 0x8004005
     
    Da fehlt eine Stelle...
     

    Martin

    Mal ein GUTES Buch über GPOs lesen?

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    And if IT bothers me - coke bottle design refreshment :))
    Montag, 30. Juni 2014 09:49
  • Am 30.06.2014 schrieb Gernot Meyer:

    Richtig. Der Zugriff auf die Windows 8 VM ist weder von einer anderen VM, dem Hyper-V Host oder einem anderen physischen Client möglich. Als Fehlermeldung bekomme ich einen gewöhnlichen Timeoutmeldung, dass er die Adresse nicht erreichen kann (0x8004005). Die Konnektivität ist aber gegeben. RDP funktioniert zb. Neustarts sowohl vom physischen Host als auch der VM habe ich auch mehrfach gemacht.

    05er Fehler sind Zugriff verweigert. Nimm die VM aus der Domain, Konto
    im AD löschen, neu starten und wieder neu aufnehmen. Funktioniert es
    dann wieder?


    Servus
    Winfried

    Gruppenrichtlinien
    WSUS Package Publisher
    HowTos zum WSUS Package Publisher
    NNTP-Bridge für MS-Foren

    Montag, 30. Juni 2014 11:13
  • > 05er Fehler sind Zugriff verweigert.
     
    Leider nicht nur... Die fehlende Stelle macht es schwierig:
     
    0x80070005: E_ACCESSDENIED
    0x80074005: DMLERR_EXECACKTIMEOUT
    0x80040005: OLE_E_NOTRUNNING
    0x80004005: E_FAIL
     
    :)
     

    Martin

    Mal ein GUTES Buch über GPOs lesen?

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    And if IT bothers me - coke bottle design refreshment :))
    Montag, 30. Juni 2014 11:33
  • > 0x8004005
     
    Da fehlt eine Stelle...

    Sorry da habe ich leider eine Zahl verschluckt. 0x80004005. Korrigiert.


    Greetings/Grüße Gernot



    Montag, 30. Juni 2014 11:39
  • Schon probiert. Brachte leider auch keine Besserung.

    Neue interessante Wendung. Die neue Test VM die ich aufgesetzt habe und bei der alles ging, hat jetzt das gleiche Problem. Es wurde nichts an der Maschine geändert. Ich habe mich lediglich einmal per Remotedektop angemeldet und wieder abgemeldet.


    Greetings/Grüße Gernot


    Montag, 30. Juni 2014 11:45
  • > Sorry da habe ich leider eine Zahl verschluckt. 0x80040035. Korrigiert.
     
    Hä? Das paßt ja mal zu gar nix in dem Zusammenhang...
     
    # for hex 0x80040035 / decimal -2147221451 :
      IO_WARNING_INTERRUPT_STILL_PENDING
    ntiologc.h
      TAPI_E_DESTNOANSWER
    tapi3err.h
    # 2 matches found for "0x80040035"
     
     

    Martin

    Mal ein GUTES Buch über GPOs lesen?

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    And if IT bothers me - coke bottle design refreshment :))
    Montag, 30. Juni 2014 13:39
  • > Sorry da habe ich leider eine Zahl verschluckt. 0x80040035. Korrigiert.
     
    Hä? Das paßt ja mal zu gar nix in dem Zusammenhang...
     
    # for hex 0x80040035 / decimal -2147221451 :
      IO_WARNING_INTERRUPT_STILL_PENDING
    ntiologc.h
      TAPI_E_DESTNOANSWER
    tapi3err.h
    # 2 matches found for "0x80040035"
     

    Sorry, aber es ist ein "0x80004005" Fehler. Hatte ich bereits in meinem Post korrigiert.

    edit: Versucht man von der neuen TestVM mit Windows 8 auf die Freigaben zuzugreifen, gibt es einen anderen error code. 0x80070035 - Netzwerkpfad nicht gefunden. Die Konnektivität ist aber nach wie vor gegeben. Nur Port 445 scheint geblockt zu werden. Beim aushandeln der Verbindung bleibt man immer bei Syn_gesendet hängen.


    Greetings/Grüße Gernot


    Montag, 30. Juni 2014 16:01
  • Am 30.06.2014 schrieb Gernot Meyer:

    Neue interessante Wendung. Die neue Test VM die ich aufgesetzt habe und bei der alles ging, hat jetzt das gleiche Problem. Es wurde nichts an der Maschine geändert. Ich habe mich lediglich einmal per Remotedektop angemeldet und wieder abgemeldet.

    Stell das SMB-Signing gem. Best Praxis Artikel überall ein:
    http://www.gruppenrichtlinien.de/artikel/smb-signing-kommunikation-digital-signieren/


    Servus
    Winfried

    Gruppenrichtlinien
    WSUS Package Publisher
    HowTos zum WSUS Package Publisher
    NNTP-Bridge für MS-Foren

    Montag, 30. Juni 2014 18:57
  • > Sorry, aber es ist ein "0x80004005" Fehler. Hatte ich bereits in meinem
    > Post korrigiert.
     
    Jetzt kommen wir der Sache ganz langsam näher :)
     
    # for hex 0x80004005 / decimal -2147467259 :
      DDERR_GENERIC        ddraw.h
      DIERR_GENERIC        dinput.h
      DPERR_GENERIC        dplay.h
      DPNERR_GENERIC    dplay8.h
      DSERR_GENERIC        dsound.h
      DVERR_GENERIC        dvoice.h
      ecError        ec.h
      MAPI_E_CALL_FAILED    mapicode.h
      STIERR_GENERIC    stierr.h
      E_FAIL        winerror.h
    # Unspecified error
    # 10 matches found for "0x80004005"
     
    Der letzte ist hier der zutreffende, auch wenn E_FAIL nicht wirklich
    aussagekräftig ist. SMB-Signing (wie Winfried schon sagte) wäre ein
    Ansatzpunkt.
     

    Martin

    Mal ein GUTES Buch über GPOs lesen?

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    And if IT bothers me - coke bottle design refreshment :))
    Dienstag, 1. Juli 2014 09:33
  • Ah! Die böse GPO vom SBS2011 ist's gewesen: Siehe u.a. auch hier:

    http://social.technet.microsoft.com/Forums/en-US/799851b3-49ad-4a19-810a-01b4a0889d63/sbs-2011-blocking-smbnetbiosrdp-on-domain-profile-by-group-policy-from-unkown-gpo?forum=smallbusinessserver

    Da muss man mal darauf kommen...


    Greetings/Grüße Gernot

    • Als Antwort markiert Gernot Meyer Dienstag, 1. Juli 2014 09:45
    Dienstag, 1. Juli 2014 09:45
  • > Da muss man mal darauf kommen...
     
    In der Tat... :)
     

    Martin

    Mal ein GUTES Buch über GPOs lesen?

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    And if IT bothers me - coke bottle design refreshment :))
    Dienstag, 1. Juli 2014 10:24