none
Logoff Script mit Robocopy funktioniert nicht richtig RRS feed

  • Frage

  • Hello an alle,

    Ich habe das folgende Problem:

    Seit dem das Speichern von Passwörtern im IE 11/Credentialmanager auf Server 2012 R2 mit RDS Rolle und Raomaing Profiles nicht mehr funktioniert, Versuchen wir ein Login/Logoff Script via GPO zu erstellen, welche die gesicherten Passwörter/Verzeichnisse kopiert (mehr hier zu finden: https://social.technet.microsoft.com/Forums/windowsserver/en-US/2ead13cc-2863-4637-b0fe-7f3b26a3aaf2/save-website-passwords-not-working-properly-with-credential-manager-in-windows-2012r2-rds?forum=winserverTS).

    Das Loginscript funktioniert soweit ohne Probleme. Das Logoff Script allerdings nicht. Die erweiterte Logfunktion für GPOs wurde aktiviert. Dort konnte ich festellen, dass das Script auf jeden Fall erkannt wird aber nicht das gewünschte ausführt (kopieren via Robocoyp des Lokalen Verzeichnisses Appdata/Local/Microsoft/Vault zum Netzlaufwerk auf dem das Profil/Daten des Benutzers liegen).

    GPSVC(a00.ad0) 14:21:03:321 Executing non-Powershell script cmdlet = <Logoff_IE.bat>, parameter = <(null)>, directory = \\server\SysVol\server\Policies\{A3B0A2CB-79AC-4AA2-A990-73A0E74D5087}\User\Scripts\Logoff

    Wird das Script von hand aus ausgeführt, bestehen soweit keine Probleme

    Hat noch jemand eine Idee woran dies liegen könnte?

    Das Script sieht folgendermaßen aus

    @Echo off

    SET PFAD="%USERPROFILE%\Appdata\local\Microsoft\Vault"

    SET PFAD2="H:\Vault"

    IF NOT EXIST %PFAD2% (

    MKDIR "H:\Vault"

    goto copy ) ELSE (

    goto copy )

    :copy

    ROBOCOPY "%PFAD%" "H:\Vault" /mir

    goto ende

    :ende

    H: ist ein Netzlaufwerk, ein Test die Daten auf dem Server in ein lokales Verzeichnis zu kopieren war ebenfalls erfolglos

    Eine Pause im Script wurde auch testweise eingebaut, um zu überprüfen, ob das Script ausgeführt wird. Dies hat auch zu verzögerten Abmeldung geführt. Allerdings wurden keine Dateien kopiert

    Hat noch jemand Ideen

    Gruß Malte

    Donnerstag, 30. März 2017 09:27

Antworten

Alle Antworten