none
Windows 2008 R2 SP1 - Installation scheitert 0x8e5e0147 RRS feed

  • Frage

  • Wenn ich auf einem usnerer Exchange Server (Windows 2008 R2) SP1 für Windows aufspielen will installiert er ca. 10 min. um dann mit  folgenden Fehlermeldung abzubrechen:

    0x8e5e0147

    Microsofts Vorbereitungstool "Windows6.1-KB947821-v10-x64.msu" wurde laufenlassen und spuckt dies aus:

    =================================
    Checking System Update Readiness.
    Binary Version 6.1.7601.21645
    Package Version 11.0
    2011-03-28 15:49

    Checking Windows Servicing Packages

    Checking Package Manifests and Catalogs

    Checking Package Watchlist

    Checking Component Watchlist

    Checking Packages

    Checking Component Store

    Summary:
    Seconds executed: 438
     No errors detected

     

    Im Eventlog findet sich ein Eintrag mit EventID 7:

    Bei der Service Pack-Installation konnten keine Änderungen an einem Update (Service Pack für Microsoft Windows (KB976932)) durchgeführt werden.
        Identität:     Package_for_KB976932~31bf3856ad364e35~amd64~~6.1.1.17514
        Fehlercode:   0x8e5e0147
        Zielstatus: 7

    Laut einem Blogeintrag soll man das Package mit DISM removen:

    dism /online /remove-package /packagename:Package_for_KB976932~31bf3856ad364e35~amd64~~6.1.1.17514

    Dies hat aber nicht geholfen.

    In der Datei c$\Windows\Logs\CBS\cbs.log findet sich noch folgender Hinweis:

    2011-03-28 16:11:31, Info                  CBS    Exec: Processing complete.  Session: 30141776_2600990062, Package: Package_for_KB976932~31bf3856ad364e35~amd64~~6.1.1.17514 [HRESULT = 0x8e5e0147 - JET_errBadPageLink]
    2011-03-28 16:11:31, Error                 CBS    Failed to perform operation.  [HRESULT = 0x8e5e0147 - JET_errBadPageLink]

     

    Das Servicepack für Windows läßt sich nicht installieren. Weiß jemand woran die liegt?

    Montag, 28. März 2011 14:58

Antworten

  • So - SP1 ist nun drauf.

    Es gab offenbar noch einen Eventlog Eintrag, den ich übersehen hatte, der aber relvant war:

    Event ID:      447

    Task Category: Database Corruption

    Level:         Error

    Keywords:      Classic

    User:          N/A

    Computer:      xxx

    Description:

    Catalog Database (540) Catalog Database: A bad page link (error -327) has been detected in a B-Tree (ObjectId: 8, PgnoRoot: 35) of database C:\Windows\system32\CatRoot2\{XYZ ...

    Dieser führt zu der Vermutung, das das CatRoot2 Verzeichnis eine defekte Datenbank enthält.

    Das Verzeichnis wird offenbar von dem Dienst "Kryptografiedienste" genutzt, der laut Beschreibung von Services.msc für folgendes zuständig ist:

    Bietet vier Verwaltungsdienste: den Katalogdatenbankendienst, der die Signaturen von Windows-Dateien bestätigt und die Installation neuer Programme ermöglicht; den geschützten Stammdienst, der diesem Computer vertrauenswürdige Zertifikate von Stammzertifizierungsstellen hinzufügt und diese daraus entfernt; den automatischen Aktualisierungsdienst für die Stammzertifizierung, der Stammzertifikate vom Windows Update abruft und Szenarien wie SSL aktiviert; und den Schlüsseldienst, von dem die Registrierung dieses Computers für Zertifikate unterstützt wird. Wird dieser Dienst beendet, funktionieren diese Verwaltungsdienste nicht ordnungsgemäß. Wird dieser Dienst deaktiviert, können alle ausdrücklich von diesem Dienst abhängigen Dienste nicht gestartet werden.

    Um das CatRoot2 neu anlegen zu lassen mußte das bestehende Verzeichnis umbenannt werden wozu vorher der Dienst "Kryptografiedienste" angehalten werden mußte. Nach dem Neustart des Dienstes wurde das Verzeichnis und die Datenbank zunächst nicht neu angelegt - das passierte dann aber beim aufruf von SP1 der ungewöhnlich lange dauerte (da er ja vermutlich im Hintergrund die Datenbank neu erstellte).

    Das SP ließ sich nun aufspielen.

    • Als Antwort markiert testrrrr Mittwoch, 30. März 2011 14:44
    Mittwoch, 30. März 2011 14:36

Alle Antworten

  • Am 28.03.2011 schrieb testrrrr:

    Wenn ich auf einem usnerer Exchange Server (Windows 2008 R2) SP1 für Windows aufspielen will installiert er ca. 10 min. um dann mit  folgenden Fehlermeldung abzubrechen:

    0x8e5e0147

    Proiber den Lösungsvorschlag aus dem letzten Posting:
    http://social.technet.microsoft.com/forums/en-US/itprovistasp/thread/fd770c72-f084-40f2-85a4-c08b6caa6de4/

    Servus
    Winfried


    Connect2WSUS: http://www.grurili.de/tools/Connect2WSUS.exe
    GPO's: http://www.gruppenrichtlinien.de
    Community Forums NNTP Bridge: http://communitybridge.codeplex.com/
    Reg2xml:  http://www.reg2xml.com - Registry Export File Converter

    Montag, 28. März 2011 16:44
  • Hallo,

    konnte der Tipp weiterhelfen?

    Gruß,
    Andrei

    Mittwoch, 30. März 2011 07:31
    Moderator
  • Danke für die Rückmeldungen. Diese vielen DLL Registrierungen ohne das ich mir sicher war das es für Windows 2008 R2 auch zutrifft waren mir etwas zu wage.

    Fixit sieht für mich eher nach Clienttool aus - das wollte ich bei einem Server ebenfalls nicht einfach so machen.

    Ich habe jetzt doch einen Call aufgemacht - ich hoffe das MS konkret sagen kann woran es hängt.

    sfc /scannow  

    hatte MS ebenfalls vorgeschlagen. Dies meldete aber nur, das keine Fehler gefunden worden seien.

     

    Mittwoch, 30. März 2011 08:48
  • Am 30.03.2011 schrieb testrrrr:

    Danke für die Rückmeldungen. Diese vielen DLL Registrierungen ohne das ich mir sicher war das es für Windows 2008 R2 auch zutrifft waren mir etwas zu wage.

    Wenn es DLLs gibt kann eine zusätzliche neue Registrierung nichts
    kaputt machen. DLLs die es nicht gibt, kannst Du auch nicht
    registrieren und somit kann auch nichts kaputt gehen.

    Fixit sieht für mich eher nach Clienttool aus - das wollte ich bei einem Server ebenfalls nicht einfach so machen.

    OK.

    Ich habe jetzt doch einen Call aufgemacht - ich hoffe das MS konkret sagen kann woran es hängt.

    Halte uns bitte auf dem laufenden. Danke.

    Servus
    Winfried


    Connect2WSUS: http://www.grurili.de/tools/Connect2WSUS.exe
    GPO's: http://www.gruppenrichtlinien.de
    Community Forums NNTP Bridge: http://communitybridge.codeplex.com/
    Reg2xml:  http://www.reg2xml.com - Registry Export File Converter

    Mittwoch, 30. März 2011 09:35
  • So - SP1 ist nun drauf.

    Es gab offenbar noch einen Eventlog Eintrag, den ich übersehen hatte, der aber relvant war:

    Event ID:      447

    Task Category: Database Corruption

    Level:         Error

    Keywords:      Classic

    User:          N/A

    Computer:      xxx

    Description:

    Catalog Database (540) Catalog Database: A bad page link (error -327) has been detected in a B-Tree (ObjectId: 8, PgnoRoot: 35) of database C:\Windows\system32\CatRoot2\{XYZ ...

    Dieser führt zu der Vermutung, das das CatRoot2 Verzeichnis eine defekte Datenbank enthält.

    Das Verzeichnis wird offenbar von dem Dienst "Kryptografiedienste" genutzt, der laut Beschreibung von Services.msc für folgendes zuständig ist:

    Bietet vier Verwaltungsdienste: den Katalogdatenbankendienst, der die Signaturen von Windows-Dateien bestätigt und die Installation neuer Programme ermöglicht; den geschützten Stammdienst, der diesem Computer vertrauenswürdige Zertifikate von Stammzertifizierungsstellen hinzufügt und diese daraus entfernt; den automatischen Aktualisierungsdienst für die Stammzertifizierung, der Stammzertifikate vom Windows Update abruft und Szenarien wie SSL aktiviert; und den Schlüsseldienst, von dem die Registrierung dieses Computers für Zertifikate unterstützt wird. Wird dieser Dienst beendet, funktionieren diese Verwaltungsdienste nicht ordnungsgemäß. Wird dieser Dienst deaktiviert, können alle ausdrücklich von diesem Dienst abhängigen Dienste nicht gestartet werden.

    Um das CatRoot2 neu anlegen zu lassen mußte das bestehende Verzeichnis umbenannt werden wozu vorher der Dienst "Kryptografiedienste" angehalten werden mußte. Nach dem Neustart des Dienstes wurde das Verzeichnis und die Datenbank zunächst nicht neu angelegt - das passierte dann aber beim aufruf von SP1 der ungewöhnlich lange dauerte (da er ja vermutlich im Hintergrund die Datenbank neu erstellte).

    Das SP ließ sich nun aufspielen.

    • Als Antwort markiert testrrrr Mittwoch, 30. März 2011 14:44
    Mittwoch, 30. März 2011 14:36
  • Am 30.03.2011 schrieb testrrrr:

    Um das CatRoot2 neu anlegen zu lassen mußte das bestehende Verzeichnis 
    umbenannt werden wozu vorher der Dienst "Kryptografiedienste" angehalten werden mußte. Nach dem Neustart des Dienstes wurde das Verzeichnis und die Datenbank zunächst nicht neu angelegt - das passierte dann aber beim aufruf von SP1 der ungewöhnlich lange dauerte (da er ja vermutlich im Hintergrund die Datenbank neu erstellte).

    Das SP ließ sich nun aufspielen.

    Freut mich für dich und Danke für Lösungsbeschreibung. ;)

    Servus
    Winfried


    Connect2WSUS: http://www.grurili.de/tools/Connect2WSUS.exe
    GPO's: http://www.gruppenrichtlinien.de
    Community Forums NNTP Bridge: http://communitybridge.codeplex.com/
    Reg2xml:  http://www.reg2xml.com - Registry Export File Converter

    Mittwoch, 30. März 2011 17:00