none
SBS 2008 Sp2 .Net4 Fehler RRS feed

  • Frage

  • Hallo zusammen,

    ich benötige Hilfe bei folgendem Problem (SBS2008 Sp2, alle Updates):

    Nach dem letzten Patchday von Microsoft wurde .Net v.4 installiert. Nach der Installation startet der Server nun alle 20 – 25 Minuten regelmäßig neu. Offensichtlich wird der Speicher durch den fehlerhaften Dienst von .Net4 „zugemüllt“.

    Folgendes Verhalten habe ich festgestellt:

    Der Dienst von.Net4 wird mit dem Systemstart automatisch (verzögert) gestartet. Das normale Verhalten wäre nun, dass der Dienst nach einer gewissen Zeit automatisch wieder beendet wird. Nicht so bei diesem System. Hier läuft dieser Dienst bis zu Absturz weiter. Beende ich nun nach dem Systemstart den Dienst manuell, läuft der Server problemlos weiter.

    Ich habe bei anderen Kunden teilweise völlig identische Hard- und Software mit exakt dieser Konstellation. Hier laufen die Server problemlos.

    Die Deinstallation von .Net4 habe ich bereits versucht, der Fehler bleibt.

    Hat jemand evtl. ein identisches Problem? Kann jemand helfen?

    Vielen Dank!

    Thomas


    Thomas Lippe Thomas.Lippe@runningnet.de
    Donnerstag, 1. Juli 2010 09:14

Antworten

  • Hi Thomas,
     
    > ich benötige Hilfe bei folgendem Problem (SBS2008 Sp2, alle Updates):
    >
    > Nach dem letzten Patchday von Microsoft wurde .Net v.4 installiert.
    > Nach der Installation startet der Server nun alle 20 – 25 Minuten
    > regelmäßig neu.
    > Offensichtlich wird der Speicher durch den fehlerhaften Dienst von .Net4
    > „zugemüllt“.
    >
    > Folgendes Verhalten habe ich festgestellt:
    >
    > Der Dienst von.Net4 wird mit dem Systemstart automatisch (verzögert)
    > gestartet.
    > Das normale Verhalten wäre nun, dass der Dienst nach einer gewissen Zeit
    > automatisch
    > wieder beendet wird. Nicht so bei diesem System. Hier läuft dieser Dienst
    > bis zu Absturz
    > weiter. Beende ich nun nach dem Systemstart den Dienst manuell, läuft der
    > Server
    > problemlos weiter.
    >
    > Ich habe bei anderen Kunden teilweise völlig identische Hard- und Software
    > mit exakt
    > dieser Konstellation. Hier laufen die Server problemlos.
    >
    > Die Deinstallation von .Net4 habe ich bereits versucht, der Fehler bleibt.
    >
    > Hat jemand evtl. ein identisches Problem? Kann jemand helfen?
     
    Aus welcher Anforderung heraus wurde das optionale ".NET Framework 4"
    installiert?
     
    Des Weiteren: Welchen "Dienst von.Net4" meinst Du?
     
    Solltest Du "Microsoft .NET Framework NGEN v4" meinen, gibt es hierzu
    folgende Hintergrundinformation:
     
    "NGen service allows the developer to defer the installation and update of
    native images to periods when the computer is idle.
     
    The NGen queue supports a simple priority scheme to help establish the order
    in which applications are pre-compiled when submitting multiple jobs to the
    queue. The priorities also determine whether the service should wait for
    idle time on the machine to do the background compilation. When the service
    detects that there are no more actions queued, it resets its status so that
    it will not restart the next time the computer is booted, and then it shuts
    itself down."
     
    Source:
    http://social.msdn.microsoft.com/Forums/en-US/netfxsetup/thread/4dd266e6-a93b-4195-81f8-109312004f4f
     
    Deswegen die Fragestellung: Welche Anwendung benötigt das ".NET Framework 4"
    bzw. verwendet den zugehörigen Dienst "Microsoft .NET Framework NGEN" und
    verursacht deswegen Probleme (wohlgemerkt NICHT der Dienst "Microsoft .NET
    Framework NGEN" verursacht vermutlich das Problem (hier vermutlich: "memory
    leak"), sondern die zugrundeliegende Applikation, die auf das "Microsoft
    ..NET Framework" aufsetzt und den Dienst "Microsoft .NET Framework NGEN"
    verwendet..)
     
    Tiefere Einblicke bekommst Du mittels einer Analyse mit dem "Process
    Monitor" (http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx)
    bzw. "Process Explorer"
    (http://technet.microsoft.com/en-us/sysinternals/bb896653.aspx) welche
    Anwendung weswegen sich unsauber verhält.
     
    --
    Tobias Redelberger
    StarNET Services (HomeOffice)
    Frankfurter Allee 193
    D-10365 Berlin
    Tel: +49 (30) 86 87 02 678
    Mobil: +49 (163) 84 74 421
    Email: T.Redelberger@starnet-services.net
    Web: http://www.starnet-services.net
     
     
     
    Donnerstag, 1. Juli 2010 12:01
    Moderator