none
SCCM 2012 Reporting Services RRS feed

  • Frage

  • Hallo,

    ich habe einen SCCM 2012 installiert, der SQL-Server ist ein dedizierter Server. Wenn ich nun den Reporting Services-Point auf dem SCCM installieren möchte dann erkennt keine Reporting Services server instance. Muss ich dann auf dem SQL-Server noch die Reporting Services nachinstallieren dass die Instanz dann sichtbar ist? Oder muss ich da noch mehr machen?

    Vielen Dank für Eure Hilfe.

    Viele Grüße

    Andi

    Freitag, 8. Juni 2012 14:13

Antworten

  • In http://technet.microsoft.com/en-us/library/gg712698.aspx#BKMK_InstallReportingServicesPoint steht: "System Center 2012 Configuration Manager makes a connection in the context of the current user to Windows Management Instrumentation (WMI) on the selected site system to retrieve the instance of SQL Server for Reporting Services. The current user must have Read access to WMI on the site system, or the Reporting Services instances cannot be retrieved."
    Weiterhin wäre noch interessant, ob es mehr als eine SQL Instanz gibt (WMI Namespace root\microsoft\SqlServer\ReportServer\RS_MSSQLSERVER\v10 und Registry HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\Instance Names\RS).

    Torsten Meringer | http://www.mssccmfaq.de

    Donnerstag, 21. Juni 2012 10:42
    Beantworter
  • Hallo Torsten,

    dann muss ich das mal beobachten bei weiteren Installationen.

    Vielen Dank für Deine Hilfe.

    Viele Grüße

    Andi

    • Als Antwort markiert Andreas Meier Donnerstag, 21. Juni 2012 21:13
    Donnerstag, 21. Juni 2012 21:12

Alle Antworten

  • Die SQL Reporting Services müssen SQL-seitig erst installiert und konfiguriert sein, bevor man einen Reporting Services Point installieren kann.

    Torsten Meringer | http://www.mssccmfaq.de

    Freitag, 8. Juni 2012 19:26
    Beantworter
  • Habe das gleiche Problem, auch wenn die Reporting Services konfiguriert sind. Aus irgendeinem Grund werden sie nicht gefunden von der Installationsroutine.

    Johannes Engel

    Sonntag, 10. Juni 2012 12:50
  • Was für eine SQL Version (SP + CU)? SQL lokal oder remote? Cluster? Instanz? 
    Fehler in srsrpsetup.log und srsrpmsi.log?
    EDIT: laut http://social.technet.microsoft.com/Forums/de-DE/systemcenterde/thread/8a00aade-e99d-453f-9fa2-8998bb49ad15 ist auf dem Server auch zusätzlich noch SQL 2012 installiert; dies könnte zu Problemen führen. Ich würde SQL 2012 entfernen und es dann nochmals versuchen.

    Torsten Meringer | http://www.mssccmfaq.de


    Montag, 11. Juni 2012 06:54
    Beantworter
  • Der SCCM läuft mit einer Remote-Installation von SQL-Server 2012. Abgesehen von der Reporting-Services-Rolle hat das auch tadellos funktioniert.

    Montag, 11. Juni 2012 09:05
  • Es mag zwar sein, dass SQL 2012 für CM12 funktioniert, supportet ist dies aber definitiv NICHT: http://technet.microsoft.com/en-us/library/gg682077.aspx#BKMK_SupConfigSQLDBconfig. Verwende eine der unterstützen SQL-Versionen und dann klappt's auch mit dem Reporting Services Point.

    Torsten Meringer | http://www.mssccmfaq.de

    Montag, 11. Juni 2012 10:39
    Beantworter
  • Vielen Dank für den Hinweis. Leider ist das Ergebnis in einer reinen 2008 R2 SP1-Umgebung exakt das gleiche. Ich kann mit dem SQL Management Studio auf Datenbank und Reporting Services von außen zugreifen, nur die Rollen-Installationsroutine findet die SRS-Instanz nicht.
    Donnerstag, 14. Juni 2012 07:50
  • Was für eine SQL Version (SP + CU)? SQL lokal oder remote? Cluster? Instanz? 
    Fehler in srsrpsetup.log und srsrpmsi.log?

    Dann stelle ich meine Frage von oben nochmals ...

    Torsten Meringer | http://www.mssccmfaq.de

    Donnerstag, 14. Juni 2012 12:38
    Beantworter
  • OK, Remote SQL 2008 R2 SP1 CU6, kein Cluster, named instance mit festem Port.

    Wo finde ich diese Logdateien?

    Donnerstag, 14. Juni 2012 12:39
  • Ich habe gerade kein CM12 greifbar, aber ich denke, dass die Logs auf der größten freien Partition auf dem SRSRP liegen (ggfs im Ordner \SMS der Partition).

    Torsten Meringer | http://www.mssccmfaq.de

    Freitag, 15. Juni 2012 10:55
    Beantworter
  • Dort habe ich es leider nicht gefunden.

    Dafür habe ich gerade unter http://blogs.technet.com/b/configmgrteam/archive/2009/05/14/faq-sql-reporting-services-integration-with-system-center-configuration-manager-2007-r2.aspx eine Aussage gefunden, dass die Reporting Services nur bei der Standard-Instanz korrekt erkannt werden. Ich versuche es also noch einmal...

    Freitag, 15. Juni 2012 18:18
  • Hallo Torsten,

    ich habe die DB in der Standard-Instanz. Ich habe SQL2008R2 SP1 CU4 installiert. Aber ich bekomme nichts angezeigt beim Reporting Server service Instance. Ich denke doch das SQL2008R2 SP1 CU 4 unterstützt wird, oder? Der SQL ist ein dedizierter SQL Server, also aus Sicht des SCCM eine Remote-Installation. Die Logfiles srsrpsetup.log und srsrpmsi.log kann ich auf meinem SCCM nicht finden.

    Soweit ich weiß liegen auch die DBs des SCOM auf diesem SQL, kann es sein das deswegen die Report-Server Installation nicht geht?

    Viele Grüße

    Thomas



    Samstag, 16. Juni 2012 16:36
  • SQL2008 R2 SP1 CU4 ist nicht supported: http://technet.microsoft.com/en-us/library/gg682077.aspx#BKMK_SupConfigSQLDBconfig. Es muss CU6 sein.

    Torsten Meringer | http://www.mssccmfaq.de

    Montag, 18. Juni 2012 07:23
    Beantworter
  • Hallo Torsten,

    kann das dann sein das deswegen die Reporting Services nicht funktionieren?

    Viele Grüße

    Andi

    Mittwoch, 20. Juni 2012 06:23
  • Denke nicht, trotzdem würde ich auf jeden Fall CU6 installieren, um zumindest eine supportete Konfiguration als Basis zu haben :-)


    Torsten Meringer | http://www.mssccmfaq.de

    Mittwoch, 20. Juni 2012 09:03
    Beantworter
  • Da hast Du natürlich vollkommen recht. Ist es denn supportet einen SCCM 2012 auf einem SQL-Cluster laufen zu lassen? Dabei geht es mir um die Hochverfügbarkeit.

    Ist es denn möglich das ich den SCCM in der Domäne A habe und den SQL in der Domäne B?

    Viele Grüße

    Andi


    Mittwoch, 20. Juni 2012 11:04
  • Wieso soll den ConfigMgr überhaupt HOCHverfügbar sein?
    SQL Cluster: ja: http://technet.microsoft.com/en-us/library/gg682077.aspx#BKMK_SupConfigSQLDBconfig.
    SQL Server / Domain: http://technet.microsoft.com/en-us/library/gg712282.aspx#BKMK_PlanDatabaseSrv: "The computer that runs SQL Server must be located in a domain that has a two-way trust with the site server and all computers running the SMS Provider. "


    Torsten Meringer | http://www.mssccmfaq.de

    Mittwoch, 20. Juni 2012 11:45
    Beantworter
  • Hallo Torsten,

    ich denke an den Fall wenn mir der SCCM mal um die Ohren fliegt, dann wäre es doch nett wenn noch zweiter SCCM da wäre der das ganze übernehmen würde. Oder wie wird das in größeren Umgebungen mit mehreren 1000 Clients gemacht? Wird dann ein CAS installiert mit verschiedenen primary sites? Aber was passiert dann wenn der CAS weg fällt?

    Viele Grüße

    Andi

    Mittwoch, 20. Juni 2012 11:48
  • Neues Spiel, wieder kein Glück:

    Frische Installation der Default Instance von SQL Server 2008 R2 SP1 mit CU 6 auf einem eigenen Server (remote), Firewall-Ports 80 und 1431 sind auf geöffnet, Verbindung zur Datenbank klappt auch perfekt, allein die Reporting Services-Instanz wird nicht gefunden bei dem Versuch, den Reporting Point zu installieren. Zugriff per Browser klappt aber auch vom SCCM-Server.

    Ich bin ratlos...

    Mittwoch, 20. Juni 2012 12:00
  • ich denke an den Fall wenn mir der SCCM mal um die Ohren fliegt

    Das Thema kann man stundenlang diskutieren. Ich würde sagen, dass man in diesem Fall einfach wieder einen Restore macht (Stichwort ConfigMgr-Backup) und die Sache läuft normalerweise innerhalb eines Arbeitstages wieder. Im Gegensatz zu zB einem DC (User kann sich nicht mehr anmelden), Exchange (kann keine Mail senden / empfangen) oder Printserver (drucken geht nicht mehr) halten sich die Auswirkungen auf die Enduser direkt in Grenzen.
    Selbst bei einer CAS und zwei Primaries ist man noch lange nicht Hochverfügbar. Was passiert, wenn die Clients 50:50 auf beide Primaries aufgeteilt sind und eine Primary fällt aus? 50% der Clients sind "unmanaged" und ohne manuellen Eingriff bleiben sie das auch (die Clients müssen dann "manuell" von Primary1 zu Primary2 assigned werden). Dann sind diese einer neuen Site assigned, ziehen komplett neue Policies, evaluieren Updates und Applications, liefern volle Hard- und Software-Inventuren (-> ggfs merklich am Client). Dann musst die ausgefallene Primary sowieso wiederhergestellt werden und die Clients wieder ihrer ursprünglichen Site assigned. Ich sehe dabei eher doppelten Aufwand. In der gleichen Zeit hat man vermutlich eine ausgefallene Primary schon wieder restored. Die Frage ist einfach, mit welchem Aufwand man sich welche "Ausfallsicherheit" (die selbst bei CAS + 2 Primaries nicht wirklich gegeben ist) erkaufen möchte (oder - wegen SLAs - vielleicht muss).

    Wegen dem SRS: hier sind ggfs mehr Ports nötig, siehe: http://technet.microsoft.com/en-us/library/hh427328.aspx. 1431 ist kein default SQL-Port (was ok wäre, wenn Du SQL so konfiguriert hast). Kannst Du denn auf http://SQLserver/Reports und http://SQLserver/Reportserver zugreifen?

    Torsten Meringer | http://www.mssccmfaq.de

    Mittwoch, 20. Juni 2012 12:37
    Beantworter
  • Hallo Torsten,

    die Firewall habe ich komplett deaktiviert. Auf die Links http://SQLserver/Reports und http://SQLserver/Reportserver kann ich nicht zugreifen, da kommt immer Service Unavailable. Mir ist noch aufgefallen dass der IIS nicht installiert war, das habe ich nachinstalliert. Aber auch nach der Installation geht es nicht. Woran kann das liegen?

    Viele Grüße

    Andi

    Mittwoch, 20. Juni 2012 13:36
  • IIS ist nicht nötig. Sind denn die Reporting Services schon konfiguriert? Start -> Microsoft SQL Serevr 2008 R2 -> Configuration Tools -> Reporting Services Configuration Manager.

    Torsten Meringer | http://www.mssccmfaq.de

    Mittwoch, 20. Juni 2012 13:55
    Beantworter
  • hallo Torsten,

    ja, die sind konfiguriert. Aber selbst wenn ich im Report Services Configuration Manager unter "Report Manager URL" auf den link gehe kommt die Meldung "Service Unavaible, HTTP Error 503. The service is unavailable.".

    Ich habe da keine Idee mehr.

    Viele Grüße

    Andi

    Mittwoch, 20. Juni 2012 14:28
  • Irgendwo in dem Instalaltionsverzeichnis von SQL gibt's Logs zu den Reporting Services (kenne auswending weder Verzeichnis noch Name). Diese könnten weiterhelfen. Klar ist aber auf jeden Fall, dass beide URLs erst einmal funktionieren müssen, bevor der SRSRP erfolgreich installiert werden kann.

    Torsten Meringer | http://www.mssccmfaq.de

    • Als Antwort vorgeschlagen m.klaas Mittwoch, 25. Juli 2012 16:47
    Mittwoch, 20. Juni 2012 14:45
    Beantworter
  • Hallo Torsten,

    ich habe den Port für die Reporting Services anstatt auf 80 auf 8080 umgestellt. Jetzt funktionieren die Seiten. Aber der SCCM erkennt trotzdem keine SRS.

    Viele grüße

    Andi


    Mittwoch, 20. Juni 2012 15:40
  • Nach http://marckean.wordpress.com/2010/12/17/sccm-2007-r3-log-files/ müssten die Logfiles unter %ProgramFiles%\Microsoft Configuration Manager\Logs liegen auf dem SCCM-Server. Dort existiert leider keines der genannten.

    Der Setup-Vorgang kann schon im zweiten Schritt nicht weitergeführt werden, weil keine Reporting Services-Serverinstanz gefunden werden kann.

    Donnerstag, 21. Juni 2012 07:29
  • In http://technet.microsoft.com/en-us/library/gg712698.aspx#BKMK_InstallReportingServicesPoint steht: "System Center 2012 Configuration Manager makes a connection in the context of the current user to Windows Management Instrumentation (WMI) on the selected site system to retrieve the instance of SQL Server for Reporting Services. The current user must have Read access to WMI on the site system, or the Reporting Services instances cannot be retrieved."
    Weiterhin wäre noch interessant, ob es mehr als eine SQL Instanz gibt (WMI Namespace root\microsoft\SqlServer\ReportServer\RS_MSSQLSERVER\v10 und Registry HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\Instance Names\RS).

    Torsten Meringer | http://www.mssccmfaq.de

    Donnerstag, 21. Juni 2012 10:42
    Beantworter
  • Hallo Torsten,

    ich habe jetzt mal den Report Server lokal auf den SCCM 2012 installiert und die Datenbank aber trotzdem auf dem dedizierten SQL-Server gelegt. Jetzt funktioniert es. Habe ich das was falsch gemacht, eigentlich sollte doch eigentlich alles automatisch geschehen, oder?

    Viele Grüße

    Andi

    Donnerstag, 21. Juni 2012 16:16
  • Prinzipiell geht's schon automatisch bzw ohne diesen Umweg.

    Torsten Meringer | http://www.mssccmfaq.de

    Donnerstag, 21. Juni 2012 18:53
    Beantworter
  • Hallo Torsten,

    dann muss ich das mal beobachten bei weiteren Installationen.

    Vielen Dank für Deine Hilfe.

    Viele Grüße

    Andi

    • Als Antwort markiert Andreas Meier Donnerstag, 21. Juni 2012 21:13
    Donnerstag, 21. Juni 2012 21:12