none
SCCM 2012 Application Deployment RRS feed

  • Allgemeine Diskussion

  • Hallo zusammen,

    ich habe mit dem SCCM 2012 eine Application mit einer .exe-Datei verteilt. In meinem Falle ist das MS Project. Die Installation läuft am Ende auf einen Fehler. Wenn ich dann die Fehlermeldung anschaue bekomme ich folgendes: The Software change returned error code 0x87D00324 (-2016410844). Seltsamerweise funktioniert Project aber einwandfrei. Habt Ihr eine Idee in welchem Log ich da suchen muß?

    Vielen Dank im Voraus.
    Viele Grüße

    Thomas

    Mittwoch, 25. April 2012 08:52

Alle Antworten

  • Im Logfile der Applikationsinstallation (falls überhaupt vorhanden).
    ConfigMgr 2012 (wie auch schon 2007) startet einfach nur die Command Line. Alles weitere (im Hinblick auf den ReturnCode) liegt an der exe/msi (oder was auch immer gestartet wird).

    Torsten Meringer | http://www.mssccmfaq.de

    Mittwoch, 25. April 2012 08:56
    Beantworter
  • Hi Thomas,

    wie Torsten schon sagt, ist der ConfigMgr einfach nur ausführende kraft. Logfiles zur installation finden sich meistens im %temp% bzw im c:\windows\temp\ schonmal dort geschaut?

    Soviel ich weiß startet die Project Setup.exe eh nur darunterliegende MSI's daher solltest du MSI Logfiles eigentlich in den o.g. Verzeichnissen finden.

    Grüße

    Ben

    Mittwoch, 25. April 2012 13:36
  • Hallo Torsten,

    kann ich eine install.bat auch mit der Option "als Administrator ausführen" starten?
    Viele Grüße

    Thomas

    Mittwoch, 25. April 2012 14:49
  • Wenn das Program schon als "run with administrative rights" konfiguriert ist, dann ist dies völlig ausreichend (da dann System-Kontext).


    Torsten Meringer | http://www.mssccmfaq.de

    Mittwoch, 25. April 2012 15:43
    Beantworter
  • Hallo Torsten,

    jede Installation die ich mit einer .exe über den SCCM 2012 installieren will fällt auf die Schnauze. Wenn ich aber eine .msi oder als App-V installiere dann funktioniert es. Und das bei verschiedenen Installationen (Office, Irfanview, Adobe Reader...).

    Es immer die gleiche Fehlermeldung: The Software change returned error code 0x87D00324 (-2016410844).

    Gibt es auf dem Client oder dem SCCM ein Log wo man da schauen kann?

    Hast Du eine Idee?

    Viele Grüße

    Thomas


    Mittwoch, 25. April 2012 18:20
  • Wenn klassisches Package/Program, dann execmgr.log. Wenn Application/DeploymentType, dann AppEnfore.log (jwls clientseitig).

    Torsten Meringer | http://www.mssccmfaq.de

    Donnerstag, 26. April 2012 09:10
    Beantworter
  • Hallo Torsten, hallo Raul,

    sorry für die späte Rückmeldung, aber ich war ein paar Tage verreist. Ich werde mal sehen ob ich den Logs etwas finde wo ich das Problem erkennen kann.

    Zuerst hatte ich die UAC in Verdacht,  aber diese hatte ich auf den Clients komplett heruntergefahren, was natürlich nicht im Sinne des Erfinders ist. Ich hatte mir dann auch ein Script gebastelt um die Applikation über das Script zu installieren. Wenn ich das Script direkt auf dem Client ausführe, dann wird die Installation sauber durchgeführt. Wenn ich dann das Script aber über das Package installieren will dann läuft mir das ganze auf einen Fehler, deswegen mein Verdacht mit der UAC.


    Grüße

    Thomas 

    Mittwoch, 2. Mai 2012 07:42
  • Wenn "run with admin rights", dann System-Kontext. UAC ist dann nicht involviert.

    Torsten Meringer | http://www.mssccmfaq.de

    Mittwoch, 2. Mai 2012 08:02
    Beantworter
  • Eben, wie gesagt, ich bin etwas ratlos. Ich muss mir das mal am Wochenende nochmals anschauen und die Logs die Du mir genannt hast nochmals durch sehen.

    Viele Grüße

    Thomas

    Donnerstag, 3. Mai 2012 14:26
  • Hallo, erhalte die selbe Fehlermeldung (0x87D00324) wenn ich eine Batchdatei als Application verteile (in der Batchdatei werden mehrere MSIs aufgerufen) . Die Installation funktioniert nur, wenn das "Installation behavior" (im Deployment Type) auf "Install for System" geändert wird. In der Batch Datei muss der MSI die Option /qn und nicht /qb mitgegeben werden, da die Installation sonst für den Benutzer (normaler Domain User) angezeigt wird. Ist dieses Verhalten so gewollt (wird die Option "Install for User" ausgewählt, macht SCCM "Install as User")?

    Donnerstag, 3. Mai 2012 14:54
  • Ich verstehe die Frage nicht ganz ... /qn oder /qb ist doch nur für das Progress Window des Installers verantwortlich (none vs basic) und hat nichts mit dem Installationskontext zu tun. Welches Verhalten ist also gewollt oder eben nicht?


    Torsten Meringer | http://www.mssccmfaq.de

    Donnerstag, 3. Mai 2012 18:28
    Beantworter
  • Es sollte doch unabhängig von der Option /qb oder /qn der eigentlichen Installtion der Applikation (MSI) dem Benutzer nichts angezeigt werden? Die Installation sollte ja unter dem Kontext System ausgeführt werden. Daher die Frage, warum wird eine Batch Datei im User Kontext ausgeführt, wenn diese als Application (Script) erstellt wird (bei MSIs ist dies nicht so)?
    Donnerstag, 3. Mai 2012 20:18
  • Die "Sichtbarkeit" kann im Deployment Type unter 'User Experience' konfiguriert werden, ebenso der Kontext (User/System). Beides ist voneinander total unabhängig und die ConfigMgr-Einstellung der Sichtbarkeit "sticht" die msi-Option.


    Torsten Meringer | http://www.mssccmfaq.de

    Freitag, 4. Mai 2012 07:32
    Beantworter
  • Danke Torsten. Dann wird dies wohl auch das Problem von Thomas beheben, da er die Installation vermutlich auch im User Kontext ausführt und deshalb keine Rechte hat.
    Freitag, 4. Mai 2012 07:49
  • Deutsch

    Bitte entschuldigen Sie meine begrenzte Deutsch.
    Ich hatte das gleiche problem. Das script lief gut und die Software richtig installiert, aber ein scheitern SCCM vorgemerkt.
    Mein problem erwies sich als falsch erkennung regel sein. So SCCM müssen den nachweis der regel analyisis, um zu prüfen, ob die software korrekt installiert.

    Englisch

    Please excuse my limited German.
    I had the same problem.  The script ran fine and the software installed correctly, however SCCM flagged a failure.
    My problem turned out to be a misconfigured detection rule.  So SCCM must run the detection rule analyisis in order to check if the software installed correctly.

    Dienstag, 8. Mai 2012 18:50
  • Hallo Thomas,

    bei mir trat ebenfalls der von dir genannte Fehlercode auf. Anscheinend ist das mal wieder eine "universelle" Fehlermeldung vom SCCM.

    Jedenfalls konnte ich das Problem lösen. Ursache war bei mir ein falsch hinterlegter Productcode des MSI-Pakets im SCCM (Zu finden unter den Deployment Types -> Programs bzw. Detection Methods).

    Mittwoch, 23. September 2015 11:21
  • 0x87D00324 = The application was not detected after installation completed. Source: System Center Configuration Manager. Siehe dazu auch http://www.mssccmfaq.de/2012/06/19/installation-failed-0x87d00324/


    Torsten Meringer | http://www.mssccmfaq.de

    Mittwoch, 23. September 2015 12:04
    Beantworter