none
Windows 10 1909 Suche im Menü funktioniert nicht nach dem man die andere Sprache hinzugefügt hat. RRS feed

  • Allgemeine Diskussion

  • Hallo Profis!

    Windows 10  1909

    Windows wird in deutscher Sprache installiert. Nun brauchen wir zusätzlich noch für die Mitarbeiter im Ausland Englisch. Sobald Englisch hinzugefügt wird, funktioniert die Suche nicht mehr.

    *.cab 6 Dateien Language Pack

    Add-WindowsPackage -Online -PackagePath Dateiname –NoRestart

    Installation der Sprache funktioniert dann lokal einwandfrei.

    Im Explorer werden die Dateien gefunden. Indizierung haben wir aktiv und erweitert.

    Klick->Startbutton->Programname eingeben funktioniert nicht. Im Taskmanager taucht kurz die Search.exe auf und stürzt ab.

    Name der fehlerhaften Anwendung: SearchUI.exe, Version: 10.0.18362.418, Zeitstempel: 0x5d995690
    Name des fehlerhaften Moduls: Windows.UI.Xaml.dll, Version: 10.0.18362.418, Zeitstempel: 0x253810c2
    Ausnahmecode: 0xc000027b
    Fehleroffset: 0x0000000000712dc0
    ID des fehlerhaften Prozesses: 0x235c
    Startzeit der fehlerhaften Anwendung: 0x01d5ab42c9772c1d
    Pfad der fehlerhaften Anwendung: C:\Windows\SystemApps\Microsoft.Windows.Cortana_cw5n1h2txyewy\SearchUI.exe
    Pfad des fehlerhaften Moduls: C:\Windows\System32\Windows.UI.Xaml.dll
    Berichtskennung: 71648c6c-9c01-4478-889b-772fae97d0e8
    Vollständiger Name des fehlerhaften Pakets: Microsoft.Windows.Cortana_1.13.0.18362_neutral_neutral_cw5n1h2txyewy
    Anwendungs-ID, die relativ zum fehlerhaften Paket ist: CortanaUI

    Cortana lässt sich nicht deinstallieren um dann neue installieren. Drüber bügeln geht auch nicht. Ich habe alle Standard Apps neue installiert.

    Sobald ich die Sprache entferne funktioniert alles sofort.

    Remove-WindowsPackage -Online -PackagePath Dateiname –NoRestart

    Hat jemand eine Idee?

    Ich habe noch festgestellt, dass bei win 1903 funktioniert alles wunderbar. Sprachpakete sind von 1903. Für 1909, schreibt Microsoft, sollen die Pakete von 1903 verwendet werden. RSAT und Net3.5 funktioniert auch.



    Freitag, 6. Dezember 2019 08:59

Alle Antworten

  • Da bleibt dann wohl nur eine Meldung über den Feedback-Hub (Win 10 App).
    Freitag, 6. Dezember 2019 09:55
  • Ich habe das gleiche Problem. Wir installieren Win10 1909 in englisch und installieren dann beispweise die deutschen Sprachpakete drüber. 

    Auch bei uns funktioniert die Suche dann leider nicht mehr. Hat jemand bereits eine Lösung für dieses Problem?

    Dienstag, 17. Dezember 2019 20:56
  • Ich habe ebenfalls das gleiche Problem.

    Hat jemand bereits eine Lösung gefunden?



    Mittwoch, 8. Januar 2020 09:15
  • Hi Vitalij,
    konntest du inzwischen eine Lösung finden?
    Gruß
    Martin

    Montag, 20. Januar 2020 09:35
  • Der Fehler scheint nicht mit der Cortana selbst in Verbindung zu stehen, sondern an fehlerhaften Installation/Konfiguration der Languagepacks. 
    Hast Du auch die LPX Pakete (*.appx) installiert oder nur die *.cab?

    Da scheint eine Resource danach zu fehlen oder auf was falsches konfiguriert zu sein:

    PRIMARY_PROBLEM_CLASS:  STOWED_EXCEPTION

    STACK_TEXT:  
    00000229`6abac508 00007ffb`73628a87 Windows_UI_Xaml!CMRTResource::Load+0x219627
    00000229`6abac510 00007ffb`7339793c Windows_UI_Xaml!XamlNodeStreamCacheManager::GetXamlBinaryReader+0x7c
    00000229`6abac518 00007ffb`73396307 Windows_UI_Xaml!XamlNodeStreamCacheManager::GetXamlReader+0x10b
    00000229`6abac520 00007ffb`732d6a02 Windows_UI_Xaml!CParser::LoadXamlCore+0x362
    00000229`6abac528 00007ffb`7327c174 Windows_UI_Xaml!CCoreServices::ParseXamlWithExistingFrameworkRoot+0x128
    00000229`6abac530 00007ffb`73397622 Windows_UI_Xaml!CApplication::LoadComponent+0x226
    00000229`6abac538 00007ffb`73408c1e Windows_UI_Xaml!Application_LoadComponent+0xae
    00000229`6abac540 00007ffb`73408a7c Windows_UI_Xaml!DirectUI::FrameworkApplication::LoadComponent+0xd8
    00000229`6abac548 00007ffb`733077a4 Windows_UI_Xaml!DirectUI::DXamlCore::EnsureCoreApplicationInitialized+0x9c
    00000229`6abac550 00007ffb`732ff6ea Windows_UI_Xaml!DirectUI::FrameworkView::Initialize+0x8a
    00000229`6abac558 00007ffb`a1ae9cf7 twinapi_appcore!Windows::ApplicationModel::Core::CoreApplicationView::CreateAndInitializeFrameworkView+0x147
    00000229`6abac560 00007ffb`a1ac859d twinapi_appcore!Windows::ApplicationModel::Core::CoreApplicationViewAgileContainer::InitializeView+0x2cd
    00000229`6abac568 00007ffb`a1ac7291 twinapi_appcore!<lambda_f57724dc141dec833c6b65286717f0de>::<lambda_invoker_cdecl>+0x61
    00000229`6abac570 00007ffb`ac02dcb4 SHCore!_WrapperThreadProc+0xc4
    00000229`6abac578 00007ffb`ac5c7bd4 kernel32!BaseThreadInitThunk+0x14
    00000229`6abac580 00007ffb`aceaced1 ntdll!RtlUserThreadStart+0x21

    --

    0:015> ~15
    . 15  Id: 4388.a78 Suspend: 1 Teb: 000000a8`a4f63000 Unfrozen
          Start: MrmCoreR!Windows::ApplicationModel::Resources::Core::LanguageChangeNotifyThreadProc (00007ffb`948962d0)
          Priority: 0  Priority class: 32  Affinity: f


    • Bearbeitet Mijanek Montag, 3. Februar 2020 15:33
    Montag, 3. Februar 2020 12:45
  • Hallo zusammen,

    wir sind gerade am ausprobieren der 1909 und haben ein ähnliches Problem. Wir installieren ein englisches OS und dann die Sprachen hinterher. Wir haben ebenfalls die .cab Dateien benutzt und dann bei der jeweiligen Sprache das Problem mit dem Startmenü und die exakt gleichen Fehler im Eventlog. Stellen wir zurück auf Englisch funktioniert es einwandfrei.

    Bei uns hat es geholfen das Local Experience Pack er jeweiligen Sprache über den Microsoft Store zu installieren:
    
    Danach funktionierte das Startmenü normal. Noch bin ich nicht soweit es per Script zu implementieren, das probiere ich erst die kommenden Tage aus. Es gibt dazu in den docs.microsoft.com eine Anleitung.

    Viel Glück weiterhin.

    Gruß

    Dienstag, 4. Februar 2020 15:45
  • Ich konnte bei uns den Fehler mit dem Funktionsupdate zumindest lokalisieren. 

    bei 1909 scheint es erforderlich zu sein, dass auch die LanguageExperiencePack.de-de.Neutral.appx installiert wird. Dies wird bei uns in Post-OOBE auch durchgeführt, jedoch schlägt es (ohne Fehlermeldung) fehl. 


    Für den SearchUI lässt sich das leicht beheben, in dem man die datei:

    c:\Windows\SystemApps\Microsoft.Windows.Cortana_cw5n1h2txyewy\pris\resources.de-DE.pri (150.344 bytes) gegen der aus dem APPX paket manuell austauscht (150.408 bytes), danach funktioniert die Startmenü-Suche wieder einwandfrei. Da bei uns jedoch auch die restlichen Systemkomponenten betroffen sind, ist dies nur eine "Umgehungslösung" des wahren Problems. 

    Die Frage was sich stellt ist, warum lässt sich nicht das gesamte APPX sauber anwenden?


    • Bearbeitet Mijanek Freitag, 7. Februar 2020 07:24 Der fürhere Verdacht auf Korrupte Berechtigung hat sich nicht bestätigt
    Mittwoch, 5. Februar 2020 09:05
  • I was able to at least locate the error with the function update.

    at 1909 it seems necessary that the LanguageExperiencePack.de-en.Neutral.appx is also installed. This is also done in Post-OOBE, but it fails (without error message).


    For searchUI, this can be easily fixed by using the file:

    c:-Windows-SystemApps-Microsoft.Windows.Cortana_cw5n1h2txyewy-pris-resources.de-DE.pri (150.344 bytes) for the manually replaced from the APPX package (150.408 bytes), after which the Start Menu search works properly again. However, since we also affect the rest of the system components, this is only a "workaround" of the real problem.

    The question is, why can't the entire APPX be used cleanly?


    Can you elaborate on how to replace the appx package?
    Mittwoch, 4. März 2020 19:27