locked
Windows 7 Miniaturanwendungen überlagern sporadisch andere Anwendungen RRS feed

  • Frage

  • Auf meinem Windows 7 Ultimate habe ich das Problem, dass sich die Gadgets zeitweise in den Vordergrund drängen und andere Anwendungen überlagern.
    Man bekommt die Miniaturanwendungen dann im Guten auch nicht wieder in den Hintergrund.
    Das Verhalten der Gadgets ist eine Weile normal, wenn ich die Sidebar.exe im Taskmanager abschieße und neu starte. Eine Weile später (Auslöser unbekannt) stehen die Miniaturanwendungen dann permanent wieder im Vordergrund.

    Die Gadget Option "Immer im Vordergrund" ist nicht gesetzt. Wenn ich "Immer im Vordergrund" anklicke, wird das Häckchen auch nicht gesetzt. Die Option ist also permanent deaktiv.

    Im Moment benutze ich die Gadgets nicht mehr, weil es einfach nur stört, wenn sie die Anwendungsfenster überlagern.
    Allerdings möchte ich auf dieses Feature nicht permanent verzichten.

    Wäre schön, wenn Jemand einen Tip hat, wie ich das Problem beseitigen kann.

    Schöne Gruße,
    Jens

     

    Mittwoch, 5. Mai 2010 07:21

Antworten

  • Neue Erkenntnisse bzw. Teilerfolge.

     

    Ich habe den Cache Ordner und die Settings.ini aus dem Ordner "%appdata%\..\Local\Microsoft\Windows Sidebar" gelöscht und mich neu angemeldet, damit das Profil neu geladen wird.

    Seither kann ich das Häckchen "immer im Vordergrund" setzen und auch wieder herausnehmen. 

    Wenn die Gadges jetzt dauerhaft brav im Hintergrund bleiben haben wir eine Lösung...

    MFG

    Jens

    Freitag, 7. Mai 2010 19:25
  • ok, dann hast du eine Lösung.

    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Samstag, 8. Mai 2010 20:41

Alle Antworten

  • Hallo,

    > Eine Weile später (Auslöser unbekannt) stehen die Miniaturanwendungen dann permanent wieder im Vordergrund.

    Start > Ausführen > msconfig > Systemstart > alles deaktivieren
    Start > Ausführen > msconfig > Dienste > alle Microsoft Dienste ausblenden > die verbleibenden deaktivieren > Neustart
    Passiert es immer noch?


    Gruß Sven
    Mittwoch, 5. Mai 2010 18:03
  • Ja, leider.
    Es hat etwa 10- 15 Minuten gedauert und dann waren die Gadges wieder im Vordergrund.
    Die Zeiten sind aber sehr variabel. Mit Glück bleiben die Miniaturanwendungen auch mal 1-2 Tage im Hintergrund. Manchmal dauert es auch nur wenige Minuten.

    Mich irritiert, dass ich die Checkbox "Immer im Vordergrund" nicht manuell aktivieren kann.
    So, als würde das Vordergrundverhalten durch eine Policy vorgegeben werden.
    In der GPO Suche http://gps.cloudapp.net/default.aspx habe ich keine entsprechende GPO gefunden, die ich einfach setzen könnte. Wäre auch zu schön gewesen...

     

    Gruß

    Jens

     

     

     

     

     

    Mittwoch, 5. Mai 2010 19:22
  • Das ist "By-Design". Du kannst nur probieren die alte Vista Sidebar unter Windows 7 zum Laufen zu bekommen.
    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Mittwoch, 5. Mai 2010 22:07
  • Das ist "By-Design". Du kannst nur probieren die alte Vista Sidebar unter Windows 7 zum Laufen zu bekommen.
    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/


    Hallo Andre,

    ich kann mir beim besten Willen nicht vorstellen, dass die Minianwendungen so designt wurden, dass sie sich sporadisch vor den Applikationsfenstern anderer Anwendungen "herumtummeln" und überall beim Klicken stören sollen. Was könnte MS Deiner Meinung nach mit dieser Implementation erreichen wollen?

    Im Übrigen kann ich das Häckchen "Immer im Vordergrund" auf sämtlichen mir zur Verfügung stehenden Windows 7 Systemen nach Belieben setzen und entfernen. Bei mir bewirkt der Klick auf den Popup-Menüeintrag "Immer im Vordergrund" einfach nichts. Das Häckchen wird nie gesetzt.
    Nirgends setzen sich die Gadges auf einmal ungewollt im Vordergrund fest. Das ist nur auf meinem PC so.

    Gruß,
    Jens

     

     

    Mittwoch, 5. Mai 2010 22:36
  • Neue Erkenntnisse bzw. Teilerfolge.

     

    Ich habe den Cache Ordner und die Settings.ini aus dem Ordner "%appdata%\..\Local\Microsoft\Windows Sidebar" gelöscht und mich neu angemeldet, damit das Profil neu geladen wird.

    Seither kann ich das Häckchen "immer im Vordergrund" setzen und auch wieder herausnehmen. 

    Wenn die Gadges jetzt dauerhaft brav im Hintergrund bleiben haben wir eine Lösung...

    MFG

    Jens

    Freitag, 7. Mai 2010 19:25
  • ok, dann hast du eine Lösung.

    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Samstag, 8. Mai 2010 20:41
  • Das Problem tritt wiederhin auf.

    Inzwischen habe ich eine reproduzierbare Ursache gefunden.

    In einer zusätzlichen Symbolleiste in der Taskleiste habe ich mir u.a. das Symbol "Desktop anzeigen" "an der gewohnten Stelle" abgelegt.

    "Desktop anzeigen.scf"

    [Shell]
    Command=2
    IconFile=explorer.exe,3
    [Taskbar]
    Command=ToggleDesktop
    Wenn auf meinem 2. Monitor z.B. ein maximiertes Explorer-Fenster oder eine andere Fullscreen Anwendung offen ist und ich auf das "Desktop anzeigen" Icon klicke, dann springen die Gadges vor das maximierte Fenster auf den 2. Monitor. Nur die Anwendungen auf Monitor 1 werden minimiert. Die Miniaturanwendungen bleiben dann bis zum "abschießen" der Sidebar.exe permanent im Vordergrund.

    Scheinbar ist der Workaround KB 190355 nicht mehr so ganz Windows 7 kompatibel.

    Kennt jemand eine Alternative?
    Auf der rechten Taskleistenseite finde ich den "Desktop anzeigen" Button einfach unpraktisch und "Win+M" ist auch nicht immer meine erste Wahl.
    Wenn möglich möchte ich auf das zusätzliche Icon an der "alten Stelle" nicht verzichten.

    Gruß,

    Jens

    Mittwoch, 26. Mai 2010 09:11
  • Hallo,

    > Die Miniaturanwendungen bleiben dann bis zum "abschießen" der Sidebar.exe permanent im Vordergrund.

    klingt für mich wie ein Treiberproblem, insbesondere Grafik.
    Was passiert in einem neuen Benutzerprofil?


    Gruß Sven
    Donnerstag, 27. Mai 2010 06:03
  • Ich installiere in der Regel die aktuellen Nvidia Treiber aus dem Windows Update Katalog.

    Unter einem neuen Benutzerprofil konnte ich den Fehler nicht (sofort) nachstellen.
    Ich habe unter meinem Profil jetzt wieder die Settings.ini in "%appdata%\..\Local\Microsoft\Windows Sidebar" mit der aus dem neuem Benutzerprofil ersetzt. Erst eninmal ist wieder alles OK. Den zuvor reproduzierbaren Fehler mit der "Desktop anzeigen" Verknüpfung habe ich momentan auch gerade nicht mehr.

    Ich habe mit jetzt den offensichtlich funktionierenden Stand der Settings.ini gesichert. Wenn der Fehler wieder mal da ist, dann bringt ein Dateivergleich hoffentlich Aufschluss.

    Gruß,
    Jens

     

    Donnerstag, 27. Mai 2010 06:39