locked
IPv6 Stateless Autokonfiguration deaktivieren und IPv6 Adresse von DHCP bekommen RRS feed

  • Frage

  • Hallo liebe Community,

    ich habe ein Problem mit der IPv6 Konfiguration eines Hosts.

    Ich bin Student und bearbeite in meiner Studienarbeit die Implementierung von IPv6 mit Windows 7.

     

    Mein Problem ist, dass ich einen Host, der zuvor keine IPv6 Adresse besitzt, an einen Cisco Router mit integrierten DHCP Server angeschlossen wird. Der Host bekommt beim Anschließen an den Router eine IPv6 Adresse geleaset. Das Leasing ist soweit in Ordnung.

    Aber der Host konfiguriert sich noch selbstständig eine IPv6 Adresse anhand des Präfixes, dass er durch die Router Advertisement Message erhält. Diese automatische Konfiguration der zusätzlichen Adresse möchte ich gerne abstellen. Denn wenn ich mit DHCP arbeite möchte ich schon gerne dass der Host nur vom DHCP seine IPv6 Adresse bekommt und nicht anders.

     

    Der Ausschnitt von ipconfig /all sieht folgendermaßen aus:

     

    Ethernet-Adapter LAN-Verbindung 2:

     

       Verbindungsspezifisches DNS-Suffix: studentennetz.com

       Beschreibung. . . . . . . . . . . : Broadcom NetXtreme-Gigabit-Ethernet

       Physikalische Adresse . . . . . . : 00-10-18-3A-5F-D5

       DHCP aktiviert. . . . . . . . . . : Ja

       Autokonfiguration aktiviert . . . : Ja

       IPv6-Adresse. . . . . . . . . . . : 2003::1:24de:5c73:9a05:e13c(Bevorzugt)

       Lease erhalten. . . . . . . . . . : Mittwoch, 18. Januar 2012 14:55:19

       Lease läuft ab. . . . . . . . . . : Mittwoch, 18. Januar 2012 15:30:52

       IPv6-Adresse. . . . . . . . . . . : 2003::1:d828:82e9:c847:6d49(Bevorzugt)

       Verbindungslokale IPv6-Adresse  . : fe80::d828:82e9:c847:6d49%13(Bevorzugt)

       IPv4-Adresse (Auto. Konfiguration): 169.254.109.73(Bevorzugt)

       Subnetzmaske  . . . . . . . . . . : 255.255.0.0

       Standardgateway . . . . . . . . . : fe80::21e:7aff:fea3:6668%13

       DHCPv6-IAID . . . . . . . . . . . : 301994008

       DHCPv6-Client-DUID. . . . . . . . : 00-01-00-01-14-E4-5A-A9-00-21-9B-71-DC-60

       DNS-Server  . . . . . . . . . . . : 2003:0:0:1::25

       NetBIOS über TCP/IP . . . . . . . : Aktiviert

       Suchliste für verbindungsspezifische DNS-Suffixe: studentennetz.com

     

    Die IPv6 Adresse unter der Zeile „Lease läuft ab. . . . . . . . . . : Mittwoch, 18. Januar 2012 15:30:52“ soll der Host nicht automatisch konfigurieren.

     

    Gibt es einen netsh Befehl mit dem ich die automatische Konfiguration deaktivieren kann?

    Falls es keinen Befehl gibt. Wie kann ich einstellen, dass er die vom DHCP Server erhaltene IPv6 Adresse von der Priorität als erstes nutzen soll?

     

    Zusätzlich noch die Konfiguration von der Routerschnittstelle. Vielleicht sieht ja jemand einen Fehler

    !

    ipv6 unicast-routing

    ipv6 cef

    ipv6 dhcp pool testgroup

     address prefix 2003:0:0:1::/64 lifetime 1800 600

     link-address 2003:0:0:1::/64

     dns-server 2003:0:0:1::25

     domain-name studentennetz.com

    !

    !

    interface FastEthernet0/0

     description Verbindung zu den Hosts

     

     duplex auto

     speed auto

     ipv6 address 2003:0:0:1::1/64

     ipv6 nd managed-config-flag

     ipv6 nd other-config-flag

     ipv6 dhcp server testgroup

     !

     

     

    Danke schon mal für eure Hilfe

     

    Gruß

    Massi


    • Bearbeitet Massi87 Mittwoch, 18. Januar 2012 14:38
    Mittwoch, 18. Januar 2012 14:18