none
Failover Cluster Manager Server 2012, keine Verbindung mit dem Cluster RRS feed

  • Frage

  • Fehler im Failover Cluster Manager:

    Image

    Fehler im Hyper-V-Manager:

    Image

    Im gleichen Zusammenhang, kann ich auf dem Hyper-V-Manager mich nicht mit dem Clusternode HyperV09 verbinden. Der Fehler hat vermutlich dieselbe Ursache!?!Manchmal ist der Fehler auch auf mehreren Hyper-V-Host. Nach einem Neustart des fehlerhaften Host, ist das Problem für einige Zeit wieder behoben!?!

    Freitag, 5. September 2014 10:07

Antworten

  • Hi,

    ist auf den Servern evtl. die Firewall aktiv?

    Die Fehlermeldung mit dem Cluster macht mich stutzig, weil der normalerweise selbst bei Ausfall eines Knotens noch leben sollte (das wird dann einfach von den restlichen Knoten übernommen). Welche Clusterkonfiguration verwendest Du denn?

    Erreichst Du den betroffenen Server dann noch per Ping/RDP? Reagiert er auf Eingaben? Bringt es was, nur den Clusterdienst neu zu starten?

    Haben die Server alle die aktuellsten Treiber und Firmwares installiert?

    Ansonsten habe ich noch das hier gefunden:

    http://social.technet.microsoft.com/Forums/en-US/42b38236-a18a-4fc1-9e36-c6ec4c97bff7/the-requested-object-does-not-exist-exception-from-hresult-0x80010114?forum=winserverClustering


    Gruß
    Ben
    MCITP Windows 7

    Wenn Dir meine Antwort hilft, markiere sie bitte entsprechend als Antwort! Danke! :-)

    Hinweis: Meine Posts werden "wie besehen" ohne jedwede Gewähr bereitgestellt, da menschliche, technische und andere Fehler nicht ausgeschlossen werden können.

    • Als Antwort markiert DEug Montag, 8. September 2014 06:20
    Freitag, 5. September 2014 10:53

Alle Antworten

  • Hi,

    ist auf den Servern evtl. die Firewall aktiv?

    Die Fehlermeldung mit dem Cluster macht mich stutzig, weil der normalerweise selbst bei Ausfall eines Knotens noch leben sollte (das wird dann einfach von den restlichen Knoten übernommen). Welche Clusterkonfiguration verwendest Du denn?

    Erreichst Du den betroffenen Server dann noch per Ping/RDP? Reagiert er auf Eingaben? Bringt es was, nur den Clusterdienst neu zu starten?

    Haben die Server alle die aktuellsten Treiber und Firmwares installiert?

    Ansonsten habe ich noch das hier gefunden:

    http://social.technet.microsoft.com/Forums/en-US/42b38236-a18a-4fc1-9e36-c6ec4c97bff7/the-requested-object-does-not-exist-exception-from-hresult-0x80010114?forum=winserverClustering


    Gruß
    Ben
    MCITP Windows 7

    Wenn Dir meine Antwort hilft, markiere sie bitte entsprechend als Antwort! Danke! :-)

    Hinweis: Meine Posts werden "wie besehen" ohne jedwede Gewähr bereitgestellt, da menschliche, technische und andere Fehler nicht ausgeschlossen werden können.

    • Als Antwort markiert DEug Montag, 8. September 2014 06:20
    Freitag, 5. September 2014 10:53
  • Hallo Ben

    Die FW sind aktiv!

    Es ist ein 4 Node Cluster 2012 DataCenter in Deutsch

    Bei diesem Fehler sind alle VMOnline, alle 4 Host sind OK, alles kein Problem! Nur wen der Cluster Manager gestartet wird, findet er keinen Cluster, auch nicht wenn dann manuell der Cluster angewählt wird! (siehe Fehlermeldung)

    Dasselbe Verhalten ist mit dem Hyper-V Manager, der "fehlerhafte" Host kann nicht verbunden werden! (siehe Fehlermeldung)

    So finde ich wenigstens den fehlerhaften Host und nach einem Neustart des Host ist das Problem für einige Wochen wieder behoben!?!

    Wenn ein Host ein "Problem" hat, findet der Cluster Manager auf allen 4 Host den Cluster nicht mehr, auch von "extern" nicht!

    Clusterdienst neu starten ist vermutlich heikel in einer prod. Umgebung.

    Alle Server haben akt. Treiber und Firmware!

    Bei deinem Link bin ich mir nicht so sicher was im ersten Teil mit PowerShel angepasst wird?

    Der 2. Teil "MemoryPerHost" von 512MB auf 1 GB vergrössern ist soweit klar, ist das empfehlenswert?

    Vielen Dank!

    Gruss Dani

    Freitag, 5. September 2014 12:36
  • Hi,

    das ist aber sehr schlecht, wenn der Failovercluster ausfällt, wenn nur ein Host nicht verfügbar ist. Dafür macht man ja gerade einen Failovercluster, damit sowas kein Problem wird... 

    Wenn die VMs durch den Ausfall des Clusters schon nicht beeinträchtigt werden und Du den ganzen Host neu starten kannst, ohne dass was passiert, dann kannst Du auch beruhigt den Dienst auf dem betroffenen Host neu starten.

    Den Befehl "wbemtest" kannst Du auch in einer normalen Eingabeaufforderung (als Administrator) ausführen, dafür braucht es die Powershell nicht. Da wird wohl der Wert "HandlesPerHost" erhöht. 

    Hast Du die bisher erschienenen Update Rollups für Server 2012 installiert? Das wird ja auch noch erwähnt (zumindest das eine)


    Gruß
    Ben
    MCITP Windows 7

    Wenn Dir meine Antwort hilft, markiere sie bitte entsprechend als Antwort! Danke! :-)

    Hinweis: Meine Posts werden "wie besehen" ohne jedwede Gewähr bereitgestellt, da menschliche, technische und andere Fehler nicht ausgeschlossen werden können.

    • Als Antwort markiert DEug Montag, 8. September 2014 06:19
    • Tag als Antwort aufgehoben DEug Montag, 8. September 2014 06:20
    Freitag, 5. September 2014 13:35
  • Hallo Ben

    Auch wenn ein "Fehler" im Management des Clusters auftaucht ist es für den Betrieb kein Problem wenn keine Änderungen gemacht werden müssen
    Die 4 Host im Cluster mit den vielen VM's arbeiten normal weiter, es sind keine Probleme feststellbar. Es ist "nur" das managen das nicht funktioniert. In diesem Zustand kann nichts geändert werden oder keine Live Migration ausgelöst werden weil mit den Management Tools keine Verbindung zum Cluster aufgebaut werden kann.

    Der erwähnte Update Rollup habe ich vor einiger Zeit standartmässig mit dem WSUS zugeteilt.

    Nun habe ich das wbemtest.exe so ausgeführt wie es im Deinem Link beschrieben ist. Wir werden dann nach dem Reboot der Hosts und einigen Wochen dann feststellen können ob das Problem gelöst wurde.

    Auf Alle Fälle jetzt schon herzlichen Dank!

    Gruss Dani

    Freitag, 5. September 2014 15:17
  • Das problem ist mir bekannt. Haben wir leide auch noch. Ist ein Bug welches im Update Rollup von August behoben sein sollte. Leider wurde dieser Patch wegen anderen Fehlern zurückgezogen.

    Probiere mal PowerShell aufzumachen und GetNetadapter aufzurufen. Sollte auch nicht gehen.

    Hier hilft leider nur eins, neustart. Den ein stoppen des WMI Dienst ist leider auch nicht ohne weiteres möglich, dieser bleibt beim stoppen hängen.

    Ursache ist das WMI Quotas erreicht und nicht geleert werden. Man diese auf allen HyperV Cluster erhöhen:

    Go to Start--> Run and type wbemtest.exe. 
    Click Connect.  
    In the namespace text box type "root" (without quotes). 
    Click Connect. 
    Click Enum Instances… 
    In the Class Info dialog box enter Superclass Name as "__ProviderHostQuotaConfiguration" (without quotes) and press OK. Note: the Superclass name includes a double underscore at the front. 
    In the Query Result window, double-click "__ProviderHostQuotaConfiguration=@" 
    In the Object Editor window, double-click HandlesPerHost. 
    In the Value dialog, type in 8192 
    Click Save Property. 
    Click Save Object. 
    Close Wbemtest. 
    Restart the computer.
    

    Dies verschiebt leider nur das Problem.

    Was wir gemacht haben, Isolation des WMI Dienst in eigene svchost. Diese kann man dann über Task Manager abschießen.

    bzw. Verschiebe dein Cluster auf einen anderen Host über PowerShel:

    Import-module failoverclustersMove-ClusterGroup -Name "Cluster Group" -Node HYPERV07

    Dann kanns du schonmal auf dein Cluster zugreifen.

    Gruss

    Samstag, 6. September 2014 21:27
  • Am 06.09.2014 schrieb its-eugen:

    Das problem ist mir bekannt. Haben wir leide auch noch. Ist ein Bug welches im Update Rollup von August behoben sein sollte. Leider wurde dieser Patch wegen anderen Fehlern zurückgezogen.

    Die Updates für W8.1 wurden am 02.09.2014 wieder ausgerollt, sind die
    nicht die für W2012R2 auch dabei?


    Servus
    Winfried

    Gruppenrichtlinien
    WSUS Package Publisher
    HowTos zum WSUS Package Publisher
    NNTP-Bridge für MS-Foren

    Sonntag, 7. September 2014 08:26
  • Hallo zusammen,

    hier der Downloadlink:

    http://www.microsoft.com/de-DE/download/details.aspx?id=44051


    Gruß
    Ben
    MCITP Windows 7

    Wenn Dir meine Antwort hilft, markiere sie bitte entsprechend als Antwort! Danke! :-)

    Hinweis: Meine Posts werden "wie besehen" ohne jedwede Gewähr bereitgestellt, da menschliche, technische und andere Fehler nicht ausgeschlossen werden können.

    Sonntag, 7. September 2014 17:50
  • Guten Morgen ist-eugen

    Danke für Deine Ergänzung.

    Weisst Du schon ob das Problem bei den korrigierten August Updates vor einigen Tagen behoben wurde?
    Wenn ja bei welchem?

    Vielen Dank!

    Gruss

    Montag, 8. September 2014 06:23
  • Hi,

    wenn Du unter "Liste behobener Probleme" (besser in Englisch schauen, die deutsche Übersetzung ist schlimm, also "List of fixed issues") schaust, werden u.a. folgende Punkte gelistet:

    • 2972257 Windows Server 2012 R2-based cluster freezes on multiple nodes when you add, rename, or remove disks
    • 2972254 Hyper-V virtual machines cannot be connected to sometimes when TCP connections reconnect in Windows Server 2012 R2
    • 2978691 Stop error when scrubbing task takes a long time on a Windows 8.1 or Windows 2012 R2-based cluster
    • 2976884 "Access denied error" when Hyper-V Replica Broker goes online in a Windows Server 2012 or Windows Server 2012 R2 cluster

    Ansonsten empfehle ich Dir noch folgende Liste:

    http://support.microsoft.com/kb/2920151/de


    Gruß
    Ben
    MCITP Windows 7

    Wenn Dir meine Antwort hilft, markiere sie bitte entsprechend als Antwort! Danke! :-)

    Hinweis: Meine Posts werden "wie besehen" ohne jedwede Gewähr bereitgestellt, da menschliche, technische und andere Fehler nicht ausgeschlossen werden können.

    Montag, 8. September 2014 06:48
  • Hoi Ben

    Danke für Deine Info!

    Hast Du mir eine solche Liste für Server 2012 basierten Failover-Cluster? (Dein Link war für Windows Server 2012 R2-basierten Failover-Cluster)

    Vielen Dank!

    Gruss

    Montag, 8. September 2014 07:02
  • Hi,

    Du solltest doch auch des Googelns (oder Bingens oder Yahooens) mächtig sein... ;-)

    http://support.microsoft.com/kb/2784261/de


    Gruß
    Ben
    MCITP Windows 7

    Wenn Dir meine Antwort hilft, markiere sie bitte entsprechend als Antwort! Danke! :-)

    Hinweis: Meine Posts werden "wie besehen" ohne jedwede Gewähr bereitgestellt, da menschliche, technische und andere Fehler nicht ausgeschlossen werden können.

    Montag, 8. September 2014 07:17
  • Hallo zusammen,

    wir sind auch von dem genannten Problem betroffen.

    Das Updaterollup August 2014 für Win8 und Server2012 (nicht R2) enthält (laut Liste) keine Updates die das Problem beheben.

    >>> http://support.microsoft.com/kb/2975331/en-us

    Gibt es zwischenzeitlich alternative (offizielle) Lösungen ? Im Netz kann ich keine weiteren Artikel dazu finden.

    Gruß,
    Martin

    Donnerstag, 25. September 2014 09:24