none
OWA2010: Maximale Anhanggröße konfigurierbar? RRS feed

  • Frage

  • Hallo Zusammen!

    Wir haben hier ein "neues" MSX2010 hochgezogen.

    Alles geht.

    Die Mailgrößenbeschränkungen im Hubtransport und ClientAccess habe ich angehoben und die Outlookuser können auch Mails größer al 10MB versenden.

    Komischerweise geht es über OWA nicht.

    Wenn ich da eine große Datei hochladen will, bekomme ich eine Fehlermeldung

    "http: 404.13 Das Anforderungsfiltermodul ist so konfiguriert, dass Anforderungen abgelehnt werden, die die Anforderungsinhaltslänge überschreiten"

    Also denke ich mal, dass ich im IIS noch irgendwas konfigurieren muss - aber ich finde es werder hier noch im Technet oder in google - und im Fußball haben wir auch verloren - vermutlich weil ich nicht gucken konnte ;-))

    LG und Danke im voraus... Jochen

    Freitag, 18. Juni 2010 13:50

Antworten

Alle Antworten

  • Hi Jochen
     
    > Hallo Zusammen!
    >
    > Wir haben hier ein "neues" MSX2010 hochgezogen.
    >
    > Alles geht.
    >
    > Die Mailgrößenbeschränkungen im Hubtransport und ClientAccess habe ich angehoben und die Outlookuser können auch Mails größer al 10MB versenden.
     
    Wo genau?
     
    > Komischerweise geht es über OWA nicht.
    >
    > Wenn ich da eine große Datei hochladen will, bekomme ich eine Fehlermeldung
    >
    > "http: 404.13 Das Anforderungsfiltermodul ist so konfiguriert, dass Anforderungen abgelehnt werden, die die Anforderungsinhaltslänge überschreiten"
    >
    > Also denke ich mal, dass ich im IIS noch irgendwas konfigurieren muss - aber ich finde es werder hier noch im Technet oder in google
     
    ..im Technet nicht? Was ist denn das? ;-)
     
    > - und im Fußball haben wir auch verloren - vermutlich weil ich nicht gucken
    > konnte ;-))
     
    ...ich habes gesehen und ... :'( Die rote Karte von Klose war unnötig und
    dann hätten wir gesiegt!!! Ich bin mir sicher wir werden WM!!!
     
    Viel Grüße
    Christian
     
    Freitag, 18. Juni 2010 14:33
    Moderator
  • Asche auf mein Haupt - DANKE!!!

    Ich will auch dass wir WM werden ;-)))

    Freitag, 18. Juni 2010 14:43
  • Hm, ich habe den WErt erhöht (stand zwar schon auf 30000, bin jetzt auf 100000) aber auch nach einen iisreset kann ich eine 20MB-PDF noch nicht hochladen.

    Was mache ich falsch?

    LG Jochen

    • Als Antwort markiert jkontny Freitag, 18. Juni 2010 17:09
    • Tag als Antwort aufgehoben jkontny Freitag, 18. Juni 2010 17:09
    Freitag, 18. Juni 2010 15:02
  • So, ich bin einen Schritt weiter.

    Das reine Ändern des MaxRequestLength hatte es nich nicht gebracht.

    Ich habe zusätzlich

    appcmd set config "Default Web Site/owa" -section:requestFiltering -requestLimits.maxAllowedContentLength:112640000

    ausgeführt.

    Nun klappt das Versenden einer 60MB Datei aus OWA heraus einwandfrei.

    Leider haben wir aber im EWS (nutzen die Mac-User mit ihrem Entourage 2008) das gleiche Problem.

    Nur steht in der web.config des EWS schon ein viel größerer Wert für MaxRequestLength als im owa-web.config (bzw er taucht an verschiedenen Stellen mit unterschiedlichen Werten auf). Daher traue ich da nicht so ran...

    Gibt es dazu vielleicht auch noch einen Tipp?

    Danke im Voraus... Jochen

       

    Freitag, 18. Juni 2010 17:48
  • Hi Jochen,
     
    > Hm, ich habe den WErt erhöht (stand zwar schon auf 30000, bin jetzt auf 100000) aber auch nach einen iisreset kann ich eine 20MB-PDF noch nicht hochladen.
    >
    > Was mache ich falsch?
    >
    > LG Jochen
    hier ist nochmal ein etwas genauere Anleitung:
     
     
    ...selber probieren schaffe ich gerade nicht, aber ich habe ein paar Seiten
    für dich zum Durcharbeiten:
     
    Damit schaffst du es bestimmt! :-) Gib uns nen feedback...
     
    Viele Grüße
    Christian
     
    Freitag, 18. Juni 2010 19:13
    Moderator
  • Hi Jochen,
     
    > Leider haben wir aber im EWS (nutzen die Mac-User mit ihrem Entourage 2008) das gleiche Problem.
    >
    > Nur steht in der web.config des EWS schon ein viel größerer Wert für MaxRequestLength als im owa-web.config (bzw er taucht an verschiedenen Stellen mit unterschiedlichen Werten auf). Daher traue ich da
    > nicht so ran...
     
    Irgendwie kam der erste Post nicht durch - schau dir zu EWS die
    Beschreibung hier an:
     
    Viele Grüße
    Christian
     
    Freitag, 18. Juni 2010 19:22
    Moderator
  • Hallo Christian!

    Eigentlich habe ich das alles gemacht.

    Nur bei dem Befehl zum Anpassen der maxallowedcontentlength (appcmd set config "Default Web Site/ews" -section:requestFiltering -requestLimits.maxAllowedContentLength: xxxx) habe ich aus Feigheit als Parameter zunächst den in Byte umgerechneten Wert aus der web.config (xxxx=2147482624) verwendet.

    Nun habe ich es nochmals mit xxx=112640000 versucht (hat ja beim owa auch geklappt) und den iis neu gestartet.

    Nun wollen wir mal den Montag abwarten (von hier komme ich nämlich nicht auf die "MACese")...

    Danke und schönes WE... Jochen

     

    Samstag, 19. Juni 2010 08:04
  • So, hat mir keine Ruhe gelassen - tut's jetzt auch bei den MACs!!

    Danke!!! Jochen

    Samstag, 19. Juni 2010 16:47
  • Am 19.06.2010 schrieb jkontny:

    Hi,

    So, hat mir keine Ruhe gelassen - tut's jetzt auch bei den MACs!!

    Und woran lags?

    Bye
    Norbert


    Dilbert's words of wisdom #32: If it wasn't for the last minute, nothing would get done.
    Samstag, 19. Juni 2010 17:05
  • Ich hatte bei dem Befehl

    "appcmd set config "Default Web Site/ews" -section:requestFiltering -requestLimits.maxAllowedContentLength: xxxx"

    zunächst als Paramter den Wert angegeben, den ich in der web.c onfig des EWS-Verzeichnisses gesehen habe (<httpRuntime maxRequestLength="2147482624" />

    Dieser Wert erschien mir sowieso viel zu groß.

    Ich habe den Wert in der web.config des EWS einfach ignoriert und so gelassen, aber als Parameter für den appcmd-Befehl 112640000 eingetragen.

    Nach dem iisreset geht es nun.

    Kann man dass verstehen, was ich da zu beschreiben versuche?

    LG Jochen

     

     

    Samstag, 19. Juni 2010 19:21
  • Am Sat, 19 Jun 2010 19:21:31 +0000 schrieb jkontny:
     
    Hi Jochen,
     
     
    > Ich hatte bei dem Befehl
    >
    > "appcmd set config "Default Web Site/ews" -section:requestFiltering -requestLimits.maxAllowedContentLength: xxxx"
    >
    > zunächst als Paramter den Wert angegeben, den ich in der web.c onfig des EWS-Verzeichnisses gesehen habe (<httpRuntime maxRequestLength="2147482624" />
    >
    > Dieser Wert erschien mir sowieso viel zu groß.
     
    Der Wert in der web.config ist ein integer-Wert und gibt einen KB Wert an.
    Mit 2147482624 ist das auch der max. Wert und mit 2TB vielleicht etwas
    hoch. ;-)
     
     
    > Ich habe den Wert in der web.config des EWS einfach ignoriert und so gelassen, aber als Parameter für den appcmd-Befehl 112640000 eingetragen.
     
    maxAllowedContentLength ist wiederum ein uint-Wert und wird in Byte
    angegeben:
     
     
    > Nach dem iisreset geht es nun.
    >
    > Kann man dass verstehen, was ich da zu beschreiben versuche?
     
    Eigentlich hätte es vorher auch passen sollen, obwohl die gleichen Werte
    nicht aufeinander abgestimmt sind. Vielleicht passt du sie noch etwas an...
     
    Grüße
    Christian
     
    Sonntag, 20. Juni 2010 11:11
    Moderator
  • Das mit den verschiedenen Datentype habe ich auch berücksichtigt und entspr. umgerechnet.

    Der "Riesenwert" in der web.config des EWS ist bei der Standardinstallation eingetragen worden und die Variable "httpRuntime maxRequestLength" steht dort auch an mehreren Stellen, deren Bedeutung/Unterschied ich so nicht blicke.

    Da jetzt alles geht, kann ich ihn doch einfach so lassen - oder?

    LG Jochen

    Sonntag, 20. Juni 2010 12:37
  • Hi Jochen,
     
    > Das mit den verschiedenen Datentype habe ich auch berücksichtigt und entspr. umgerechnet.
    >
    > Der "Riesenwert" in der web.config des EWS ist bei der Standardinstallation eingetragen worden und die Variable "httpRuntime maxRequestLength" steht dort auch an mehreren Stellen, deren
    > Bedeutung/Unterschied ich so nicht blicke.
     
    Das eine bezieht sich glaube ich auf den IIS und der andere speziel auf
    ASP. Bei mir war in der web.config als Standard 2097151 hinterlegt.
     
    > Da jetzt alles geht, kann ich ihn doch einfach so lassen - oder?
     
    Wenns läuft... du hast ja noch weitere Sendebeschränkungen... Man sollte
    die Werte aber eher gering halten, um DoS-Angriffe zu verhindern.
     
    Viele Grüße
    Christian
     
    Sonntag, 20. Juni 2010 16:40
    Moderator