none
Darstellungsfehler in Sharepoint 2013 RRS feed

  • Frage

  • Hallo liebe Gemeinde,

    ich habe ein Problem bei der Nutzung von Sharepoint Foundation 2013 und SQL Server Reporting Service 2012 Berichten.

    Sharepoint Foundation 2013 ist installiert auf einem virtuellem Server und läuft problemlos. In einer Sharepointseite ist eine Seiten-Viewer Webpart enthalten. Als URL ist ein SQL Server Reporting Service Bericht verlinkt der auf einem anderem Server liegt. Es funktioniert und der Bericht wird in dem Frame angezeigt; aber leider nur zur Hälfte (links) und es erscheint unten ein Rollbalken. Die rechte Seite im Webpart ist weiss.

    Wir nutzen den Internet Explorer 9.

    Stellt man im Internetexplorer per F12 die Anzeige Dokumentenmodus IE=9 auf IE = 8 um, dann wird der Bericht richtig und komplett im Frame angezeigt.

    Unter einem CHROME Browser funktioniert die Anzeige auf anhieb korrekt.

    Weiss jemand wie und wo wir Einstellungen vornehmen können, um die Anziege auch im IE9 immer korrekt zu bekommen ?

    Gruß
    Tom

    Freitag, 10. Januar 2014 13:06

Antworten

  • Hallo liebe Gemeinde,

    das Problem ließ sich jetzt beheben.

    Dazu haben wir die seattle.master Vorlage im Head geändert.

    ALT:  <meta http-equiv="X-UA-Compatible" content="IE=10"/>

    NEU:  <meta http-equiv="X-UA-Compatible" content="IE=8"/>

    Jetzt öffnet sich die Gesamtseite von Sharepopint im Dokumentenmodus 8.

    Nachteile in SP konnte ich bisher nicht entdecken.

    Gruß Tom

    • Als Antwort markiert TomSP2013 Dienstag, 14. Januar 2014 17:09
    Dienstag, 14. Januar 2014 09:37

Alle Antworten

  • Hallo Tom,

    leider wird der IE9 Modus nicht von SSRS unterstützt:

    http://connect.microsoft.com/SQLServer/feedback/details/750690/ui-issues-while-loading-ssrs-reports-in-ie9-doc-mode

    Ich glaube auch nicht, das sich Serverseitig in dieser Richtung noch etwas tun wird.

    Evtl. wäre der IE9 Kompatibilitätsmodus eine Option für euch?

    VG,
    Andrei

    Freitag, 10. Januar 2014 14:29
  • Hallo Andrei,

    vielen Dank für die Antwort. Der Link beantwortet die Frage ja grösstenteils.

    Mit dem Kompatibilitätsmodus haben wir auch schon getestet, leider ohne Erfolg.

    Hier wäre noch die Frage, ob man die Sharepoint Seite als content = "IE8" laufen lassen kann, Anpasung der SP2013 Master Seite ? Wird aber wohl in der Summe dann nicht besser ...

    Gruß

    Tom

    Montag, 13. Januar 2014 13:21
  • Hallo liebe Gemeinde,

    das Problem ließ sich jetzt beheben.

    Dazu haben wir die seattle.master Vorlage im Head geändert.

    ALT:  <meta http-equiv="X-UA-Compatible" content="IE=10"/>

    NEU:  <meta http-equiv="X-UA-Compatible" content="IE=8"/>

    Jetzt öffnet sich die Gesamtseite von Sharepopint im Dokumentenmodus 8.

    Nachteile in SP konnte ich bisher nicht entdecken.

    Gruß Tom

    • Als Antwort markiert TomSP2013 Dienstag, 14. Januar 2014 17:09
    Dienstag, 14. Januar 2014 09:37