none
Windows 10 Inplace von 1707 nach 1803 RRS feed

  • Frage

  • Hallo,

    ich habe bei einem Kunden ein komisches Verhalten nach einem Inplace festgestellt. Der Kunde setzt die Softwareverteilung DSM der Firma Ivanti ein. Über diese Softwareverteilung weise ich einem Client das Inplace zu.

    - das Setup wird mit den entsprechenden Parametern gestartet. Abhängig von Computer startet er nach ca. 20-30 Minute neu

    - das Update wird installiert (bis 100% angezeigt wird) und am Ende startet der Computer neu und ich kann mich wieder anmelden. Die Anmeldung funktioniert auch ohne Probleme.

    - DSM nutzt zur Softwareverteilung einen eigenen Dienst. Dieser Dienst überprüft beim Starten ob er Zugriff auf sein Depot hat. Direkt nach dem Inplace steht aber in den Logfiles, dass er keinen Zugriff auf sein Depot hat. Starte ich dann nach eine Benutzeranmeldung den Computer neu, funktioniert wieder alles, der Client hat wieder Zugriff auf sein Depot.

    - Spreche ich nach den Computer nach einigen Minuten an und sage er soll erneut auf sein Depot zugreifen, so funktioniert es auch wieder.

    - DSM kopiert Pakete die installiert werden sollen in einen lokalen Cache auf dem Client.

    - ich habe ein Paket erstellt, welches im Logfile nach dem oben beschrieben Fehler sucht. Wird der Fehler gefunden, so wird ein Neustart ausgeführt wenn zuvor auch erkannt wurde, dass 1803 installiert ist. Als Shutdown nutze ich shutdown.exe -r -f -t 0

    - wird er Fehler gefunden und der Neustart eingeleitet, so wird offensichtlich ein Rollback durchgeführt und nach dem Neustart ist wieder 1709 aktiv.

    Kennt jemand ein solches Netzwerkproblem direkt nach dem Inplace?

    Wieso wird ein Rollback gemacht "nur" weil ich unmittelbar nach dem Inplace einen Neustart durchführe. 

    Das beschriebene Verhalten war kein Einzelfall und ist reproduzierbar.

    Liebe Grüße

    Norbert

    PS: Das Verhalten bzgl. der Netzwerkprobleme wird bereits seit längerer Zeit auch schon im Ivanti Forum diskutiert. Mich interessiert aber wieso es dieses Netzwerkproblem gibt. Ist das Inplace nach dem letzten Neustart noch nicht fertig obwohl sich ein Benutzer anmelden kann? Was dann vielleicht das Rollback erklären würde.


    IT Berater

    Samstag, 26. Januar 2019 06:05