none
Upgrade-Fehler SCOM 2007 R2 CU5 Deutsch nach SCOM 2012 RRS feed

  • Frage

  • Hallo Forum,

    ich versuche das ganze jetzt noch mal in Deutsch (Eintrag in Englisch ist auch vorhanden ;-)).

    Ich versuche, einen SCOM 2007 R2, CU in einer komplet deutschen Installation (also deutscher Server, deutscher SQL, deutscher SCOM) auf die 2012er-Version hochzuziehen.
    Leider scheint dieses nicht zu funktionieren.
    Das Upgrade-Helper-Management-Pack ist installiert, alle Agenten wurden manuell auf den 2012-Agenten hochgezogen.
    Einzig ein Gateway-Server ist noch nicht aktualisiert.

    Der Upgrade-Wizzard lauft auch erst einmal ein paar Minuten, dann er scheint "Upgrade is incomplet":

    Aud den Log-Dateien kann ich leider nicht so wirklich erkennen, warum das Upgrade nicht erfolgreich ist.

    [15:42:18]: Always: :registryItem.KeyNameToCopy - Parameters
    [15:42:18]: Info: :SetupHelpers : CloseProcess() - GetProcessesByName did not return any process
    [15:42:18]: Info: :could not kill the process Microsoft.Mom.UI.Console.exe
    [15:42:18]: Info: :Info:preparing for MS upgrade
    [15:42:18]: Info: :Detected MOM product with ProductCode {26D71F0F-82B4-418B-96AC-BB9E54CED283}
    [15:42:18]: Always: :uninstalling product with product code: {26D71F0F-82B4-418B-96AC-BB9E54CED283}
    [15:42:18]: Info: :Info:uninstall commandline =  /i {26D71F0F-82B4-418B-96AC-BB9E54CED283} MOMV3_PRODUCT_FOUND=1  PREREQ_COMPLETED=1 REMOVE=MOMServer  /qn /l*vx "C:\Users\scomadmin\AppData\Local\SCOM\Logs\RemoveMOMServer.log"
    [15:42:18]: Debug: :GetFullPathBasedOnSetupLocation: Attempted to resolve a file at E:\Setup\AMD64\ but it wasn't found there.  Will return an empty string.
    [15:42:18]: Debug: :InstallItem.GetFullPath did not resolve a path with inputs SetupLocation, ,
    [15:42:19]: Debug: :CheckMsiMutex: Msi mutex is not in use.
    [15:42:19]: Debug: :LaunchMsi: Turning off the internal UI for .
    [15:42:19]: Debug: :LaunchMSI:  Enable logging for the MSI at C:\Users\scomadmin\AppData\Local\SCOM\Logs\RemoveMOMServer.log.
    [15:42:19]: Debug: :LaunchMsi: MSI  is not in silent mode.  Setting the external UI.
    [15:42:19]: Always: :LaunchMsi: Launching
    [15:42:19]: Always: :launching msiexec
    [15:42:19]: Always: :LaunchExeSetup: Starting process: C:\Windows\system32\msiexec.exe  /i {26D71F0F-82B4-418B-96AC-BB9E54CED283} MOMV3_PRODUCT_FOUND=1  PREREQ_COMPLETED=1 REMOVE=MOMServer  /qn /l*vx "C:\Users\scomadmin\AppData\Local\SCOM\Logs\RemoveMOMServer.log" REBOOT=ReallySuppress
    [15:42:19]: Debug: :====================================== Following is the standard output for C:\Windows\system32\msiexec.exe ======================================
    [15:44:01]: Debug: :====================================== Standard output for C:\Windows\system32\msiexec.exe Complete ======================================
    [15:44:01]: Always: :LaunchExeSetup: Complete: 103 seconds
    [15:44:01]: Always: :LaunchExeSetup: Failed, return code: 1603
    [15:44:01]: Always: :MsiInstallProduct finished for msi .
    [15:44:02]: Always: :LaunchMsiSetup: Complete: 103 seconds
    [15:44:02]: Error: :LaunchMsiSetup: Failed, return code: 2
    [15:44:02]: Error: :Error:Failed to uninstall previous MOM product on this machine, cannot proceed with upgrade
    [15:44:02]: Error: :Error:Failed to uninstall Server
    [15:44:02]: Error: :Error:Failed to uninstall R2 server, this is a fatal error
    [15:44:02]: Error: :ProcessInstalls: Install Item Initial Configuration failed to install.  We did not launch the post process delegate.
    [15:44:02]: Always: :SetErrorType: Setting VitalFailure. currentInstallItem: Initial Configuration
    [15:44:02]: Info: :SetProgressScreen: FinishMinorStep.
    [15:44:02]: Always: :!***** Installing: OMDATABASE ***
    [15:44:02]: Info: :ProcessInstalls: Rollback is set and we are not doing an uninstall so we will stop processing installs
    [15:44:02]: Always: :****************************************************************
    [15:44:02]: Always: :****Starting*RollBack*******************************************
    [15:44:02]: Always: :****************************************************************
    [15:44:02]: Info: :SetProgressScreen: StartMinorStep.
    [15:44:02]: Always: :ProcessRollback: Skipping rollback for install item Initial Configuration as it was not successfully installed.
    [15:44:02]: Always: :****************************************************************
    [15:44:02]: Always: :****Ended*RollBack**********************************************
    [15:44:02]: Always: :****************************************************************

    Es scheint so, das die Routine keine deinstallation der alten SCOM-Installation durchführen kann. Ich habe mir während des Upgrades das SCOM2007-Verzeichnis angesehen. Die Anzahl der Dateien geht von über 200 auf über 80. Dann scheint das Rollback zu greifen und die original Datei-Anzahl taucht wieder auf.

    Fakt ist jedoch, das nach dem nicht erfolgreichen Upgrade die beide Dienste
    System Center Data Access und System Center Management Configuration
    nicht mehr starten können.
    Erst wenn wir mittels InstallUtil.exe auf dem .Net-Framework eine "reparatur" durchführen, können die Dienste wieder gestartet werden.

    Vielleicht hat ja schon jemand Erfahrung mit dem Upgrade einer komplett Deutschen installation und kann Helfen.

    Danke und Gruß

    Stefan


    Dienstag, 17. Juli 2012 06:35

Antworten

  • Fehler gefunden:

    In den tiefen der Log-Datei removemomserver.log  steht, mehr oder weniger klar beschrieben, das die die Installationsquelle für die deinstallation der scom2007r2-komponenten (laufwerk:\server\amd64\mom.msi) nicht zur verfügung stand.

    Nachdem die "Quelle" wieder zur Verfügung steht, funzt auch das Upgrade anscheinend.

    Gruß

    Stefan

    • Als Antwort markiert Stefan Kadoic Dienstag, 17. Juli 2012 10:58
    Dienstag, 17. Juli 2012 10:58