locked
Explorer.exe stürzt bei jedem Klick im Ordner "Geräte und Drucker" ab RRS feed

  • Allgemeine Diskussion

  • Hallo,

    sobald ich im Ordner "Geräte und Drucker" auf ein Symbol klicke (rechte oder linke Maustaste ist egal), hängt sich "explorer.exe" auf. Es erscheint folgende Fehlermeldung:

    Windows-Explorer funktioniert nicht mehr
    Es wird nach einer Lösung für das Problem gesucht...

    Danach startet der Explorer neu.

    Im Anwendungsprotokoll finde ich folgendes dazu:

    Protokollname: Application
    Quelle:        Application Error
    Datum:         18.05.2012 15:50:50
    Ereignis-ID:   1000
    Aufgabenkategorie:(100)
    Ebene:         Fehler
    Schlüsselwörter:Klassisch
    Benutzer:      Nicht zutreffend
    Computer:      POLLITO.trossingen.local
    Beschreibung:
    Name der fehlerhaften Anwendung: explorer.exe, Version: 6.1.7601.17567, Zeitstempel: 0x4d672ee4
    Name des fehlerhaften Moduls: StorageContextHandler.dll, Version: 6.1.7600.16385, Zeitstempel: 0x4a5be06d
    Ausnahmecode: 0xc0000005
    Fehleroffset: 0x0000000000006724
    ID des fehlerhaften Prozesses: 0x1e9c
    Startzeit der fehlerhaften Anwendung: 0x01cd34fd32f74538
    Pfad der fehlerhaften Anwendung: C:\Windows\explorer.exe
    Pfad des fehlerhaften Moduls: C:\Windows\system32\StorageContextHandler.dll
    Berichtskennung: 7a052648-a0f0-11e1-9bde-000272c05853

    Mein System:

    • W7, 64 Bit, deutsch
    • 16 GB Hauptspeicher
    • RAID10, 1TB

    Der Fehler trat zum ersten Mal auf, als ich einen über Bluetooth gepaarten Headset trennte, um ihn mit meinem Telefon zu verwenden. Als ich ihn nach einigen Tagen erneut verbinden wollte, stürzte explorer.exe ab.

    Ich habe bisher nach einer Google-Suche folgende Tipps erfolglos versucht:

    • Die ganze Bluetooth-Software samt Treiber deinstalliert und anschließend den Bluetooth-Stick entfernt.
    • Die meisten Programme, die sich in das Kontextmenü einnisten, entfernt oder diesen diese "Angewohnheit" ausgetrieben.
    • So nebenher nicht mehr gebrauchte Programme deinstalliert.
    • Reparaturinstallation von Microsoft Office Professional Plus 2010
    • Diesen Hotfix eingespielt: http://support.microsoft.com/kb/2486635/de
    • Hotfix KB2515325 war bereits eingespielt.
    • Virenscan
    • System testhalber mit Minimallast gestartet (viele Programme und Dienste abgeschaltet).

    Nichts hat geholfen – sobald ich einen einzigen Klick in "Geräte und Drucker" wage, hängt sich explorer.exe auf.

    Es wäre toll, wenn jemand eine Lösung hätte.

    Im Voraus besten Dank!


    René



    • Bearbeitet René - ISE Freitag, 18. Mai 2012 15:15
    • Verschoben Alex Pitulice Dienstag, 22. Mai 2012 10:29 Zusammenfuehrung Plan (aus:Windows 7 Installationsprobleme)
    • Typ geändert Alex Pitulice Donnerstag, 31. Mai 2012 14:09 Warten auf Feedback
    Freitag, 18. Mai 2012 14:11

Alle Antworten

  • Hallo,

    betrifft Dein Problem eine Firma Umgebung? Wenn nicht, für Fragen über Heim- und Personal Umgebungen, werden die Fragen am besten und am schnellsten in den Microsoft Answers Forum beantwortet:

    http://answers.microsoft.com/de-de/windows/forum/windows_7

    Vielen Dank für das Verständnis.
    Gruss,
    Alex


    Alex Pitulice, MICROSOFT 
    Bitte haben Sie Verständnis dafür, dass im Rahmen dieses Forums, welches auf dem Community-Prinzip „IT-Pros helfen IT-Pros“ beruht, kein technischer Support geleistet werden kann oder sonst welche garantierten Maßnahmen seitens Microsoft zugesichert werden können.

    Dienstag, 22. Mai 2012 10:32
  • Eigentlich schon – es handelt sich um meine eigene kleine Firma mit einer Domäne auf Windows-Server-2003-Basis und 5 Arbeitsstationen. Eine davon, gerade meine, ist vom Fehler betroffen.Ich kann es trotzdem in der anderen Gruppe versuchen, da hier sowieso etwas ruhig ist.

    Dankeschön


    René

    Dienstag, 22. Mai 2012 12:06
  • Hallo René,

    > die sich in das Kontextmenü einnisten, entfernt oder diesen diese "Angewohnheit" ausgetrieben.

    Der Weg war wohl richtig, hast du dabei ShellExView benutzt, wenn nicht schau damit mal nach.

    > Die ganze Bluetooth-Software samt Treiber deinstalliert und anschließend den Bluetooth-Stick entfernt.

    Die Reihenfolge ist sicher nur ein Vertipper?, erst Stick abziehen, dann deinstallieren.

    Dabei frage ich mich, wer blockiert evtl. Änderungen an Registry-Zweigen, welche Antivirussoftware nutzt du?

    Nach Treibern die als Reste im System rumschwirren, kann mal vorkommen, forscht du am besten mit Autoruns.

    Wenn Alex nix dagegen hat, gehts hier erst mal weiter, hast auch im MSA eingestellt wie ich sah.


    mfg Michael | www.mbormann.de

    Dienstag, 22. Mai 2012 21:15
  • Nach mehreren Stunden und über 9 Millionen geprüften Dateien hat das Tool nichts gefunden.

    René

    Mittwoch, 23. Mai 2012 10:49
  • Die BT-Software ist richtig runter, der Fehler ist aber geblieben.

    Mit ShellExView kenne ich mich nicht aus. Ich habe das Programm gestartet, kann jedoch die vielen Einträgen nicht interpretieren. Trotzdem haben ich alle nicht Microsoft-Einträge testweise deaktiviert, brachte aber leider nichts. Ich habe auch fast jeden Prozess gekillt und viele Dienste testhalber deaktiviert, aber auch ohne erfolg.

    Wenn ich "Geräte und Drucker" öffne, startet der Prozess "DeviceDisplayObjectProvider.exe". Wenn ich dann darin auf ein Symbol klicke – mit linker oder rechter Maustaste, das ist egal –, stürzt der Windows-Explorer ab. "DeviceDisplayObjectProvider.exe" wird dann nicht mehr beendet.

    Ich glaube, ich werde verrückt, denn ich kann keine Geräte mehr verwalten.

    Antivirensoftware verwende ich "Microsoft Security Essentials" und als Firewall die Windows-Firewall, also keine Drittherstellerprodukte.


    René

    Mittwoch, 23. Mai 2012 11:24
  • Ich komme nicht weiter. Gibt es zumindest eine Möglichkeit, ohne neu installieren zu müssen, "Geräte und Drucker" wieder zum Laufen zu bringen?

    Wenn jemand noch Infos braucht, mache ich das gerne.

    Danke im Voraus!


    René

    Donnerstag, 24. Mai 2012 10:28
  • Hallo Rene,

    Man konnte mit Hilfe des Windows In-Place Upgrade versuchen die System Dateien wiederherzustellen.

    Siehe mal bitte den folgenden Artikel: How to Perform an In-Place Upgrade on Windows Vista, Windows 7, Windows Server 2008 & Windows Server 2008 R2

    Sehr wichtig: An in-place upgrade is the final alternative before you have to reinstall the operating system.

    Note that it takes the same amount of time to do the upgrade as to reinstall the operating system. Also, some of your customized Windows settings may be lost through this process.

    NotePerforming a repair installation will not damage files and applications that are currently installed on your computer.

    Siehe bitte auch:

    windows 7 in-place upgrade to fix problems (Antwort von J.W.Stuart) und

    How to Repair a Corrupt Windows 7 Installation

    Eine andere Möglichkeit könnte sein das System zurück zu einem Wiederherstellungspunkt wiederherzustellen, falls Du ein vorher erstellt hast(bevor die BT Treiber & Software installiert waren).

    Andere Möglichkeiten sehe ich leider nicht.

    Gruß

    Alex


    Alex Pitulice, MICROSOFT 
    Bitte haben Sie Verständnis dafür, dass im Rahmen dieses Forums, welches auf dem Community-Prinzip„IT-Pros helfen IT-Pros“ beruht, kein technischer Support geleistet werden kann oder sonst welche garantierten Maßnahmen seitens Microsoft zugesichert werden können.




    Donnerstag, 24. Mai 2012 11:44
  • Ergänzend zum Hinweis von Alex:
    Deine Problembeschreibung sieht nach einem Treiber aus, der immer noch aktiv ist, typisch dafür ist BT.

    Autoruns ist dir genannt worden.

    Damit erkennt man was noch läuft obwohl es nicht mehr vorhanden sein dürfte.

    Eine andere Möglichkeit wäre zudem noch: das derzeitige Konto deinerseits hat einen Schaden erlitten.

    Also als Test ein neues Benutzerkonto erstellen und das Verhalten dort überprüfen.


    mfg Michael | www.mbormann.de

    Donnerstag, 24. Mai 2012 22:53
  • Ich habe gestern abermals die BT-Treiber samt Software entfernt, das Problem blieb aber. Habe zusätzlich fast alles deinstalliert, was ging, aber der Fehler blieb. Nun habe ich meine deinstallierten Drucker und Software neu installiert und bin soweit wie vor einigen Tagen.

    Was mir aufgefallen ist, ist ein Gerät "HTC HD7 T9292" im Bereich "Nicht angegeben". Sieht wie ein kleiner Kühlschrank aus, ist aber ausgegraut bzw. halb-transparent. – Ich habe tatsächlich ein Windows-Smartphone HD7, aber wenn ich ihn anschließe, erscheint das Gerät mit diesem Namen unter "Geräte" – der kleine Kühlschrank erfährt nicht davon. Vielleicht macht mir das die Probleme und nicht Bluetooth, ich weiß aber nicht, wie ich diesen kleinen Kühlschrank loswerden kann.

    Das Betriebssystem neu installieren, kommt nicht in Frage, da es sich um einen Entwicklungsrechner handelt (Visual Studio, Unify Team Developer, Expression, SQL-Server, SQLBase usw.) – bis ich wieder soweit bin, vergehen zwei Wochen. Also, es muss eine andere Lösung her.

    Ich versuche es noch mit den Tipps (z. B. Autoruns), aber für den Moment behelfe ich mich bei den Druckern mit der Druckerverwaltung (printmanagement.msc) und hoffe, bei den Geräten mit deren Software weiter zu kommen.

    Auf einen Wiederherstellungspunkt zurück will ich nicht, denn ich weiß nicht einmal, seit wann ich das Problem habe.

    Ich hoffe, ich komme mit Autoruns zu recht, wenn auch der erste Start "erschreckend" war. :-)

    Schönen Dank und falls jemand noch Ideen hat, her damit!



    René


    Freitag, 25. Mai 2012 00:29
  • Hallo René,

    versuch mal bitte die Tipps von Michael mit dem neuen Benutzerkonto Erstellung zu probieren. Es sollte unter dem neuen Konto gehen. :)

    Siehst Du den Treiber in der Liste mit dieser Methode?: -> http://www.howtogeek.com/howto/windows-vista/generate-a-list-of-installed-drivers-from-the-command-line/  (driveryquery > c:\test.txt)

    Im Ordner "Geräte und Drucker" hast Du kein Zugriff(d.h.Explorer crashes), aber ist Dir möglich Geräte-Manager zu öffnen? Wenn ja, kannst Du den Treiber dort unter Ausgeblendete Geräte sehen? -> http://www.makeuseof.com/tag/how-to-easily-remove-old-drivers-from-windows/

    Gruss,

    Alex


    Alex Pitulice, MICROSOFT 
    Bitte haben Sie Verständnis dafür, dass im Rahmen dieses Forums, welches auf dem Community-Prinzip„IT-Pros helfen IT-Pros“ beruht, kein technischer Support geleistet werden kann oder sonst welche garantierten Maßnahmen seitens Microsoft zugesichert werden können.



    Freitag, 25. Mai 2012 07:05
  • Hallo Alex,

    ich habe ein anderes Benutzerkonto verwendet, welches bisher noch nicht benutzt wurde, der Misserfolg war jedoch derselbe. Ich habe auch driverquery zweimal ausgeführt und die Ergebnisse zum Download hier bereitgestellt:

    Zusätzlich habe ich nach dem zweiten Tipp ein Abbild meiner Geräte gemacht und ebenfalls zum Download bereitgestellt:

    Schlussendlich habe ich im Ordner Geräte und Drucker, wie bereits in einem früheren Beitrag beschrieben, eine Leiche, die ich langsam als Verursacher verdächtige und nicht wegbekomme. Hier ein Ausschnitt aus dem früheren Beitrag:

    Was mir aufgefallen ist, ist ein Gerät "HTC HD7 T9292" im Bereich "Nicht angegeben". Sieht wie ein kleiner Kühlschrank aus, ist aber ausgegraut bzw. halb-transparent. – Ich habe tatsächlich ein Windows-Smartphone HD7, aber wenn ich ihn anschließe, erscheint das Gerät mit diesem Namen unter "Geräte" – der kleine Kühlschrank erfährt nicht davon. Vielleicht macht mir das die Probleme und nicht Bluetooth, ich weiß aber nicht, wie ich diesen kleinen Kühlschrank loswerden kann.

    Ich habe auch gleich ein Bild gemacht, damit jeder sehen kann, was ich meine:

    Ich hoffe, jemand kann mir helfen. Heute z. B. wollte ich über das Symbol im System-Tray "Hardware sicher entfernen und..." eine externe USB-3.0-Festplatte auswerfen und der Explorer ist mir gleich abgestürzt. Das geht mir auf die Nerven und ich komme nicht weiter.

    Für jede Hilfe bin ich euch dankbar.

    Schönen Dank!


    René


    Freitag, 1. Juni 2012 13:28
  • Hallo René

    --------snip------------

    @Echo off
    set devmgr_show_nonpresent_devices=1
    devmgmt.msc

    ------- snapp ----

    Text zwischen snip/snapp in eine Batch kopieren, diese per rechtsklick als administrator starten, im Gerätemanager ausgeblendete Geräte anzeigen lassen.

    Was da nun per helleres Grau dargestellt ist, sind gerade nicht existente Geräte, da kann man aufräumen.

    du kannst die Batch aber auch aus einer cmd starten, die mit administrativen Rechten gestartet ist.

    Driverquery, schaue ich später mal rein.

    Du hast Acronis drauf, Try&Decide aktiviert?

    Dann hält das Änderungen zurück, dran denken.


    mfg Michael | www.mbormann.de

    Freitag, 1. Juni 2012 18:02
  • Hallo,

    zunächst vielen Dank. Ich hatte den Fehler gemacht, die Konsole nicht als Administrator gestartet zu haben. Jetzt habe ich dank deines Tipps es bemerkt und ich war erstaunt, wie viele nicht existierende Geräte vorhanden waren. Unter anderem auch jede Menge Bluetooth-Geräte, obwohl der Stick draußen und die Software deinstalliert war. Auch das widerspenstige HTC-Smartphone tauchte auf. Ich habe alles samt Treiber deinstalliert, aber der Fehler blieb weiterhin bestehend.

    Acronis habe ich, das ist richtig, Try&Decide ist aber nicht aktiviert (Einschub: gibt es was besseres als Acronis?).

    Nun habe ich langsam keine Idee mehr.

    Mit der Druckerverwaltung über den Printmanager kann ich gut leben. Weitere Bluetooth-Geräte werde ich sicher keine mehr anschließen (außer meinem Headset für Skype), aber ein Problem habe ich trotzdem noch: Ich kann nicht mehr auf das Symbol "Hardware sicher entfernen und Medium auswerfen" im Systemtray klicken, ohne das der Explorer abstürzt. Das brauche ich aber, um z. B. Festplatten, die ich an einer USB-3.0-Dockingstation betreibe, auswerfen zu können. Gibt es dafür andere Wege wie z. B. über die Kommandozeile? – Eine Neuinstallation kommt zurzeit nicht in Frage, wie ich bereits in einem früheren Beitrag erzählte.

    Nochmals herzlichen Dank!


    René


    Samstag, 2. Juni 2012 11:57
  • Sollte sich jemand hierher verirren, dann habe ich immer noch keine Lösung und ich würde mich wahnsinnig über jede Hilfe freuen.

    René

    Sonntag, 10. Juni 2012 16:27
  • Sollte sich jemand hierher verirren, dann habe ich immer noch keine Lösung und ich würde mich wahnsinnig über jede Hilfe freuen.

    Hallo,

    mehr fällt mir dazu offline wirklich nicht ein:

    http://support.microsoft.com/kb/2515325/de

    Schaue es dir mal an.


    mfg Michael | www.mbormann.de

    Dienstag, 12. Juni 2012 12:37
  • Danke, diesen Patch hatte ich schon eingespielt, brachte jedoch keine Lösung. Ich drehe durch...

    René

    Dienstag, 12. Juni 2012 13:41
  • Am 12.06.2012 schrieb René - ISE:

    Danke, diesen Patch hatte ich schon eingespielt, brachte jedoch keine Lösung. Ich drehe durch...

    Auch wenn es viel Arbeit macht, eine saubere Neuinstallation wäre wohl
    die beste aller Möglichkeiten.

    Servus
    Winfried


    Connect2WSUS: http://www.grurili.de/tools/Connect2WSUS.exe
    GPO's: http://www.gruppenrichtlinien.de
    Community Forums NNTP Bridge: http://communitybridge.codeplex.com/

    Sonntag, 17. Juni 2012 16:26
  • Erst wenn ein neuer Rechner kommt. Bis alles wieder so funktioniert, dass ich wieder uneingeschränkt arbeiten kann, vergehen zwei Wochen. Die Zeit habe ich aber nicht.

    Den nächsten Rechner virtualisiere ich mit VMWARE (ich brauche auch USB) und dann überlege ich mir eine bessere Sicherungsstrategie, damit so was sich nicht wiederholt. Dummerweise weiß ich nicht, seit wann ich diesen Fehler habe, so dass ich nicht zu einem Wiederherstellungspunkt zurück kann/will. Mit einer virtuellen Maschine wären solche Versuche einfacher und nervenschonender.


    René

    Sonntag, 17. Juni 2012 16:46
  • Ich möchte das Thema noch einmal aufgreifen. Bisher habe ich keine Lösung gefunden und eine Neuinstallation ist zeitlich nicht möglich.

    Das Betriebssystem ist nicht das Thema, aber ich müsste einen Haufen Programme installieren und konfigurieren wie z. B. Visual Studio, CorelDraw, Corel PaintShop Pro, Gupta Team Developer, SQLBase (Client), ERP-System (Client), alle Canon-Programme für meine DSLR, Microsoft Office, Bankprogramm, VMWARE-Workstation und noch einen großen Haufen Sattelitenprogramme und Tools. Bis ich durch bin und ich wieder 100% arbeitsfähig bin, vergehen zwei Wochen

    Ein neuer Rechner steht erst nächstes Jahr an und jetzt habe ich das Problem, dass ich einige Geräte verwalten muss und das geht nur über den Ordner "Geräte und Drucker", der bei jedem Klick den Explorer komplett abstürzen lässt.

    Daher an dieser Stelle ein verzweifelter Hilfeschrei!

    Voller Hoffnung im Voraus vielen Dank!


    René

    Donnerstag, 11. Oktober 2012 13:40
  • Hallo,

    bitte mal folgenden Ordner leeren:

    %ProgramData%\Microsoft\Windows\DeviceMetaDataStore

    Grüße,

    Toni

    Dienstag, 16. Oktober 2012 07:04
  • bitte mal folgenden Ordner leeren:

    %ProgramData%\Microsoft\Windows\DeviceMetaDataStore

    Herzlichen Dank! Ich habe es sofort getestet, aber es hat leider nichts gebracht.

    Darin befand sich nur ein Ordner namens "en-US" und darin folgende zwei Dateien:

    • 63921eef-8415-4368-9201-f0df4af5778f.devicemetadata-ms
    • 34e548a8-3268-4dde-bedf-c40f9b6c814a.devicemetadata-ms

    Sollte ich den Ordner samt der zwei Dateien zurückkopieren? Ich habe bisher keine zusätzlichen Nebeneffekte dadurch festgestellt.


    René



    • Bearbeitet René - ISE Dienstag, 16. Oktober 2012 17:13
    Dienstag, 16. Oktober 2012 17:13