locked
Automatic re-logon Administrator after manual logoff in Windows 7 / Windows 2008 Server R2 RRS feed

  • Frage

  • Coming from here I was told to ask my question here ;-) , so here it is.

     

    How to achieve Administrator to automatically re-logon after a manual logoff.

    Automated login on reboot is already working fine, but when login off  from a signed in administrator session it always asked for
    password.

    The neede for Crt-Alt-Del is already deactivated in policies.

    Adding
    DefaultUserName & DefaultPassword & AutoAdminLogon & ForceAutoLogon under
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
    does not get it to work

    control userpasswords2
    checkbox for password the need to enter the password is also deactivated.


    Security concerns doesn't matter ;-) so I just need the trick for Automatic re-logon after logoff for the Administrator account.

    I know it is possible cause the this tool here http://www.logonexpert.com has an implicit option for this when being
    set works perfectly.
    But I´m looking for a free tweak.

    Looking forward to your answers :-)

    Dienstag, 6. September 2011 09:41

Antworten

  • In Deinem Screenshot fehlt ForceAutologon - ohne das geht's garantiert
    nicht :-)
     
    mfg Martin
     

    A bissle "Experience", a bissle GMV...
    Montag, 19. September 2011 16:46
  • Aktuell probiert habe ich es mit dem was man auf dem Screenprint sieht. Es darf also geglaubt werden was man sieht ;-)

    Und zwar weil hier steht:

    "The ForceAutoLogon value should be added to the Winlogon key only if the computer is running Windows 2000.

    Und ich teste das ja gerade wie gesagt auf Win2008 Server Enterprise Edition R2 SP1

    Inzwischen habe ich das ForceAutoLogon nochmal eingefügt und aktiviert (1)

    Somit sind nun alle diese Einträge in diesem Regkey drin:

    AutoAdminLogon 1
    DefaultUserName Administrator
    DefaultPassword Password für den User Administrator
    ForceAutoLogon 1

    und zusätzlich in den Policies die notwendigkeit für crtl-alt-del deaktiviert.

    Und siehe da, es funktioniert. Dann ist das ForceAutoLogon wohl doch wichtig :-)

    Vieleicht sollte man doch nicht alles glauben was man sieht LOL.

    Danke für Eure Geduld.

     

     

    Dienstag, 20. September 2011 11:53

Alle Antworten

  • Hi,

    an answer you did not like - why?

     


    mfg Michael | www.mbormann.de
    Dienstag, 6. September 2011 19:51
  • Because it simply did not help me identifying the screws I need to turn ;-) to write my own code to archive this goal. Pretty sure it can be done somehow on an easy way like with powershell command or similar. If you can point me to the right direction please.
    Dienstag, 6. September 2011 19:59
  • AgentNappi007:

    Coming from here  <http://answers.microsoft.com/de-de/windows/forum/windows_7-security/automatic-re-logon-administrator-after-manual/0beaf355-0581-4488-91fa-fbae3f0ca41e>I was told to ask my question here ;-) , so here it is.

    Schön. Du beherrscht allerdings die deutsche Sprache. Somit wäre es angebracht, diese in einem rein deutschen
    Forum auch zu verwenden, sofern man denn Antworten haben möchte. Meinjanur.

    Mittwoch, 7. September 2011 08:46
  • Hi,

    you are in a German Forum. Only German should be written here. If German is not your language you preffer, please open a Thread in English TechNet Forums:

    http://social.technet.microsoft.com/Forums/en-us/categories/

    Regards,
    Raul

     

    Mittwoch, 7. September 2011 10:16
  • Wie erreiche ich das sich das Administrator Konto nach einem manuellen abmelden, automatisch wieder anmeldet.

    Das automatische Anmelden nach dem Neustart funktioniert bereits, aber wenn sich das Administrator manuell abmeldet, wird wieder nach den Anmeldeinformation gefragt


    In den Systemrichtlinien ist bereits deaktiviert das vor der Anmeldung noch Crt-Alt-Del gedrückt werden muss.

    Das hinzufügen von
    DefaultUserName & DefaultPassword & AutoAdminLogon & ForceAutoLogon unter
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
    in der Registry bringt auch nichts.

    control userpasswords2
    checkbox für das Passwort ist auch deaktiviert.

    Sicherheitsbedenken spielen bei der Lösung keine Rolle.
    Ich bräuchte also nur den Trick der die automatisch Anmeldung nach manueller Abmeldung ermöglicht.


    Das es geht, hab ich mit dem Tool hier ausprobiert http://www.logonexpert.com  Da kann man dieses Verhalten explizit mit einer checkbox aus und einschalten. Nur leider ist das kostenpflichtig.

    Freue mich schon auf Eure konstruktive Hilfe

     

    Mittwoch, 7. September 2011 11:26
  • AgentNappi007:

    Das hinzufügen von
    DefaultUserName & *DefaultPassword &*AutoAdminLogon & ForceAutoLogon unter
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
    in der Registry bringt auch nichts.

    Doch, das bringt was. Wenn man den User abmeldet, meldet er sich sofort automatisch wieder an.
    Eine Abmeldung ist also praktisch gar nicht mehr möglich mit dieser Einstellung.

    Mittwoch, 7. September 2011 16:47
  • Sorry das ich erst so spät Feedback gebe. Aber bei meinem aktuellen Versuch unter win2008 Server R2 geht es leider nicht.

     

    Der etsprechende regkey schaut so aus:

    In den Policies ist die Notwendigkeit für Ctr-Alt-Del ausgeschaltet. Und trotzdem kommt der Login Screeen.

    Hast du das wirklich unter 2008 probiert?

    Gruß Agent

    Montag, 19. September 2011 13:59
  • In Deinem Screenshot fehlt ForceAutologon - ohne das geht's garantiert
    nicht :-)
     
    mfg Martin
     

    A bissle "Experience", a bissle GMV...
    Montag, 19. September 2011 16:46
  • In Deinem Screenshot fehlt ForceAutologon - ohne das geht's garantiert
    nicht :-)
     

    Hier gab er vor alles gesetzt zu haben - fehlt also nicht, ist nur nicht enabled?

    mfg Michael | www.mbormann.de
    Montag, 19. September 2011 21:32
  • > - fehlt also nicht, ist nur nicht enabled?
     
    Im Post vom 07.09. 13:26 steht's "im Text" auch drin - in dem Screenshot
    fehlt es. Und ich bin leidgeprüft - nur glauben, was man selber sieht :-)
     

    A bissle "Experience", a bissle GMV...
    Dienstag, 20. September 2011 05:58
  • Aktuell probiert habe ich es mit dem was man auf dem Screenprint sieht. Es darf also geglaubt werden was man sieht ;-)

    Und zwar weil hier steht:

    "The ForceAutoLogon value should be added to the Winlogon key only if the computer is running Windows 2000.

    Und ich teste das ja gerade wie gesagt auf Win2008 Server Enterprise Edition R2 SP1

    Inzwischen habe ich das ForceAutoLogon nochmal eingefügt und aktiviert (1)

    Somit sind nun alle diese Einträge in diesem Regkey drin:

    AutoAdminLogon 1
    DefaultUserName Administrator
    DefaultPassword Password für den User Administrator
    ForceAutoLogon 1

    und zusätzlich in den Policies die notwendigkeit für crtl-alt-del deaktiviert.

    Und siehe da, es funktioniert. Dann ist das ForceAutoLogon wohl doch wichtig :-)

    Vieleicht sollte man doch nicht alles glauben was man sieht LOL.

    Danke für Eure Geduld.

     

     

    Dienstag, 20. September 2011 11:53
  • > und zusätzlich in den Policies die notwendigkeit für crtl-alt-del
    > deaktiviert.
     
    DAS ist m.W. nicht erforderlich... Wenn C-A-D erforderlich ist, muß man
    das nach dem Anlegen der Regkeys genau einmal manuell drücken, dann
    kommt sofort der Autologon, und bei allen weiteren Boots geht's
    tatsächlich automatisch.
     
    > Vieleicht sollte man doch nicht alles glauben was man sieht LOL.
     
    :)
     

    A bissle "Experience", a bissle GMV...
    Dienstag, 20. September 2011 15:48
  • Das kann ich so bestätigen. Ich habe die Policy wieder zurückgenommen und es funktioniert trotzdem.
    Dienstag, 20. September 2011 15:52