none
scom 2012 r2 - dynamische Gruppen zeigen keine Mitglieder an... RRS feed

  • Frage

  • Hallo zusammen,

    ich möchte im SCOM 2012 r2 eine Gruppe anlegen, deren Mitglieder einen bestimmten Dienst installiert haben.

    Dazu habe ich mich an die Anleitung unter http://systemcenter.no/?p=876 gehalten und als query den folgenden Eintrag im zu erstellenden Attribut verwendet: select * from Win32_service where name = "sophos agent"

    Nun noch eine Gruppe erstellt und fertig:

    Was mache ich falsch - wieso greift entweder das Attribut oder die Regel zur dynamischen Gruppenmitgliedschaft nicht?


    Mit freundlichem Gruss - Harald Haas - MCSE Server Infrastructure 2012; MCTS Exchange Server 2010 Configuration;

    Montag, 27. Juli 2015 07:22

Antworten

  • Hallo Michaela,

    ich habe die Ursache gefunden, nein ich muss fairerweise sagen, dass ein Kollege, der uns in einer anderen Sache half, mich auf den richtigen Weg gebracht hat.

    Zuerst haben wir uns das ermittelte Inventar mit dem geänderten Zieltyp auf die vom Attribut erzeugte Windows-Computer_extendet Gruppe anzeigen lassen und haben festgestellt, dass bezogen auf das Attribut kein Ergebnis vorliegt.

    Somit konnten wir erarbeiten, dass es am Attribut und nicht an der Gruppe liegen muss.

    Nun haben wir uns das Attribut angeschaut und haben folgendes gefunden:

    Die Query lautete: select * from Win32_service where name = “Dienstname”
    Als Eigenschaftenname wurde Handle eingetragen!

    Mittels WBEMTEST unter C:\Windows\System32\wbem\wbemtest.exe konnten wir aber sehen, dass für die Query im Testprogram folgende Formate ausgegeben werden: Win32_service.Name="Dienstname"

    Der Augenmerk liegt hier auf dem Eintrage hinter Win32_service.! Hier steht nicht Handle sondern Name.

    Ändere ich die Query in select * from Win32_Process ab, dann bekomme ich im WBEMTEST auch Handle als Ergebnis ausgegeben!

    Also sind wir in einem nächsten Schritt hingegangen und haben das Attribut dahingehend geändert, dass wir als Eigenschaftennamen "Name" eingegeben haben und nicht Handle.

    Noch kurz das Ergebnis mit "ermittelte Inventar " im SCOM geprüft und siehe da, nun bekomme ich die Spalte auch gefüllt.

    Wenn ich nun die Gruppe anlege und mich auf das Attribut beziehe, klappt es auch.

    Abschließend muss ich eingestehen, dass ich nicht der Crack in Sachen Query bin und mit dem Eigenschaftennamen in dem Assistenten für das Erstellen eines Attributes nichts anfangen konnte.

    Also hatte ich mich an der Anleitung (link stehet im Eröffnungsbeitrag) bedient und diese Anleitung hat halt eine Query auf den Win32_Process abgesetzt - dann passt Handle natürlich...Somit habe ich wieder was gelernt... :-)

    Und ich hoffe, den Lesern dieses Threads konnte ich auch helfen...


    Mit freundlichem Gruss - Harald Haas - MCSE Server Infrastructure 2012; MCTS Exchange Server 2010 Configuration;

    • Als Antwort markiert H.Haas Dienstag, 28. Juli 2015 05:53
    Dienstag, 28. Juli 2015 05:53

Alle Antworten

  • Hallo H.Haas,

    ich habe an einige Stellen versucht etwas über dieses Problem nachzulesen aber keine wirkliche Information gefunden. Das was mir fast überall aufgefallen ist, dass man "Prozess Name" und nicht "Display Name" verwenden sollte. Kann es sein, dass es daran liegt?

    Grüße,

    Michaela


    Bitte haben Sie Verständnis dafür, dass im Rahmen dieses Forums, welches auf dem Community-Prinzip „IT-Pros helfen IT-Pros“ beruht, kein technischer Support geleistet werden kann oder sonst welche garantierten Maßnahmen seitens Microsoft zugesichert werden können.



    Montag, 27. Juli 2015 15:45
    Moderator
  • Hallo Michaela,

    ich habe die Ursache gefunden, nein ich muss fairerweise sagen, dass ein Kollege, der uns in einer anderen Sache half, mich auf den richtigen Weg gebracht hat.

    Zuerst haben wir uns das ermittelte Inventar mit dem geänderten Zieltyp auf die vom Attribut erzeugte Windows-Computer_extendet Gruppe anzeigen lassen und haben festgestellt, dass bezogen auf das Attribut kein Ergebnis vorliegt.

    Somit konnten wir erarbeiten, dass es am Attribut und nicht an der Gruppe liegen muss.

    Nun haben wir uns das Attribut angeschaut und haben folgendes gefunden:

    Die Query lautete: select * from Win32_service where name = “Dienstname”
    Als Eigenschaftenname wurde Handle eingetragen!

    Mittels WBEMTEST unter C:\Windows\System32\wbem\wbemtest.exe konnten wir aber sehen, dass für die Query im Testprogram folgende Formate ausgegeben werden: Win32_service.Name="Dienstname"

    Der Augenmerk liegt hier auf dem Eintrage hinter Win32_service.! Hier steht nicht Handle sondern Name.

    Ändere ich die Query in select * from Win32_Process ab, dann bekomme ich im WBEMTEST auch Handle als Ergebnis ausgegeben!

    Also sind wir in einem nächsten Schritt hingegangen und haben das Attribut dahingehend geändert, dass wir als Eigenschaftennamen "Name" eingegeben haben und nicht Handle.

    Noch kurz das Ergebnis mit "ermittelte Inventar " im SCOM geprüft und siehe da, nun bekomme ich die Spalte auch gefüllt.

    Wenn ich nun die Gruppe anlege und mich auf das Attribut beziehe, klappt es auch.

    Abschließend muss ich eingestehen, dass ich nicht der Crack in Sachen Query bin und mit dem Eigenschaftennamen in dem Assistenten für das Erstellen eines Attributes nichts anfangen konnte.

    Also hatte ich mich an der Anleitung (link stehet im Eröffnungsbeitrag) bedient und diese Anleitung hat halt eine Query auf den Win32_Process abgesetzt - dann passt Handle natürlich...Somit habe ich wieder was gelernt... :-)

    Und ich hoffe, den Lesern dieses Threads konnte ich auch helfen...


    Mit freundlichem Gruss - Harald Haas - MCSE Server Infrastructure 2012; MCTS Exchange Server 2010 Configuration;

    • Als Antwort markiert H.Haas Dienstag, 28. Juli 2015 05:53
    Dienstag, 28. Juli 2015 05:53
  • Hallo H.Haas,

    vielen Dank für die Rückmeldung!

    Grüße

    Michaela


    Bitte haben Sie Verständnis dafür, dass im Rahmen dieses Forums, welches auf dem Community-Prinzip „IT-Pros helfen IT-Pros“ beruht, kein technischer Support geleistet werden kann oder sonst welche garantierten Maßnahmen seitens Microsoft zugesichert werden können.

    Dienstag, 28. Juli 2015 14:46
    Moderator