none
Runas Batch Skript Starter RRS feed

  • Frage

  • Hi Community,

    auf einen unserer Fileserver laufen nachts zwei Synchronisierungsjobs, der eine als Batch Skript holt intern das Delta von einen anderen Server und danach synct Archiware Synchronize das Delta an einen anderen Standort. Der zweite SyncJob ist daher vom ersten abhängig. Archiware hat in seinem Jobmanagement dafür die Möglichkeit ein Pre- bzw. Postscript auszuführen. Das Problem ist nur, dass der Archiware Dienst als lokaler Systemaccount läuft und so auch das Skript gestartet wird. Der lokale Systemaccount hat aber offensichtlich nicht das Recht auf einen UNC-Pfad zuzugreifen, somit scheitert die interne Synchronisation.

    Welche Möglichkeiten hätte ich jetzt das Batch-Skript als Administrator auszuführen?

    Note: Alle involvierten Server sind W2K8R2SP1.

    Thx & Bye Tom

    Montag, 15. Dezember 2014 08:32

Antworten

Alle Antworten

  • > Der lokale Systemaccount hat aber offensichtlich nicht das Recht auf
    > einen UNC-Pfad zuzugreifen, somit scheitert die interne Synchronisation.
     
    Doch, hat er - er ist "Authentifizierte Benutzer", er ist
    "Domänen-Computer" und er ist %computername%$. Berechtige ihn und alles
    wird gut :)
     

    Martin

    Mal ein GUTES Buch über GPOs lesen?

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    And if IT bothers me - coke bottle design refreshment :))
    Montag, 15. Dezember 2014 12:27
  • Hallo Tom,

    es ist möglich ein Batch-Skript mit administrativen Rechten auszuführen, du musst aber vorher eine Verknüpfung zu diesem anlegen. Das geht durch Rechtklick auf das Skript -> Senden an -> Desktop . Die Verknüpfung kann auch irgendwo anders angelegt werden.

    Danach gehst du wie folgt vor:

    • Rechtsklick auf die Verknüpfung, die du gerade erstellt hast
    • Gehe im Reiter Verknüpfung auf Erweitert...
    • Setze den Haken bei Als Administrator ausführen und bestätige zwei Mal mit Ok
    • Führe das Skript durch Doppelklick aus.

    Ich hoffe das konnte dein Problem lösen.

    Viele Grüße,
    Anton Mehlmann
    TechNet Deployment Hotline    

    TechNet Deployment-Hotline

    Disclaimer:

    Bitte haben Sie Verständnis dafür, dass wir hier auf Rückfragen gar nicht oder nur sehr zeitverzögert antworten können.
    Bitte nutzen Sie für Rückfragen oder neue Fragen den telefonischen Weg über die TechNet Deployment Hotline: http://technet.microsoft.com/de-de/ff959330

    TechNet Deployment-Hotline
    Telefon: 0800-6087338*
    Email: msdn-technet-support@escde.net

    * 16:00 – 18:00 Uhr (außer an bundeseinheitlichen Feiertagen). Kostenfrei aus dem dt. Festnetz, Mobilfunknetz ggfs. abweichend. Anrufer aus Österreich und der Schweiz können die Telefon-Hotline aus technischen Gründen über +49 721 693 7233 zum Tarif für Auslandsverbindungen des jeweiligen Telefonanbieters erreichen.
    Es gelten Nutzungsbedingungen, Hinweise zu Markenzeichen sowie die allgemein gültigen Informationen zu Datenschutz und Cookies. Bitte beachten Sie auch die gesonderten Nutzungsbedingungen für die Deployment-Hotline.

    Montag, 15. Dezember 2014 12:34
  • Servus,

    > es ist möglich ein Batch-Skript mit administrativen Rechten auszuführen, du musst aber vorher eine Verknüpfung zu diesem anlegen.

    Wenn ich die Verknüpfung per Doppelklick ausführe dann klappt das aber der Archiware Preprocessor führt die Verknüpfung (also das LNK-File) leider nicht aus.

    Schade, mit dieser Variante hätte ich an der Quelle nichts verändern müssen...

    Thx & Bye Tom

    Montag, 15. Dezember 2014 13:35
  • Servus,

    > Doch, hat er - er ist "Authentifizierte Benutzer", er ist
    "Domänen-Computer" und er ist %computername%$. Berechtige ihn und alles
    wird gut :)

    Also ich habe an der Quelle jetzt mal den Computernamen mit Vollzugriff eingetragen aber er holt sich dort keine Daten. Im Eventlog steht auch nichts, weder an der Quelle noch am Ziel.

    Thx & Bye Tom

    Montag, 15. Dezember 2014 13:42
  • Servus,

    > Doch, hat er - er ist "Authentifizierte Benutzer", %computername%$...

    Nachtrag: Jetzt glaub weiß ich warum das mit dem Hinzufügen des Computer Accounts nicht funktioniert. Das Skript greift auf eine administrative Freigabe zu (\\192.168.111.2\h$\Source\), da darf vermutlich auch nur ein Admin ran. Ich habe das Computerobjekt jetzt an der Quelle in die Gruppe der Administratoren aufgenommen und jetzt funktioniert das scheinbar. Ist aus sicherheitstechnischen Gründen vielleicht nicht ganz die sauberste Sache aber darum gehts in diesem Setup nicht primär.

    Thx & Bye Tom


    Montag, 15. Dezember 2014 14:45
  • > Nachtrag: Jetzt glaub weiß ich warum das mit dem Hinzufügen des Computer
    > Accounts nicht funktioniert. Das Skript greift auf eine administrative
    > Freigabe zu (\\192.168.111.2\h$\Source\), da darf vermutlich auch nur
    > ein Admin ran.
     
    In der Tat :) Die saubere Lösung wäre, das Verzeichnis H:\Source noch
    freizugeben mit geeigneten Berechtigungen.
     

    Martin

    Mal ein GUTES Buch über GPOs lesen?

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    And if IT bothers me - coke bottle design refreshment :))
    Montag, 15. Dezember 2014 15:21