none
inplace upgrade Server 2008R2 > Server 2012R2 RRS feed

  • Frage

  • Hallo zusammen,

    würde gerne eure Meinung hören.

    Folgende Situation.

    Virtuelle Umgebung alles Server 2008R2.

    Server 2008R2 auf diesem läuft ein Exchange 2013 Server

    Wir werden unserer Umgebung nun auf Server 2012R2 umstellen

    Kann ich den Server 2008R2 direkt auf Server 2012R2 upgrade ohne mir den Exchange Server

    zu "zerschießen"?

    Oder ratet ihr generell von einem inplace upgrade ab?

    Danke für Eure Meinungen

    viele Grüße

    Stefan

    Montag, 9. Mai 2016 11:12

Antworten

Alle Antworten

  • Am 09.05.2016 schrieb Stefan Kahlert:
    Hi,

    Kann ich den Server 2008R2 direkt auf Server 2012R2 upgrade ohne mir den Exchange Server zu "zerschießen"?

    Nein kannst du nicht. Inplace OS Updates sind genauso "unmöglich", wie Exchange Inplace Updates.

    Oder ratet ihr generell von einem inplace upgrade ab?

    Ja und Microsoft ebenfalls. ;)
    Lohnt auch gar nicht den STress, einfach migrieren und gut. :)

    Bye
    Norbert


    Dilbert's words of wisdom #34:
    When you don't know what to do, walk fast and look worried.
    nntp-bridge Zugriff auf die MS Foren wieder möglich: https://communitybridge.codeplex.com/

    Montag, 9. Mai 2016 11:42
  • Ich würde von einem Inplace Upgrade grundsätzlich auch abraten, da es nur Probleme mit sich bringt.
    Es wird jedoch supportet: https://technet.microsoft.com/de-de/windowsserver/dn527660

    Zudem bietet eine klassische Migration die Domain und Server mal aufzuräumen und die Server neu zu strukturieren.
    Die Migration eines Exchange Servers 2013 ist auch nicht problematisch.
    Neuer Server 2012R2 in die bestehende Domain installieren, Exchange installieren und klassisch migrieren als wäre es ein EX2010.

    https://technet.microsoft.com/de-de/library/jj898583(v=exchg.150).aspx

    https://technet.microsoft.com/de-de/exdeploy2013/Checklist?state=2993-W-AAAAAAAAQAAAAAEAAAAAAAAAAAAAwAM%7e

    Gruß Patrick

    Samstag, 28. Mai 2016 03:23
  • Ich würde von einem Inplace Upgrade grundsätzlich auch abraten, da es nur Probleme mit sich bringt.
    Es wird jedoch supportet: https://technet.microsoft.com/de-de/windowsserver/dn527660

    Nein wird es nicht: https://technet.microsoft.com/en-us/library/bb691354(v=exchg.160).aspx You can't upgrade Windows from one version to another, or from Standard to Datacenter, when Exchange is installed on the server.

    Samstag, 28. Mai 2016 15:48
  • Du hast vollkommen recht.

    Hatte überlesen, dass ein Inplace Uprade auf einem Exchange Server gemacht werden soll.

    Sonntag, 19. Juni 2016 23:02
  • Hallo zusammen

    ersmal vielen Dank für Eure Hinweise.

    Habe den Exchange  Server  zwischenzeitlich installiert

    Mus nur nur die Postfächer verschieben.Hat soweit alles geklappt :-)

    Was mir noch aufgefallen ist ist die Tatsache das alle Emil noch über den "alten" Exchange Server an unseren Smarthost geschickt werden.

    Wir senden alle Emals via Smarthost ins Internet. An den Logs kann ich sehen das der neue Exchange Server

    (hab zwei Testpostfächer schon migriert) alle Mail an den Alten Exchange zustellt.

    An welcher Stelle kan ich diese Verhalten den anpassen?

    Sendeconnector mit Quellservern schon neu erstellt, ohne Erfolg.

    Hab nun etwas "Bauchweh" was passiert sobald alle Postfächer verschoben wurden und der alte Server offline ist....

    Sonnige Gruesse

    Stefan

     

     

    Montag, 27. Juni 2016 11:49
  • Am 27.06.2016 schrieb Stefan Kahlert:
    Hi,

    Hab nun etwas "Bauchweh" was passiert sobald alle Postfächer verschoben wurden und der alte Server offline ist....

    Im Sendeconnector nur den neuen Server eintragen.

    Montag, 27. Juni 2016 13:33
  • Hallo,

    hatte ich schon versucht. Nur leider werden die Mails sobald der alte Server vom Connector gelöscht wurde

    nicht mehr zugestellt.

    Sie landen ja alle auf dem alten Server....

    viele Gruesse

    Stefan

    Montag, 27. Juni 2016 14:04
  • Am 27.06.2016 schrieb Stefan Kahlert:
    Hi,

    hatte ich schon versucht. Nur leider werden die Mails sobald der alte Server vom Connector gelöscht wurde

    Hast du den neuen Server im alten Connector hinzugefügt? Danach den alten Server im alten Connector entfernt? Dann kann es noch etwas dauern, bis das Routing wieder ausgewürfelt ist. ;)

    Sie landen ja alle auf dem alten Server....

    Na rate mal, warum die da landen, wenn der Server im Connector steht. Wieviele Sendeconnectoren hast du? Alternativ lösche den alten Connector mit dem alten Server und leg einen neuen Connector mit dem neuen Server und den gleichen Einstellungen an. Auch dann solltest du die Transportservices auf den Servern mal durchtreten, damit der alte Server weiß, wo es ins Internet geht. ;)

    Bye
    Norbert


    Dilbert's words of wisdom #34:
    When you don't know what to do, walk fast and look worried.
    nntp-bridge Zugriff auf die MS Foren wieder möglich: https://communitybridge.codeplex.com/

    Montag, 27. Juni 2016 15:11
  • Das hat aber alles nichts mehr mit dem OP zu tun.

    Wenn du hier noch weiter Unterstützung brauchst, trenne ich den Thread hier gerne.

    :)


    Gruß Norbert

    Montag, 27. Juni 2016 19:04
    Moderator
  • Hallo,

    ist leider das eingetreten was ich befürchtet hab....

    Zwischenzeitlich sind alle Postfächer auf dem neuen Server

    Die Senderconnector hab ich neu erstellt. Als Quell Server nur den neuen eingetragen

    Alten Server reboot, auf dem neuen Server die Dienste durchgestartet.

    Die Mail landen alle auf dem alten Server ! und können nicht zugestellt werden

    Hab ca 2 Stunden gewartet

    Queue läuft voll

    Noch jemande ne Idee?

    besten Dank

    Viele Gruesse

    Donnerstag, 30. Juni 2016 13:12
  • Am 30.06.2016 schrieb Stefan Kahlert:
    Hi,

    Die Senderconnector hab ich neu erstellt. Als Quell Server nur den neuen eingetragen

    Und der neue Server kann auch nach extern senden?

    Alten Server reboot, auf dem neuen Server die Dienste durchgestartet.

    Die Mail landen alle auf dem alten Server ! und können nicht zugestellt werden

    Warum nicht? Der Sendeconnector auf dem alten Server ist noch da, und sollte doch das Internet/Smarthost weiterhin erreichen oder? ;)

    Noch jemande ne Idee?

    SMTP Log, warum die Mails zum alten Server geroutet werden.

    Bye
    Norbert


    Frank, I never thought I'd say this again. I'm getting the pig!
    nntp-bridge Zugriff auf die MS Foren wieder möglich: https://communitybridge.codeplex.com/

    Donnerstag, 30. Juni 2016 13:20
  • Hallo Norbert,

    komm so nicht weiter. Hab bei MS mal ein Ticket eröffnet

    Halt euch auf dem laufenden...

    schönes Wochenende

    Stefan

    Freitag, 1. Juli 2016 11:13
  • Hallo zusammen,

    Problem gelöst

    Der MS Techniker hat alle Empfangs & Sendeconnectoren neu erstellt

    Auf dem alten Server alle Empfnagsconnectoren deaktiviert

    Die Dienst edurchgestartet

    Seither läufts....

    muss man nicht verstehen

    Viele Gruesse

    Stefan

    Mittwoch, 13. Juli 2016 14:46