none
Kein Zugriff auf Geräte im Netzwerk über SMB RRS feed

  • Frage

  • Hallo,

    im privaten Netzwerk habe ich mehre Win10 Rechner, die untereinander Dateifreigaben haben. Das funktioniert auch. Dazu kommen mehrere Geräte die über SMB angesprochen werden (Router, NAS etc.)

    In der Netzwerkübersicht auf allen Win10 werden die Geräte vollständig angezeigt.Bild

    PrimeBook (win10) kann auf alle zugreifen

    Server2020 (win10) kann auf Primebook(win10) zugreifen - nicht aber auf ET9X00(SMB3) und ASUS-RT(SMB1)

    Auf dem Server2020 kommt diese Fehlermeldung:

    Bild

    Die Aufforderung den Benutzer/Passwort ein zu geben kommt nicht

    SMB ist eigentlich installiert:

    Bild

    Wer hat eine Idee, was das Problem sein könnte?

    Donnerstag, 23. Juli 2020 12:30

Antworten

Alle Antworten

  • Seit Update 2004 scheint es mit SMB1 unwiderrufliche Probleme zu geben auch wenn man SMB1 noch aktivieren kann.
    Donnerstag, 23. Juli 2020 13:56
  • Für ET9X00(SMB3) braucht es die veraltete SMB 1.0/CIFS Freigabe nicht, ist ja SMB3!

    ASUSRT ist offensichtlich noch SMB1, nur würde ich das Häckchen ... automatisch entfernen ganz sicher weglassen. Weiter wenn ich von Windows als Client auf den samba share von ASUSRT zugreiffen will brauche ich nur das -Client Häckchen. Das Kästchen -Server würde ich also auch leer lassen.

    Weitere Hinweise: Mit der Version 2004 hat Microsoft mindestens für SMB1 neue Bugs eingebracht:

    Wenn ein Netzlaufwerk mit verbinden gewählt wird, gibt es nach dem Neustart ein Problem falls man "Verbindung bei Anmeldung wieder herstellen" gewählt hat. Auf keines dieser Netzlaufwerke kann nach dem Neustart zugergriffen werden. Wenn man das genannte Häckchen weglässt, darf man nach jedem Neustart wieder neu einbinden. Ist langweilig und mühsam, aber immerhin funktioniert's! Und auf nicht eingebundene Netzlaufwerke kann man auch zugreifen. Wenn man wegen Häckchen nicht zugreiffen kann, muss man alle ALLE eingebundenen Laufwerke trennen, mindestens den Explorer schliessen danach neuer Explorer öffnen und neu von Hand verbinden. Funktioniert, aber nicht immer. Bei Letzterem muss man mindestens abmelden oder sogar restarten! Unheimlich amüsant!

    Donnerstag, 23. Juli 2020 13:58
  • Um Netzlaufwerke erneut einzubinden hatte ich vor Kurzem diesen Beitrag gefunden, vielleicht hilfts:

    Es gibt auf support.microsoft.com einen älteren Artikel, der per Powershellscript das Problem löst, indem mit dem Befehl: "New-SmbMapping" die Laufwerke nochmals gemappt werden können:

    Verbindungswiederherstellung mit zugeordnetem Netzlaufwerk kann in Windows 10, Version 1809 fehlschlagen

    https://support.microsoft.com/de-de/help/4471218/mapped-network-drive-may-fail-to-reconnect-in-windows-10-version-1809

    Wenn mit: Get-SmbMapping (PS) bzw. net use (DOS) die Laufwerke noch angezeigt werden, und nicht auf "OK" stehen, könnte es helfen.

    Ist aus diesem Beitrag:

    https://social.technet.microsoft.com/Forums/ie/de-DE/03469905-e833-461f-a278-2ca1fd14a84d/netzwerklaufwerke-mit-rotem-x?forum=win10itprogeneralDE#2a4dc45f-0913-407c-8e45-e4a65b1da9ea


    • Bearbeitet heutegehtes Donnerstag, 23. Juli 2020 14:25
    Donnerstag, 23. Juli 2020 14:21
  • Einer meiner Kunden hat das Problem so lösen können, da er ein System hat dass SMB2 oder höher nicht unterstützt:

    "„ … Registrierungsschlüssel "ProviderFlags" als REG_DWORD mit dem Wert 1 (0x00000001) zu HKEY_CURRENT_USER\Netzwerk\*SMBv1-Laufwerkbuchstaben* hinzuzufügen …“

    Nach einem Neustart sind hier alle Laufwerke wieder verbunden. Wenn man mehrere Verbindungen hat, dann reicht der Eintrag bei einem Laufwerksbuchstaben."

    Vielleicht hilft es ja dem einen oder anderen.

    • Als Antwort vorgeschlagen Hungaryfriend Montag, 5. Oktober 2020 16:28
    Mittwoch, 12. August 2020 09:48
  • Bei mir ist nun auch das rote Kreuz auf dem Laufwerk nach dem Boot verschwunden.
    Donnerstag, 13. August 2020 05:31
  • DANKE!!!

    Nach vielen vergeblichen Versuchen die beiden Speicher meines Epsondruckers wieder im Netzwerk einzubinden, war das die Lösung!



    Montag, 5. Oktober 2020 16:24
  • Ich konnte das Thema lösen!

    Unsichere Gastanmeldungen aktivieren

    Diese Richtlinieneinstellung bestimmt, ob der SMB-Client unsichere Gastanmeldungen auf einem SMB-Server zulässt.

    Hier der komplette Artikel mit der Lösung:

    https://getadmx.com/?Category=Windows_10_2016&Policy=Microsoft.Policies.LanmanWorkstation::Pol_EnableInsecureGuestLogons&Language=de-de

    Samstag, 24. Oktober 2020 12:21