none
Windows 7, Softwareinstallation, PC langsam RRS feed

  • Allgemeine Diskussion

  • Hallo zusammen,

    ich weiß nicht ob ich hier im richtigen Forum bin, aber ich weiß das hier gute Leute sitzen.

    Ich habe heute bei meinem Kollegen gesehen, dass um 10:30 sein PC hing. Man konnte nicht einmal mehr mit der Maus vernüftig arbeiten. Man merkte das die Platte arbeitet. Eventlog angesehen und herausgefunden, dass um diese Zeit eine Software (Adobe Flash) per GroupPolicy installiert wird, jedoch die bestehende ältere Version nicht deinstalliert werden konnte.

    Ich denk da bleibt uns nicht viel an Möglichkeiten, wenn Windows 7 so schlecht reagiert, dass gleich der ganze PC hängt nur weil die Platte kurz einmal mehr zu tun hat! Generell fällt auf, dass die PC (auch neuere) obwohl immmer schnell durch Hintergrund Virenscannen, Hintegrund Indizieren trotzdem wieder bald am Limit  sind

     


    Chris
    Mittwoch, 7. Dezember 2011 10:48

Alle Antworten

  • Hallo,

    nun gut, was soll ich zu großartig sagen?

    Ok, fangen wir mal so an:

    >Ich denk da bleibt uns nicht viel an Möglichkeiten, wenn Windows 7 so schlecht reagiert, dass gleich der ganze PC hängt

    Das hat erstmal nichts großartig mit Windows 7 zu tun.
    Du musst ermitteln warum das so ist.
    Du hast von Haus aus schon einmal ein paar gute Tools dafür, z.B. den Ressourcenmonitor (welchen du im Taskmanager > Leistung findest). Dort kannst du schon einmal erkennen, welche Process genau die Festplattenlast verursacht.

    Performanceeinbrüche können sehr viele Ursachen haben. Angefangen von veralteten Treibern bishin zu defekter oder falsch
    konfigurierter Hardware.

    Das eigentliche Betriebssystem spielt hierbei meistens nur die Nebenrolle.

    Was dein Problem mit der Softwarezuweisung per GPO betrifft, so wie ich das sehe werden die Pakete nicht von dir angelegt sondern von den Admin(s) die die Domäne betreuen?

    Wenn das so ist, dann spreche doch bitte mit diesen Personen.
    Andernfalls können wir natürlich noch einiges an Logging usw. aktivieren.
    Aber das macht nur Sinn, wenn du auch die Hintergründe verstehst.

     


    MVP - Group Policy http://matthiaswolf.blogspot.com/
    Mittwoch, 7. Dezember 2011 12:18
    Beantworter
  • es lag großteils am Flash.

    Eine Flash Anwendung im IE benötigte den Flashplayer verbrauchte ca. 750MB RAM, und die GP konnte nicht angewendet werden, da ein Problem mit dem MSI von Adobe gibt. Tritt leider nicht bei jedem Client auf.

    http://forums.adobe.com/thread/707685

    PS: Ich kann mich noch ein Zeiten erinner, da war die Grafik im Kernel und verursachte dann BlueScreens. Nur weil eine anwendung nicht installiert werden kann sollte nicht gleich das ganze Betriebssystem hängen. Es ging auch kaum der Taskmanager.

     


    Chris
    Mittwoch, 7. Dezember 2011 14:14
  • > Man konnte nicht einmal mehr mit der Maus vernüftig arbeiten. Man merkte
    > das die Platte arbeitet. Eventlog angesehen und herausgefunden, dass um
    > diese Zeit eine Software (Adobe Flash) per GroupPolicy installiert wird,
     
    Sorry, da muß ich Dir widersprechen - per GPO wird Software garantiert
    NICHT installiert, während der Anwender angemeldet ist. Das MUSS
    irgendwas anderes gewesen sein, das diese Installation angestoßen hat.
    AppMgmt wird nur und ausschließlich beim Computerstart/bei der Anmeldung
    verarbeitet.
     
    Und MSI-Installationen aus GPOs laufen auch nicht asynchron im
    Hintergrund - der Installer muß fertig sein, bevor es weitergeht.
     
    mfg Martin
     

    A bissle "Experience", a bissle GMV...
    Mittwoch, 7. Dezember 2011 16:49
    Beantworter
  • Ich habe das gleiche Problem wie Martin.

    Du mischt viele Fragen und dein konkretes Problem kann ich im Moment nicht erkennen.

    Zum Thema AppMgmt:

    >Eine Flash Anwendung im IE benötigte den Flashplayer verbrauchte ca. 750MB RAM, und die GP konnte nicht angewendet werden

    Ist das Problem mit der Installation nun gelöst oder besteht es immer noch?

    Hast du das Logging des MSI Installers einmal aktiviert?

    http://support.microsoft.com/kb/223300

    Sollte das FixIt nicht zutreffend sein, bitte manuell aktivieren.

    Die MSI lässt sich manuell, also nicht per GPO, installieren?

    Wenn dir das Logging des Installers nicht weiter hilft, dann nofalls noch Appmgmtdebuglevel setzen:
    http://technet.microsoft.com/en-us/library/cc775423(WS.10).aspx

    Aber nur am Rande, erwarte von der integrierten Softwaredistribution mittels AD nicht sonderlich viel.

    Ich habe schon viele Pakete gesehen, die nicht kompatibel sind.

    Hier ist ein "richtiges" Softwaredistribution-Werkzeug oftmals vorteilhafter (ala SCCM etc.)


    MVP - Group Policy http://matthiaswolf.blogspot.com/
    Mittwoch, 7. Dezember 2011 20:20
    Beantworter