none
"whoami /groups" SID wird nicht aufgelöst RRS feed

  • Frage

  • Hallo zusammen

    Wir habe bei uns den MCAfee Web Gateway (MWG) auf allen Clients (Windows 10) installiert. Dieser steuert den Internet Zugriff anhand einer Gruppe aus dem AD. Nun gab es schon mehrere Fälle in denen Benutzer blockiert wurden, obwohl diese in der Gruppe sind. Der McAfee Support meint, dass der MWG Client die Gruppe nicht erkennt. 

    Ebenfalls haben wir festgestellt, dass die Gruppennamen nicht oder nur zum Teil aufgelöst werden, wenn der Client keine Verbindung zum AD hat. Nach Absetzen des Befehls "whoami /groups" sieht das z.B. wie folgt aus (ganze SID habe mit xxx gekürzt/ersetzt):

    GROUP INFORMATION
    -----------------
    
    Group Name                                               Type             SID                                              Attributes                                                     
    ======================================================== ================ ================================================ ===============================================================
    Jeder                                                    Well-known group S-1-1-0                                          Mandatory group, Enabled by default, Enabled group             
    VORDEFINIERT\Administrators                              Alias            S-1-5-32-544                                     Group used for deny only                                       
    VORDEFINIERT\Event Log Readers                           Alias            S-1-5-32-573                                     Mandatory group, Enabled by default, Enabled group             
    VORDEFINIERT\Users                                       Alias            S-1-5-32-545                                     Mandatory group, Enabled by default, Enabled group             
    NT-AUTORITŽT\INTERAKTIV                                  Well-known group S-1-5-4                                          Mandatory group, Enabled by default, Enabled group             
    KONSOLENANMELDUNG                                        Well-known group S-1-2-1                                          Mandatory group, Enabled by default, Enabled group             
    NT-AUTORITŽT\Authentifizierte Benutzer                   Well-known group S-1-5-11                                         Mandatory group, Enabled by default, Enabled group             
    NT-AUTORITŽT\Diese Organisation                          Well-known group S-1-5-15                                         Mandatory group, Enabled by default, Enabled group             
    LOKAL                                                    Well-known group S-1-2-0                                          Mandatory group, Enabled by default, Enabled group             
                                                             Unknown SID type S-1-5-21-xxxxxx                                  Mandatory group, Enabled by default, Enabled group             
                                                             Unknown SID type S-1-5-21-xxxxxx                                  Mandatory group, Enabled by default, Enabled group             
                                                             Unknown SID type S-1-5-21-xxxxxx                                  Mandatory group, Enabled by default, Enabled group             
                                                             Unknown SID type S-1-5-21-xxxxxx                                  Mandatory group, Enabled by default, Enabled group       

    Die SID bleibt immer im Cache, der Gruppenname nicht. Gibt es eine Möglichkeit (per GPO z.B.) diese Gruppen ebenfalls in den Cache mitzugeben oder gibt es hierzu andere Lösungen?

    Ähnlicher Fall:
    https://social.technet.microsoft.com/Forums/ie/en-US/1112015a-52c4-4a8e-adc0-0ec24cff5845/whoami-groups-does-not-show-domain-groups?forum=windowsbackup

    Informationen zu MWG

    https://www.mcafee.com/enterprise/en-us/products/web-gateway.html


    • Bearbeitet errorwarrior Donnerstag, 14. Februar 2019 11:51
    Donnerstag, 14. Februar 2019 11:41