none
Hyper-V - Storage Performance RRS feed

  • Frage

  • Hallo zusammen,

    wie haben extreme Performance Probleme mit unserem Hyper-V Server im Bereich Storage. Die Systeme sind extrem träge. Gerade der SQL Server und Exchange Server sind ein grauen. Was ja auch ziemlich normal ist bei Storage Problemen… Hier ein kurzer Überblick der Hardware.

    Hardware:

    HP C7000

    BL460c Gen8 Blade

    Brocade SAN Switche (Intern im C7000)

    HP EVA P6350 (100 * 10k Disks)

    Betriebssystem: Windows Server 2012 R2

    Das C7000 hat eine direkte Storage Anbindung per Fiber Channel. Die LUNs werden unter dem Host (Hyper-V) mittels MPIO verbunden. In dieser Konfiguration erreichen wir max. 1500 IOPS. Dabei spielt es auch keine Rolle welches Raid Level die LUNs haben. Also egal ob Raid 1, 5 oder 6 an der Performance sprich IOPS ändert sich nichts. Es bleibt bei den ~1500 IOPS. Der Hyper-V Server wurde mittels HP Intelligent Provisioning installiert.

    Dann haben wir zum Testen auf dem Blade das aktuelle ESXi Image installiert, LUNs verbunden und eine virtuelle Maschine in Betrieb genommen. Wir erreichen in dieser Konfiguration ~12 000 IOPS. Mit gleicher Hardware ohne spezielles Fein Tuning.

    Was läuft da an der Windows Konfiguration schief? Bzw. was kann/muss ich am MPIO Konfigurieren? Treiber sind in der Windows Welt auf dem neusten Stand. Die aktuelle Firmware der HBA (QLogic QMH2572) ist auch installiert. Das aktuell SPP von HP ist auch komplett installiert.

    Hat da jemand ein Tipp für mich?

    Gruß

    Donnerstag, 1. Juni 2017 08:10

Antworten

Alle Antworten