none
Aufgabenplanung Fehlermeldung, Pfadname ungültig RRS feed

  • Frage

  • Hallo erstmal :)

    Ich bin Dual Student und soll in meinem Unternehmen einen Kioskmodus, mit Hilfe der Aufgabenplanung, auf unseren Zero-Clients (VDI) implementieren. Dies Scheitert jedoch aktuell beim erstellen der Aufgabe, da der Pfadname wohl ungültig ist. Ich vermute das er die Aktion nicht von C ausführen will. Es ist dabei egal ob ich meine batch Datei starten will, oder einfach nur z.B. PowerPoint. Der Pfadname ist immer ungültig. Hat dazu jemand eine Idee? Oder weiß vielleicht, dass es mit Zero-Clients überhaupt nicht möglich ist über die Aufgabenplanung?

    mit freundlichen Grüßen

    Schmidt

    Montag, 7. August 2017 09:47

Antworten

  • Wichtig zu wissen ist, dass die Aufgabenplanung zwar unter einem bestimmten Benutzer durchgeführt wird, aber keine Anmeldung incl. Profilübernahme durchführt. M.a.W, das klappt meist nur mit lokalen Usern.
    Also verwendest du am Besten immer Pfade, die den Usernamen nicht beinhalten.
    Beispiel: "Eigene Dateien", "Dokumente" liegen z.B. in einem Verzeichnis "Dokumente und Einstellungen/Mein UserName/Eigene Dateien".
    Dieser Pfad ist bei Netzwerkusern in der Aufgabenplanung nicht verfügbar.
    Montag, 7. August 2017 10:08
  • Alle benötigten Objekte müssen zum Zeitpunkt der Ausführung natürlich zur Verfügung stehen.
    Wenn der User also nicht angemeldet ist, also nicht lokal registriert ist, exisitiert die gesamte Umgebung halt nicht (Stichwort Profil-Roaming).
    Viele Dinge wie Laufwerkszuordnung erledigen Logon-Sripte. Da ja kein Logon (Dialog) sondern nur eine Anmeldung stattfindet, erfolgt auch keine Ausführung des Scriptes.
    Dienstag, 8. August 2017 06:21

Alle Antworten

  • Wichtig zu wissen ist, dass die Aufgabenplanung zwar unter einem bestimmten Benutzer durchgeführt wird, aber keine Anmeldung incl. Profilübernahme durchführt. M.a.W, das klappt meist nur mit lokalen Usern.
    Also verwendest du am Besten immer Pfade, die den Usernamen nicht beinhalten.
    Beispiel: "Eigene Dateien", "Dokumente" liegen z.B. in einem Verzeichnis "Dokumente und Einstellungen/Mein UserName/Eigene Dateien".
    Dieser Pfad ist bei Netzwerkusern in der Aufgabenplanung nicht verfügbar.
    Montag, 7. August 2017 10:08
  • Das klingt für mich soweit logisch. Sollte es dann nicht aber bei Programmen wie PowerPoint funktionieren? Das liegt ja unter C:\Programme oder liegt es dann daran, dass das Image ja an einen User gebunden ist ?
    Montag, 7. August 2017 10:58
  • Alle benötigten Objekte müssen zum Zeitpunkt der Ausführung natürlich zur Verfügung stehen.
    Wenn der User also nicht angemeldet ist, also nicht lokal registriert ist, exisitiert die gesamte Umgebung halt nicht (Stichwort Profil-Roaming).
    Viele Dinge wie Laufwerkszuordnung erledigen Logon-Sripte. Da ja kein Logon (Dialog) sondern nur eine Anmeldung stattfindet, erfolgt auch keine Ausführung des Scriptes.
    Dienstag, 8. August 2017 06:21
  • Auch das macht Sinn. Deswegen habe ich eine automatische Anmeldung über PCoIP eingerichtet, damit der Benutzer sich unabhängig von anderen Programmen anmeldet. Aber wie ich ja geschrieben habe, lässt sich die Aufgabe gar nicht erst erstellen!! Ich wähle z.B. einfach PowerPoint als Aktion aus, wähle Benutzer usw. und beim Abschließen der Aufgabe kommt die Fehlermeldung das der Pfadname ungültig sei.

    Ich kann sie also noch überhaupt nicht ausführen lassen...

    Dienstag, 8. August 2017 06:40
  • Dann prüfe noch mal alle Pfadangaben, die du bei der Aufgabenerstellung angibst.
    Oder mache es Schritt für Schritt:
    a) Aufgabe erstellen mit dem Exe-Namen
    b) Aufgabe ergänzen mit Parametern usw....

    Im Übrigen:
    Wenn ein Pfad Leerzeichen enthält, setze ihn in doppelte Anführungszeichen:

    "C:\Dies ist mein langer Pfad\"NameDerExe.exe

    Dienstag, 8. August 2017 11:34
  • Ok, habe ich gemacht. Brachte mich leider noch nicht weiter... 

    Ich versuche jetzt gerade einfach erstmal die PowerPoint.exe zu starten.

    Der Pfad dazu lautet: "C:\Program Files (x86)\Microsoft Office\Office16\POWERPNT.EXE"

    Er wird scheinbar auch automatisch von der Aufgabenplanung in Anführungszeichen gesetzt. Das sollte dann wohl auch nicht das Problem sein. Immer die selbe Fehlermeldung: Der angegebene Pfadname ist ungültig..

    Ich habe auch versucht die letzten Anführungszeichen vor die .exe zu setzen, so wie du es vorgeschlagen hast. Leider auch ohne Erfolg..

    Und andere Pfadangaben mache ich ja nicht. Ich habe auch versucht einen anderen Trigger zu wählen (zuvor Bei Anmeldung) und ein anderes ausführendes Konto zu wählen. Auch ohne Erfolg und die selbe Meldung... 

    • Als Antwort vorgeschlagen AdLuger2016 Mittwoch, 26. Mai 2021 15:38
    Dienstag, 8. August 2017 13:32
  • Also meine Office2016-Installation verweist auf "C:\Program Files (x86)\Microsoft Office\root\Office16".
    Prüfe das doch einfach mal über den Windowsexplorer (Start->Ausführen, bzw. WIN-Taste + "R").

    Dienstag, 8. August 2017 16:36
  • Daran hat es scheinbar auch nicht gelegen. Hab es so ausgeführt, aber der Pfad ist nicht verfügbar. Habe das dann natürlich auch direkt mit meinen Pfad getestet und PowerPoint öffnet sich...

    Also der Pfad scheint korrekt zu sein. Die Aufgabenplanung mag den nur nicht.


    Mittwoch, 9. August 2017 06:55
  • Also sollte sich hier jemand melden der, wieso auch immer :), die selbe Aufgabe zu bewältigen hat, wir haben das Problem jetzt lösen können, indem wir die Firewall für die Kiosk-Profile abgeschaltet haben. Danach hat es funktioniert und ich konnte den Kioskmodus fertigstellen.

    Bin dennoch dankbar das du (@bfuerchau) mir versucht hast schnellstmöglich zu helfen.

    mit freundlichen Grüßen

    Schmidt 

     
    Donnerstag, 10. August 2017 11:45
  • Nun ja, wenn der User im Kiosk-Modus läuft dann darf der halt nicht alles.
    Da stellt sich mir die Frage, wieso der Kiosk-Modus für den User im Batch eingeschaltet aber im Dialog ausgeschaltet ist.
    Donnerstag, 10. August 2017 12:10