none
Windows Server 2016 - Kein Sound über RDP RRS feed

  • Frage

  • Sehr geehrte Community,

    leider hatte ich bisher keine richtige Lösung für mein Problem gefunden, weshalb ich euch um Rat fragen möchte.

    Ich habe einen virtualisierten Windows Server 2016, welcher auf einem Hyper-V (Generation 2) läuft und Mitglied einer Domäne ist.

    Dieser Server fungiert nur als Terminalserver und soweit funktioniert auch alles wunderbar, naja bis auf Folgendes:

    Wenn ich mich via RDP auf den Server schalte, erhalte ich leider keinerlei Sounds.


    Leider finde ich immer wieder gleiche Vorgehensweisen, welche mich aber leider noch nicht weitergebracht haben. Folgendes habe ich schon probiert:

    - Überprüfen des Audiodienstes (war und ist aktiviert)

    - Überprüfen der GPO:

    "Computerkonfiguration -> Administrative Vorlagen -> Windows Komponenten -> Remotedesktopdienste -> Remotedesktopsitzungs-Host -> Geräte- und Ressourcenumleitung"

    Dort habe ich entsprechend alles aktiviert.

    - Einstellungen in der RDP Verbindung überprüft: Audio wird auf dem Rechner ausgegeben, über welchen ich die Verbindung herstelle


    Sobald ich die Verbindung mit dem Server hergestellt habe, wird mir auch unten angezeigt, dass der Sound "Remoteaudio" aktiv sei. Aber dennoch kommt kein Sound.


    Auch die Registry habe ich überprüft:

    "Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp"

    Eintrag "DisableAudioCapture" war bereits auf Wert "0".

    Im Geräte-Manager wird mir auch Remoteaudio angezeigt.

    Brauche ich vielleicht einen Treiber oder muss ich im Hyper-V Manager etwas für die VM einstellen? Gibt es vielleicht ein zusätzliches Feature oder Ähnliches, welches ich vergessen habe? Ich bin ratlos und würde mich über jede Hilfe freuen.

    Falls ihr mehr Informationen braucht lasst es mich gerne wissen.

    Leider konnte ich noch keine Bilder in den Post einfügen.

    Viele Grüße

    Donnerstag, 26. März 2020 07:50

Alle Antworten

  • Hallo Jan Phillipp

    in diesem Thread kannst Du Dein Konto verifizieren lassen:

    Verify Account

    Gruß

    Mihaela


    Bitte haben Sie Verständnis dafür, dass im Rahmen dieses Forums, welches auf dem Community-Prinzip „IT-Pros helfen IT-Pros“ beruht, kein technischer Support geleistet werden kann oder sonst welche garantierten Maßnahmen seitens Microsoft zugesichert werden können.



    Donnerstag, 26. März 2020 21:39
    Moderator
  • Hallo Jan,

     

    hmm, die bei dir zum Einsatz kommende VM Gen (nämlich 1 oder 2) dürfte wohl eher wenig bis gar nichts mit VM Audio zu tun haben.

     

    Würde an deiner Stelle mal überprüfen ob deine Installation die Aktivierung des erweiterten Modus ermöglicht oder nicht. Dies lässt sich nach Start der VM anhand des Buttons "Erweiterte Sitzung" überprüfen. Sollte dieser ausgegraut sein wirst du aus meiner Sicht um ein Neuaufsetzen nicht herumkommen.

     

    RDP sollte alternativ  dazu eigentlich Audio ermöglichen, weshalb das in deinem Fall nicht funktioniert -gute Frage..

     

    Hier findest du zur Thematik weitere Hinweise.

     

    Stefan

    Donnerstag, 26. März 2020 22:51
  • Hallo Stefan,

    vielen Dank für Deine Antwort und bitte entschuldige die späte Antwort.

    Ich habe, wie in der von Dir angefügten Anleitung im Link, den erweiterten Modus im Hyper-V Manager aktiviert. Hat auch alles funktioniert, nur hatte ich leider weiterhin keinen Sound. Wenn ich das richtig verstehe bringt das nur etwas, wenn ich eine Verbindung zum virtuellen Server über den Gastgeber aufbaue, oder?

    In meinem Falle würde es aber über einen anderen Client geschehen, welcher sich im selben Gebäude befindet und mittels mstsc (Remotedesktop) auf den Server zugreift. Dort funktioniert der Sound leider nicht.

    Viele Grüße

    Montag, 30. März 2020 11:53