none
Exchange in VM - Keine Löschung der Log-Files nach Backup RRS feed

  • Frage

  • Hallo,

    ich habe Exchange in einer Hyper-V VM laufen. Der Hyper-V Server führt täglich eine komplette Sicherung (mit der Windows Server Sicherung) von Festplatten und VM's durch, also auch von der VM-Instanz mit Exchange. 

    Normalerweise sollte Exchange die Log-Files seiner Mailbox-Datenbanken nach einem erfolgreichen Backup bereinigen. Dies geschieht in meinem Fall jedoch nicht, wodurch die Logs sich mit der Zeit auf der ganzen Festplatte breit machen. Liegt es möglicherweise daran, dass die Windows-Bordmittel unfähig sind der VM zu signalisieren, dass sie mitgesichert wurde? Gibt es irgendeine bekannte Lösung, damit diese Log-Bereinigung automatisch durchgeführt wird, nachdem der Hyper-V Host sein Backup erfolgreich beendet hat?

    Mit besten Grüßen,

    Hendrik Motza

    Dienstag, 4. März 2014 15:52

Antworten

  • Moin,

    das geht auch mit inkrementiellen Backups. Allerdings kannst Du die bei WSB im Assistenten nicht explizit auswählen. Da kannst Du noch "Voll" oder "Kopie" auswählen. Ob dann nur Voll oder Voll+Inkrement gesichert wird, entscheidet sich über das Backup-Ziel. Bei lokalen Zielen wird Voll+Ink gemacht, bei Remote Zielen nur Voll. Darauf weist Dich der Assistent beim Anlegen eines geplanten Backups auch hin.

    In Exchange ist das aber egal und wird immer nur als Vollsicherung gesehen. Inkrementiell ist das nur in Hinsicht auf die VM, nicht auf das System in der VM.

    Allerdings muss ich nach einem Test bei mir sagen, dass die Sicherung bei Ex 2013 nicht mehr so zu funktionieren scheint. Auf dem gleichen Host mit Windows 2012 R2 wird in einem Rutsch eine VM mit Ex 2010 (auf Windows 2008 R2) und eine mit Ex 2013 SP 1 (auf Windows 2012) gesichert. Bei Ex 2010 sieht das wie erwartet aus, bei 2013 nicht.

    Mehr kann ich aus Zeitgründen nun aber nicht testen. Ist schwer zu sagen, ob es hier am BS oder an Exchange liegt. Beiden traue ich Änderungen zu.

    Dann wirst Du wohl doch in der VM selbst noch mal sichern müssen. Das kann man mit Diskshado scripten. Dann "scheint" zwar eine Sicherung zu laufen, man muss aber keine Dateien bewegen..

    Das würde dann so aussehen, nur ohne die Befehle expose und exec.

    http://wolfgangontheroad.wordpress.com/2009/08/06/245-exchange-2007-backup-auf-windows-server-2008-mit-bordmitteln-reloaded/

    Habe ich eben ausprobiert. Funktioniert und entfernt die Logs. Einträge 224 und 2006 werden wie erwartet erzeugt.


    Gruesse aus Berlin schickt Robert - MVP Exchange Server

    • Als Antwort markiert Hendrik Motza Freitag, 21. März 2014 11:25
    Dienstag, 18. März 2014 18:03

Alle Antworten

  • Moin,

    in diesem Forum sind zwar ein paar gute Leute, aber hellsehen gehört leider noch nicht dazu. ;)

    Version Exchange?

    Version Hyper-V?

    Wird eine "Vollständige VSS-Sicherung" durchgeführt und nicht eventuell eine "VSS-Kopiesicherung"?

    Was schreibt Exchange nach dem Backup in Event 224 und 2006 (Quelle ESE)?


    Gruesse aus Berlin schickt Robert - MVP Exchange Server

    Dienstag, 4. März 2014 17:56
  • Gut dass du es sagst, da ich kein Hellseher bin, war mir das noch nicht bewusst! :-D

    Ich dachte vielleicht hätte hier ohnehin schon jemand die Erfahrung gemacht, aber manchmal habe ich den Eindruck, dass ich scheinbar eine eher untypische Server-Konfiguration haben muss! ;-)

    Derzeit laufen die Windows Server noch mit 2012 (nicht R2). Exchange 2013 (V15) ist nur auf der einen VM eingerichtet.  

    Es wird eine vollständige Sicherung mit inkrementellen Backups durchgeführt. Aber das habe ich schon recherchiert und sollte wohl kein Problem sein. 

    Seit dem Ersatz der EMC durch das ECP im Browser habe ich ohnehin das Gefühl, dass viele Tools zum Debuggen abhanden gekommen sind. Ich vermute mal du meinst die "MSExchange Management"-Logs in der Ereignisanzeige? Dort ist leider nichts erkennbar in Bezug auf durchgeführte Sicherungen. Die einzigen Logs von heute sind das erneute Einbinden der DB und die Umstellung der Umlaufprotokollierung (um erstmal auf manuellem Wege 50GB Logfiles los zu werden). 

    Liebe Grüße zurück von Berlin nach Berlin!

    Hendrik

    Dienstag, 4. März 2014 19:16
  • Hallo Alex,

    leider bin ich noch kein Stück schlauer als vor 2 Wochen (allerdings war ich auch die letzte Woche auf Dienstreise). Mir mangelt es auch ein wenig an Ideen, was ich noch ausprobieren könnte.

    Ich bin auch schon seit einem Jahr im Gespräch mit der Firma Altaro. Auf meine Anfrage hin wollten diese ein paar neue Features in ihre Backup-Software einbauen, die vermutlich auch solche Probleme lösen sollte. Unglücklicherweise werde ich auch da stets vertröstet, bisher gibt es keine neue Version und das geplante Release wird immer wieder mal verschoben.

    Gruß,

    Hendrik

    Sonntag, 16. März 2014 11:23
  • Moin,

    Backup vom Host hilft dir beim Exchange nicht, da musst du den Gast sichern.

    Übrigens Voll-Backup, nicht inkremetell...

    http://www.msxfaq.de/admin/backupwinbackup.htm

    ;)


    Gruß Norbert

    Montag, 17. März 2014 05:58
    Moderator
  • Moin,

    wie kommst Du darauf? Natürlich kann man auf dem Host beim Sichern der VMs auch fehlerfrei Exchange mitsichern. Event 224 und 2006 belegen das wunderbar. Und auch Log-Dateien werden abgeschnitten, alles in Ordnung.

    Es muss halt nur richtig gesichert werden, als die VMs und Voll.


    Gruesse aus Berlin schickt Robert - MVP Exchange Server

    Montag, 17. März 2014 17:11
  • Ich dachte ich hätte auch etwas davon gelesen, dass es mit vollen sowie inkrementellen Backups funktionieren soll. Man könnte auch meinen, dass das erste inkrementelle Backup fast sowas wie ein Vollbackup ist...

    Ich werde das demnächst nochmal mit dem Vollbackup versuchen und dann hier berichten. Da ich jedoch eindeutig inkrementelle Backups bevorzuge, wäre es auch sehr schön, wenn sich die Logs auf diesem Wege bereinigen ließen...

    Montag, 17. März 2014 22:41
  • Moin,

    das geht auch mit inkrementiellen Backups. Allerdings kannst Du die bei WSB im Assistenten nicht explizit auswählen. Da kannst Du noch "Voll" oder "Kopie" auswählen. Ob dann nur Voll oder Voll+Inkrement gesichert wird, entscheidet sich über das Backup-Ziel. Bei lokalen Zielen wird Voll+Ink gemacht, bei Remote Zielen nur Voll. Darauf weist Dich der Assistent beim Anlegen eines geplanten Backups auch hin.

    In Exchange ist das aber egal und wird immer nur als Vollsicherung gesehen. Inkrementiell ist das nur in Hinsicht auf die VM, nicht auf das System in der VM.

    Allerdings muss ich nach einem Test bei mir sagen, dass die Sicherung bei Ex 2013 nicht mehr so zu funktionieren scheint. Auf dem gleichen Host mit Windows 2012 R2 wird in einem Rutsch eine VM mit Ex 2010 (auf Windows 2008 R2) und eine mit Ex 2013 SP 1 (auf Windows 2012) gesichert. Bei Ex 2010 sieht das wie erwartet aus, bei 2013 nicht.

    Mehr kann ich aus Zeitgründen nun aber nicht testen. Ist schwer zu sagen, ob es hier am BS oder an Exchange liegt. Beiden traue ich Änderungen zu.

    Dann wirst Du wohl doch in der VM selbst noch mal sichern müssen. Das kann man mit Diskshado scripten. Dann "scheint" zwar eine Sicherung zu laufen, man muss aber keine Dateien bewegen..

    Das würde dann so aussehen, nur ohne die Befehle expose und exec.

    http://wolfgangontheroad.wordpress.com/2009/08/06/245-exchange-2007-backup-auf-windows-server-2008-mit-bordmitteln-reloaded/

    Habe ich eben ausprobiert. Funktioniert und entfernt die Logs. Einträge 224 und 2006 werden wie erwartet erzeugt.


    Gruesse aus Berlin schickt Robert - MVP Exchange Server

    • Als Antwort markiert Hendrik Motza Freitag, 21. März 2014 11:25
    Dienstag, 18. März 2014 18:03
  • Ich muss zu meiner Schande gestehen, dass ich wirklich nur Blind war! Bei der Auswahl der Elemente zur Sicherung fand ich den Dialog so eigenartig, dass ich den Button "Erweiterte Einstellungen" schon gar nicht mehr bewusst wahrgenommen habe. Dort findet sich in dem einen Reiter auch die Einstellung für "Voll" oder "Kopie", welche mir zum Verhängnis wurde.

    Es scheint nun alles wunschgemäß zu funktionieren. Vielen Dank nochmals für die vielen guten Ratschläge!

    Gruß,

    Hendrik

    Freitag, 21. März 2014 11:28
  • Moin,

    danke für die Info.

    Willst Du damit sagen, dass das bei Dir dann doch von außen geklappt hat. Komisch, weil das mir auch nicht klappte.


    Gruesse aus Berlin schickt Robert - MVP Exchange Server

    Freitag, 21. März 2014 12:16
  • Ja es hat funktioniert. Ich nehme an die Sicherung ist bei dir auch ohne Warnungen durchgelaufen?

    Manchmal beendet er das Backup bei mir mit Warnungen, dann findet wohl auch keine Bereinigung statt. Aber ansonsten scheint er es zu machen. Ich sichere bei mir komplett Hyper-V und Systemplatte (Bare-Metal...). Damit scheint er dann auch zufrieden zu sein.

    Freitag, 21. März 2014 12:32