none
Host File (Namensaufschlüsselung) ohne Wirkung RRS feed

  • Frage

  • Hallo Community,

    ich habe folgendes Problem:

    Ich benutze AppGate und den HostFile Writer um eine Verbindung zu einem anderen Firmennetz herzustellen.

    Vorneweg möchte ich anmerken das es kein Fehler des Programms ist und es auf anderen Windows10 installationen hervorragend funktioniert.

    Ich verwende Windows 10 64bit.

    Das Programm Appgate trägt nach erfolgreicher Verbindung folgende IP / Namen in die Hostfile unter c:\windows\system32\drivers\etc\host ein: (Domain wurde unbenannt)

    127.0.0.3        xy1.z.firma.unb     # Added by AppGate Hosts File Writer
    127.0.0.4        xy2.z.firma.unb      # Added by AppGate Hosts File Writer
    127.0.0.2        xy3.z.firma.unb     # Added by AppGate Hosts File Writer
    127.0.0.6        xy4.z.firma.unb      # Added by AppGate Hosts File Writer
    127.0.0.5        xy5.z.firma.unb      # Added by AppGate Hosts File Writer

    Danach öffnet AppGate den Browser uns versucht xy5.z.firma.unb zu öffnen.

    Diese Domain kennt kein Nameserver, trotzdem nutzt Windows10 nicht die Inhalte der Hostfile bzw steht im Browser keine Verbindung

    zum Server möglich. (Das ist in sämtlichen Browsern so, IE EDGE Mozilla usw.).

    AppGate baut über SecureID Verfahren eine Verbindung zu einem anderen Server über Port xx her.

    Diese Verbindung besteht und wurde auch von der Gegenseite bestätigt.

    Bisher wurde folgendes probiert:

    !Es sind keine Proxys vorhanden!

    Firewall deaktivieren

    Virenscanner deaktivieren (EndSet Antivirus mit HostFile Protection)

    Virenscanner sauber deinstallieren

    Windows Defender deaktivieren

    Pfad der Hostfile in der Registry kontrolliert. (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\)

    Kontrolle der Hostfile mit dem Tool Hostman

    TCP/IP Einstellungen auch der Haken für "LMHOSTS Abfrage aktiviert / deaktiviert

    DNS-Cache leeren ( ipconfig /flushdns)

    Loopback IP von 127 auf 0.0.0.0 (testweise)

    IPV6 abgeschalter

    Hostfile als Ausnahme im Defender

    sfc /scannow

    uvm..

    ALLES OHNE ERFOLG

    Wenn ich statt der Domain z.B. https://127.0.0.5 eingebe, dann kann ich mich mit der gewünschten Seite verbinden.

    Nur leider hat hiermit die Sicherheit vom anderen Server ein Problem und sobald ich eine Benutzersession habe werde ich wieder ausgeloggt. (Zertifikate usw gehen auch nicht)

    Wie kann ich an dieses Problem rangehen ohne das ich den Laptop neuinstallieren muss, das wäre für mich der "Worst Case" da ich viele HW Lizenzen nutze.

    Hier noch ein Auszug von ipconfig /all:

    Windows IP Configuration

       Host Name . . . . . . . . . . . . : Firma-NB-USER
       Primary Dns Suffix  . . . . . . . : firma.local
       Node Type . . . . . . . . . . . . : Broadcast
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No
       DNS Suffix Search List. . . . . . : firma.local
                                           fritz.box

    Ethernet adapter Ethernet:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Realtek USB GbE Family Controller
       Physical Address. . . . . . . . . : 18-DB-F2-61-C5-C5
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes

    Wireless LAN adapter Local Area Connection* 11:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft Wi-Fi Direct Virtual Adapter
       Physical Address. . . . . . . . . : 14-AB-C5-2D-0C-B3
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes

    Ethernet adapter Ethernet 2:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . : esrlabs.local
       Description . . . . . . . . . . . : Sophos SSL VPN Adapter
       Physical Address. . . . . . . . . : 00-FF-00-31-19-95
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes

    Wireless LAN adapter Wi-Fi:

       Connection-specific DNS Suffix  . : fritz.box
       Description . . . . . . . . . . . : Intel(R) Dual Band Wireless-AC 8260
       Physical Address. . . . . . . . . : 14-AB-C5-2D-0C-B2
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       IPv6 Address. . . . . . . . . . . : 2003:c6:4bd4:4200:39ce:cff5:8dcd:cdc1(Preferred)
       Temporary IPv6 Address. . . . . . : 2003:c6:4bd4:4200:2d73:e270:e0f0:f1b1(Preferred)
       Link-local IPv6 Address . . . . . : fe80::39ce:cff5:8dcd:cdc1%20(Preferred)
       IPv4 Address. . . . . . . . . . . : 192.168.178.31(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Lease Obtained. . . . . . . . . . : Tuesday, June 20, 2017 9:27:26 AM
       Lease Expires . . . . . . . . . . : Friday, June 30, 2017 9:27:32 AM
       Default Gateway . . . . . . . . . : fe80::cece:1eff:fe5a:1165%20
                                           192.168.178.1
       DHCP Server . . . . . . . . . . . : 192.168.178.1
       DHCPv6 IAID . . . . . . . . . . . : 420785093
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-20-35-BD-8E-18-DB-F2-61-C5-C5
       DNS Servers . . . . . . . . . . . : fd00::cece:1eff:fe5a:1165
                                           192.168.178.1
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Ethernet adapter Bluetooth Network Connection:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Bluetooth Device (Personal Area Network)
       Physical Address. . . . . . . . . : 14-AB-C5-2D-0C-B6
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Teredo Tunneling Pseudo-Interface:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter isatap.fritz.box:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . : fritz.box
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter #3
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Und ein Auszug von route print:

    C:\Users\anton.buchfelder>route print
    ===========================================================================
    Interface List
     14...18 db f2 61 c5 c5 ......Realtek USB GbE Family Controller
     32...14 ab c5 2d 0c b3 ......Microsoft Wi-Fi Direct Virtual Adapter
      2...00 ff 00 31 19 95 ......Sophos SSL VPN Adapter
     20...14 ab c5 2d 0c b2 ......Intel(R) Dual Band Wireless-AC 8260
     22...14 ab c5 2d 0c b6 ......Bluetooth Device (Personal Area Network)
      1...........................Software Loopback Interface 1
      9...00 00 00 00 00 00 00 e0 Teredo Tunneling Pseudo-Interface
     30...00 00 00 00 00 00 00 e0 Microsoft ISATAP Adapter #3
    ===========================================================================

    IPv4 Route Table
    ===========================================================================
    Active Routes:
    Network Destination        Netmask          Gateway       Interface  Metric
              0.0.0.0          0.0.0.0    192.168.178.1   192.168.178.31     35
            127.0.0.0        255.0.0.0         On-link         127.0.0.1    331
            127.0.0.1  255.255.255.255         On-link         127.0.0.1    331
      127.255.255.255  255.255.255.255         On-link         127.0.0.1    331
        192.168.178.0    255.255.255.0         On-link    192.168.178.31    291
       192.168.178.31  255.255.255.255         On-link    192.168.178.31    291
      192.168.178.255  255.255.255.255         On-link    192.168.178.31    291
            224.0.0.0        240.0.0.0         On-link         127.0.0.1    331
            224.0.0.0        240.0.0.0         On-link    192.168.178.31    291
      255.255.255.255  255.255.255.255         On-link         127.0.0.1    331
      255.255.255.255  255.255.255.255         On-link    192.168.178.31    291
    ===========================================================================
    Persistent Routes:
      None

    IPv6 Route Table
    ===========================================================================
    Active Routes:
     If Metric Network Destination      Gateway
     20    291 ::/0                     fe80::cece:1eff:fe5a:1165
      1    331 ::1/128                  On-link
      9    331 2001::/32                On-link
      9    331 2001:0:9d38:78cf:48d:2128:3f57:4de0/128
                                        On-link
     20    291 2003:c6:4bd4:4200::/56   fe80::cece:1eff:fe5a:1165
     20    291 2003:c6:4bd4:4200::/64   On-link
     20    291 2003:c6:4bd4:4200:2d73:e270:e0f0:f1b1/128
                                        On-link
     20    291 2003:c6:4bd4:4200:39ce:cff5:8dcd:cdc1/128
                                        On-link
     20    291 fe80::/64                On-link
      9    331 fe80::/64                On-link
      9    331 fe80::48d:2128:3f57:4de0/128
                                        On-link
     20    291 fe80::39ce:cff5:8dcd:cdc1/128
                                        On-link
      1    331 ff00::/8                 On-link
     20    291 ff00::/8                 On-link
      9    331 ff00::/8                 On-link
    ===========================================================================
    Persistent Routes:
      None

    Was ich noch ergänzen möchte:

    Von meinem Laptop wurde die W-Lan Karte getauscht auf Garantie und es war übergangsweise eine 2.te Karte verbaut. 

    Wifi Netzwerverbindung 2 als die original wieder verbaut wurde gab nur noch Wifi Netzververbindung (1).

    Auch das Anstecken ans Internet über LAN gibt keine Änderung.

    Der PC wurde auch schon einmal auf einen Wiederherstellungspunkt zurückgesetzt ansonsten ist das System frisch.

    Netzwerkkartentreiber wurden auch schon gelöscht und neu gestartet.

    Auch die Windows10 Netzwerk zurücksetzen Funktion brachte keinen Erfolg.

    Ein neues Lokales Benutzerkonto ohne Domain funktioniert ebenfalls nicht.

    Ich hoffe ein Netzwerkexperte von euch kann mir helfen oder einen Weg findne wie man Stück für Stück zum Fehler findet.

    Ich bin RATLOS.

    Vielen Dank.

    LG Anton

    Mittwoch, 21. Juni 2017 08:45

Antworten

  • Hallo,

    Danke für deine Antwort!

    Ich habe das Problem gefunden.

    Der Ping und die Namensauflösung haben nicht funktioniert, es war auch kein Proxy eingestellt.

    Das Problem war eine falsche Dateiberechtigung der HOST Datei, dadurch wurde sie zwar beschrieben aber ignoriert.

    Ich habe die HOST Datei testweise auf Berechtigung everybody (read / write) und es hat funktioniert.

    Danach habe ich Sie mit einer anderen Installation verglichen und die Berechtigung korrigiert.

    Gruß Anton

    • Als Antwort markiert Anton93 Mittwoch, 21. Juni 2017 13:23
    Mittwoch, 21. Juni 2017 13:23

Alle Antworten

  • Moin,

    wenn die Verbindung im Browser per IP klappt und per FQDN nicht, dann gibt es m.E. nur zwei mögliche Ursachen, die auch zusammen vorkommen können:

    1. Die DNS-Auflösung des FQDN ist fehlerhaft. Was sagt denn PING dazu?
    2. Es ist nicht der Browser, der die DNS-Auflösung tätigt. Das wäre z.B. mit einem Proxy der Fall.

    Wenn PING die Adresse richtig auflöst (auch nach einem ipconfig /flushdns), bleibt nur die Variante 2. Du kannst ja mal einen NetMon-Trace machen und schauen, wohin die Verbindung versucht wird.

    Was passiert denn, wenn Du einen Proxy aktivierst, aber *.firma.unb auf die Ausnahmeliste setzt? Immer vorausgesetzt, dass dann AppGate funktioniert natürlich... aber kannst Du ja machen, nachdem AppGate die Verbindung aufgebaut hat.


    Evgenij Smirnov

    I work @ msg services ag, Berlin -> http://www.msg-services.de
    I blog (in German) @ http://it-pro-berlin.de
    my stuff in PSGallery --> https://www.powershellgallery.com/profiles/it-pro-berlin.de/
    Exchange User Group, Berlin -> http://exusg.de
    Windows Server User Group, Berlin -> http://www.winsvr-berlin.de
    Mark Minasi Technical Forum, reloaded -> http://newforum.minasi.com

    Mittwoch, 21. Juni 2017 10:08
  • Hallo,

    Danke für deine Antwort!

    Ich habe das Problem gefunden.

    Der Ping und die Namensauflösung haben nicht funktioniert, es war auch kein Proxy eingestellt.

    Das Problem war eine falsche Dateiberechtigung der HOST Datei, dadurch wurde sie zwar beschrieben aber ignoriert.

    Ich habe die HOST Datei testweise auf Berechtigung everybody (read / write) und es hat funktioniert.

    Danach habe ich Sie mit einer anderen Installation verglichen und die Berechtigung korrigiert.

    Gruß Anton

    • Als Antwort markiert Anton93 Mittwoch, 21. Juni 2017 13:23
    Mittwoch, 21. Juni 2017 13:23
  • Hallo,

    Danke für deine Antwort!

    Ich habe das Problem gefunden.

    Der Ping und die Namensauflösung haben nicht funktioniert, es war auch kein Proxy eingestellt.

    Das Problem war eine falsche Dateiberechtigung der HOST Datei, dadurch wurde sie zwar beschrieben aber ignoriert.

    Ich habe die HOST Datei testweise auf Berechtigung everybody (read / write) und es hat funktioniert.

    Danach habe ich Sie mit einer anderen Installation verglichen und die Berechtigung korrigiert.

    Gruß Anton

    Vielen Dank für deinen Beitrag... genau durch das richtige setzen der Besitzer und Berechtigungen konnte ich das Problem auch wieder lösen.
    Freitag, 24. Mai 2019 14:13
  • Wenn ich die Hosts nicht schreiben konnte (nicht als Admin geöffnet), wurde ich aufgefordert diese dann in einem anderen Verzeichnis zu sichern.
    Das fällt einem doch auf;-).

    Das passiert eben auch dann, wenn man bereits Admin ist. Man muss den Editor "als Admin" starten.

    Freitag, 24. Mai 2019 14:36