none
WMI Filter gelöscht RRS feed

  • Allgemeine Diskussion

  • Hallo,

     

    mein Problem ist das ich nun das ich alle WMI Filter gelöscht habe . Nun können ja die Clients nicht mehr aktualisieren. Nun meine Frage wie kann ich wieder ein WMI-Filter erstellen,dieser soll für XP & 7 gültig sein, die Gruppenrichtline heißt gpo1.

     

    Da ich mit der Gruppenrichtline noch etwas schwach bin benötige ich eure Hilfe.

     

     

    Samstag, 28. Januar 2012 06:08

Alle Antworten

  • Hallo,

     

    mein Problem ist das ich nun das ich alle WMI Filter gelöscht habe . Nun können ja die Clients nicht mehr aktualisieren. Nun meine Frage wie kann ich wieder ein WMI-Filter erstellen,dieser soll für XP & 7 gültig sein, die Gruppenrichtline heißt gpo1.

     

    Da ich mit der Gruppenrichtline noch etwas schwach bin benötige ich eure Hilfe.

     

     


    Diesen Beitrag habe ich eben gefunden http://technet.microsoft.com/de-de/library/cc780416(WS.10).aspx . Aber ich verstehe nicht was ich abfragen soll?
    Samstag, 28. Januar 2012 06:13
  • Am 28.01.2012 07:08, schrieb 1234_marco:

    mein Problem ist das ich nun das ich alle WMI Filter gelöscht habe .

    Warum?

    wie kann ich wieder ein WMI-Filter erstellen,dieser soll für XP & 7
    gültig sein

    GPMC -> Wmi Filter -> Neu
    SELECT * FROM Win32_OperatingSystem WHERE BuildNumber > '5000'

    XP            = 2600
    2003          = 3790
    Vista/2008    = 6000
    Vista/2008SP1 = 6001
    Vista/2008SP2 = 6002
    7/2008R2      = 7600
    7/2008R2SP1   = 7601

    alles größer "5999" ist Vista.-artig, alles kleinere ist XP/2003

    Tschö
    Mark


    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage:       www.gruppenrichtlinien.de - deutsch
    GPO Tool:       www.reg2xml.com - Registry Export File Converter
    NetworkTrayTool www.gruppenrichtlinien.de/tools/Networktraytool.htm

    Samstag, 28. Januar 2012 09:30
  • Am 28.01.2012 07:08, schrieb 1234_marco:

    mein Problem ist das ich nun das ich alle WMI Filter gelöscht habe .

    Warum?

    wie kann ich wieder ein WMI-Filter erstellen,dieser soll für XP & 7
    gültig sein

    GPMC -> Wmi Filter -> Neu
    SELECT * FROM Win32_OperatingSystem WHERE BuildNumber > '5000'

    XP            = 2600
    2003          = 3790
    Vista/2008    = 6000
    Vista/2008SP1 = 6001
    Vista/2008SP2 = 6002
    7/2008R2      = 7600
    7/2008R2SP1   = 7601

    alles größer "5999" ist Vista.-artig, alles kleinere ist XP/2003

    Tschö
    Mark


    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage:       www.gruppenrichtlinien.de - deutsch
    GPO Tool:       www.reg2xml.com - Registry Export File Converter
    NetworkTrayTool www.gruppenrichtlinien.de/tools/Networktraytool.htm


    So nun habe ich folgendes Problem , ich habe den neuen WMI Filter (Den einzigsten) mit diesen Einstellungen sprich, Windows 7 - Windows 7 SP1 -Windows XP gefüllt. Nun sagt der XP Client ,er hat die neue GPO übernommen, und der Windows 7 Client sagt ,das die GPO Aktualisierung  auf Grund von WMI Einstellungen fehlgeschlagen ist. Was kann ich tun? Der Windows XP Client übernimmt zwar die neue GPO ,lädt aber die vorgegebenen Laufwerke nicht !? Gruss 1234_marco
    Sonntag, 29. Januar 2012 09:08
  • Am 28.01.2012 07:08, schrieb 1234_marco:

    mein Problem ist das ich nun das ich alle WMI Filter gelöscht habe .

    Warum?

    wie kann ich wieder ein WMI-Filter erstellen,dieser soll für XP & 7
    gültig sein

    GPMC -> Wmi Filter -> Neu
    SELECT * FROM Win32_OperatingSystem WHERE BuildNumber > '5000'

    XP            = 2600
    2003          = 3790
    Vista/2008    = 6000
    Vista/2008SP1 = 6001
    Vista/2008SP2 = 6002
    7/2008R2      = 7600
    7/2008R2SP1   = 7601

    alles größer "5999" ist Vista.-artig, alles kleinere ist XP/2003

    Tschö
    Mark


    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage:       www.gruppenrichtlinien.de - deutsch
    GPO Tool:       www.reg2xml.com - Registry Export File Converter
    NetworkTrayTool www.gruppenrichtlinien.de/tools/Networktraytool.htm


    So nun habe ich folgendes Problem , ich habe den neuen WMI Filter (Den einzigsten) mit diesen Einstellungen sprich, Windows 7 - Windows 7 SP1 -Windows XP gefüllt. Nun sagt der XP Client ,er hat die neue GPO übernommen, und der Windows 7 Client sagt ,das die GPO Aktualisierung  auf Grund von WMI Einstellungen fehlgeschlagen ist. Was kann ich tun? Der Windows XP Client übernimmt zwar die neue GPO ,lädt aber die vorgegebenen Laufwerke nicht !? Gruss 1234_marco

    So ich habe die Eingabe in den Filter eingefügt SELECT * FROM Win32_OperatingSystem WHERE BuildNumber > '5000' , aber jetzt aktualisiert er zwar die Benutzerrichtlinie , aber bei der Computerrichtlinie beschwert er sich immer noch?!
    Sonntag, 29. Januar 2012 09:21
  • Hallo,

    poste doch bitte einmal deinen aktuellen WMI-Filter.

    >aber jetzt aktualisiert er zwar die Benutzerrichtlinie , aber bei der Computerrichtlinie beschwert er sich immer noch?!

    der WMI Filter ist immer an die ganze Policy gebunden.
    Dementsprechend darf es hier keinen Unterschied geben.

     


    MVP Group Policy - Mythen, Insiderinfos und Troubleshooting zum Thema GPOs: http://matthiaswolf.blogspot.com/
    Sonntag, 29. Januar 2012 10:56
  • Hallo,

    poste doch bitte einmal deinen aktuellen WMI-Filter.

    >aber jetzt aktualisiert er zwar die Benutzerrichtlinie , aber bei der Computerrichtlinie beschwert er sich immer noch?!

    der WMI Filter ist immer an die ganze Policy gebunden.
    Dementsprechend darf es hier keinen Unterschied geben.

     


    MVP Group Policy - Mythen, Insiderinfos und Troubleshooting zum Thema GPOs: http://matthiaswolf.blogspot.com/


    Das sind die eingefügten Objekte

    In der Abfrage sind drin:

    SELECT * FROM Win32_OperatingSystem WHERE BuildNumber > '7600'

    SELECT * FROM Win32_OperatingSystem WHERE BuildNumber > '7601'

    SELECT * FROM Win32_OperatingSystem WHERE BuildNumber > '2600'

    SELECT * FROM Win32_OperatingSystem WHERE BuildNumber > '5000'

     

    Sonntag, 29. Januar 2012 11:22
  • Am 29.01.2012 12:22, schrieb 1234_marco:

    In der Abfrage sind drin:
    SELECT * FROM Win32_OperatingSystem WHERE BuildNumber > '7600'
    SELECT * FROM Win32_OperatingSystem WHERE BuildNumber > '7601'
    SELECT * FROM Win32_OperatingSystem WHERE BuildNumber > '2600'
    SELECT * FROM Win32_OperatingSystem WHERE BuildNumber > '5000'

    die Einzel Abfragen innerhalb eines Filters werden mit AND verknüpft.
    Das kann niemals TRUE ergeben, denn keines der Systemem wird ein
    "größer Win7 SP1 liefern", höchstens ein "=" (gleich)

    Und bei 4 eingetragenen select Befehlen müssen ale "TRUE" ergeben, damit
    die GPO angewendet wird.

    Noch was, wo ich all die "Schlösser" an den GPOs sehe:
    Sortiere sie "noch oben" und "nach unten" oder verlinke sie richtig,
    bzw. widersprech diesen nicht  in den darunterliegenden GPs, dann muss
    du sie auch nicht erzwingen. Das macht es nur unnötig kompoliziert.

    "Force" / "Erzwungen" erzwingt nichts, es sorgt nur dafür, daß die höher
    liegende Richtlinie später läuft und damit am Ende mit ihrer
    Einstellungen gegenüber einer darunter liegende gewinnt.

    Tschö
    Mark


    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage:       www.gruppenrichtlinien.de - deutsch
    GPO Tool:       www.reg2xml.com - Registry Export File Converter
    NetworkTrayTool www.gruppenrichtlinien.de/tools/Networktraytool.htm

    Sonntag, 29. Januar 2012 15:42
  • >SELECT * FROM Win32_OperatingSystem WHERE BuildNumber > '7600'
    >SELECT * FROM Win32_OperatingSystem WHERE BuildNumber > '7601'
    >SELECT * FROM Win32_OperatingSystem WHERE BuildNumber > '2600'
    >SELECT * FROM Win32_OperatingSystem WHERE BuildNumber > '5000'

    Das ist natürlich von der Logik her schon unsinnig.

    Selbst wenn die Filter nicht per AND verknüpft wären, so würde schon der Filter > '2600' immer gelten.

    (auch z.B. bei Windows Vista).

    Was du machen könntest:

    SELECT * FROM Win32_OperatingSystem WHERE BuildNumber = '2600' or BuildNumber = '5000' or BuildNumber >='7600' 

    bzw.

    SELECT * FROM Win32_OperatingSystem WHERE BuildNumber = '2600' or BuildNumber = '5000' or BuildNumber ='7600' or BuildNumber ='7601'


    MVP Group Policy - Mythen, Insiderinfos und Troubleshooting zum Thema GPOs: http://matthiaswolf.blogspot.com/

    Sonntag, 29. Januar 2012 19:52