none
SQL 2012 Replikation - Merge-Replikation lässt sich nicht einrichten RRS feed

  • Frage

  • Hallo,
    ich muss bei einem Kunden die Replikation wieder einrichten, die seit einem Hardware-Wechsel
    (Fritz-Box) nicht mehr läuft.
    Mein Problem ist, dass vom SQL-Server aus die Express-Maschine nicht erreichbar ist, obgleich
    sie derzeit (auf einem Notebook) im Büro per LAN im Netzwerk hängt
    und natürlich in der Domäne eingebunden ist.
    Der Server ist von der Express-Maschine aus zu erreichen.

    --------------------
    Folgendes ist der Status:

    Beide Maschinen sind im AD und per ping zu erreichen.
    Die Geräte sind per LAN im lokalen Netz (der ursprüngliche Übeltäter Fritz-Box ist
    noch gar nicht involviert)

    Namensauflösung ist ok
    SQL-Server Browser läuft auf beiden SQL-Servern
    Die Protokolle sind alle eingeschaltet
    Firewall in der Domäne ist deaktiviert
    Notebook ist brandneu und SQL-Express jungfräulich installiert
    Habe jetzt auf dem Server eine neue VM bereitgestellt bekommen, auf der ich die
    SQL-Server-Evaluation installiert habe, um zu sehen, ob es evtl.
    an der bisher laufenden SQL-VM liegt, d. h. auch die Server-SQL-Installation ist jungfräulich

    ---------------------
    Wenn ich im Management-Studio des SQL-Servers versuche, mich mit der Express zu verbinden,
    bekomme ich die Fehlermeldung
    Fehlermeldung SQL-Server
    Der angegebene Link ist leider auch tot.
    Habe auch schon eine UDL-Datei erstellt, aber da bekomme ich die Fehlermeldung

    Ich frage mich so langsam, ob mit der Hostmaschine / Windows irgendwas so total verbogen ist,
    dass ich so keine Chance mehr habe, die Replikation zum Laufen zu bringen,
    ohne dass man den kompletten Host neu aufsetzt.

    Fällt jemandem von euch noch was dazu ein???

    Gruß

    Susanne

    Dienstag, 24. Juli 2018 09:50

Alle Antworten

  • Hallo Susanne,

    bei der Express Edition sind im Standard Remote Connections abgeschaltet, es funktionieren nur lokale Connections; das würde die Situation erklären.

    Siehe https://blogs.msdn.microsoft.com/sqlexpress/2005/05/05/how-to-configure-express-to-accept-remote-connections/


    Olaf Helper

    [ Blog] [ Xing] [ MVP]

    Dienstag, 24. Juli 2018 09:54
  • Hallo, Olaf,

    danke für die schnelle Antwort, ich wusste doch, dass ich in meiner Status-Liste einen Punkt vergessen hatte - Remote Connections sind auf beiden Maschinen enabled, ich habe sogar bei beiden den TimeOut auf 0 gesetzt. Aber leider ist dieser Punkt auch schon abgearbeitet und der Erfolg fehlt :-(

    Gruß

    Susanne

    Dienstag, 24. Juli 2018 10:02
  • Läuft der SQL Browser Dienst auf beiden Machinen?

    Ansonsten gibt es hier noch eine lange Liste mit Punkten zum Prüfen: https://support.microsoft.com/en-us/help/4009936/solving-connectivity-errors-to-sql-server


    Olaf Helper

    [ Blog] [ Xing] [ MVP]

    Dienstag, 24. Juli 2018 10:08
  • SQL-Server Browser läuft auf beiden SQL-Servern
    Dienstag, 24. Juli 2018 10:09
  • Am 24.07.2018 schrieb SIH007:

    Hallo,ich muss bei einem Kunden die Replikation wieder einrichten, die seit einem Hardware-Wechsel (Fritz-Box) nicht mehr läuft.

    Wurde die Fritzbox gegen eine Fritzbox oder gegen etwas anderes
    getauscht? Hat sich das IP-Segment geändert?

    Mein Problem ist, dass vom SQL-Server aus die Express-Maschine nicht erreichbar ist, obgleich sie derzeit (auf einem Notebook) im Büro per LAN im Netzwerk hängt und natürlich in der Domäne eingebunden ist.
    Der Server ist von der Express-Maschine aus zu erreichen.--------------------
    Folgendes ist der Status:Beide Maschinen sind im AD und per ping zu erreichen.
    Die Geräte sind per LAN im lokalen Netz (der ursprüngliche Übeltäter Fritz-Box ist noch gar nicht involviert)
    Namensauflösung ist ok
    SQL-Server Browser läuft auf beiden SQL-Servern
    Die Protokolle sind alle eingeschaltet

    Kannst Du von jedem Gerät der Domain aus die Express Maschine
    anpingen?

    Firewall in der Domäne ist deaktiviert

    Mit Verlaub, das ist nicht gut. Firewall einschalten und korrekt
    konfigurieren.

    Notebook ist brandneu und SQL-Express jungfräulich installiert

    D.h. die OEM Installation des uns unbekannten Gerätes ist drauf?
    Welches Gerät ist im Einsatz? Welcher AV-Scanner ist vorinstalliert?
    Welcher AV-Scanner läuft im Hintergrund ständig? Welche Versionen vom
    SQL sind im Einsatz? Welche genaue Windows Version ist im Einsatz? W10
    1803?

    Habe jetzt auf dem Server eine neue VM bereitgestellt bekommen, auf der ich die SQL-Server-Evaluation installiert habe, um zu sehen, ob es evtl. an der bisher laufenden SQL-VM liegt, d. h. auch die Server-SQL-Installation ist jungfräulich---------------------
    Wenn ich im Management-Studio des SQL-Servers versuche, mich mit der Express zu verbinden, bekomme ich die Fehlermeldung

    Welche Fehlermeldung? So eine Meldung kann man auch abtippen.

    Hast Du den Port 1433 richtig eingestellt?
    https://alexanderzeitler.com/articles/Auf-welchem-Port-l%C3%A4uft-mein-SQL-Server-(Express)-2008-R2-Oder-warum-bekomme-ich-keine-Verbindung/

    EDIT: Ich hab den Link 'repariert', wäre die Forensoftware nicht so kaputt, hätte man mit langen Links auch kein Problem.

    Servus
    Winfried


    WSUS Package Publisher: http://wsuspackagepublisher.codeplex.com/
    HowTos zum WSUS Package Publisher http://www.wsus.de/wpp
    GPO's: http://www.gruppenrichtlinien.de
    NNTP-Bridge für MS-Foren: http://communitybridge.codeplex.com/
    GP-PACK - PRIVACY AND TELEMETRIE: http://www.gp-pack.com/



    Dienstag, 24. Juli 2018 20:15
  • Hallo, Winfried,

    danke für deine Antwort. Hab die Einstellungen nochmal überprüft - dein Link ist übrigens nicht erreichbar - steht alles auf 1433. 

    Was mir dabei allerdings noch auffiel und ich mir nicht erklären kann, ist folgendes:

    Wenn ich auf dem Notebook in den Konfigurationsmanager gehe, sehe ich die lokale Maschine und einen SQL-Server, beide könnte ich theoretisch konfigurieren. 

    Am Server dagegen sehe ich nur die lokale Maschine.

    Hab natürlich beide SQL-Server neu gestartet, trotzdem ist vom Server aus keine Verbindung auf den SQL-Express möglich (umgekehrt war das noch nie ein Problem)

    Mittwoch, 25. Juli 2018 06:21
  • Hallo Susanne,

    der Browser-Dienst benötigt noch UPD 1434 auf der Firewall. Wurde das ebenfalls geprüft?

    Kannst Du - nur als Test - den SQL Server per IP, Port erreichen?

    Ist die Installation von SQLExpress mit einem Instanznamen installiert worden?


    Uwe Ricken (Blog | Twitter)
    Microsoft Certiied Master - SQL Server 2008
    Microsoft Certified Solution Master - CHARTER Data Platform
    Microsoft Certified Solution Expert - Data Platform
    db Berater GmbH
    Microsoft SQL Server Blog (german only)

    Mittwoch, 25. Juli 2018 07:47
  • Am 25.07.2018 schrieb SIH007:

    danke für deine Antwort. Hab die Einstellungen nochmal überprüft - dein Link ist übrigens nicht erreichbar - steht alles auf 1433. 

    Wenn der Link nicht erreichbar ist, woher weißt Du dann was darin
    erklärt wurde? Der Link war und ist erreichbar.

    Servus
    Winfried


    WSUS Package Publisher: http://wsuspackagepublisher.codeplex.com/
    HowTos zum WSUS Package Publisher http://www.wsus.de/wpp
    GPO's: http://www.gruppenrichtlinien.de
    NNTP-Bridge für MS-Foren: http://communitybridge.codeplex.com/
    GP-PACK - PRIVACY AND TELEMETRIE: http://www.gp-pack.com/

    Mittwoch, 25. Juli 2018 15:54