none
Eine Datei kann nicht erstellt werden, wenn sie bereits vorhanden ist RRS feed

  • Frage

  • Hallo zusammen!

    Ich werde hier noch bekloppt!! Ich habe mit unseren neuen Server in der Schule ein echtes Problem, was ich nicht alleine gelöst bekomme.

    Wir haben hier folgende Umgebung:
    -          1 Server: Windows Server 2008 Enterprise mit AD
    -          28 Client´s: Windows XP Pro

    Alle mit den neusten Updates versorgt!

    Zum Problem.

    Wenn sich der Schüler an den AD anmeldet, sieht erst einmal alles gut aus.
    -          Profil wird neu erstellt, da es noch kein Servergespeichertes Profil gibt
    -          Die Gruppenrichtlinie wird erfolgreich übernommen

    Problem fängt allerdings an, wenn sich der User wieder abmeldet. Hier kommt es dann zu folgender Meldung:

    ------------------------------------------------------------------

    Erste Meldung:

    Die Datei C:\Dokumente und Einstellungen\Maxmusterschuler\Startmenü\Programme\Zubehör\Unterhaltungsmedien konnte nicht nach \\Server\Profile$\Klasse5a\Maxmusterschueler\Startmenü\Programme\Zubehör\Unterhaltungsmedien kopiert werden. Mögliche Fehlerursache sind Netzwerkprobleme oder nicht ausreichende Sicherheitsrechte. Wenden Sie sich an den Netzwerkadministrator, wenn das Problem weiterhin besteht.

    Details – Eine Datei kann nicht erstellt werden, wenn sie bereits vorhanden ist.
    --------------------
    Zweite Meldung:

    Das servergespeicherte Profil konnte nicht aktualisiert werden. Mögliche Fehlerursachen sind Netzwerkprobleme oder nicht ausreichende Sicherheitsrechte. Wenden Sie sich an den Netzwerkadministrator, wenn das Problem weiterhin besteht.
    ------------------------------------------------------------------

    Eine Anwendung, die auf die besagt Datei zugreift (in diesem Fall der Ordner "Unterhaltungsmedien") kann ich glaube ich ausschließen, denn wenn ich den Ordner ""Unterhaltungsmedien" lösche, wird gleich die nächste Datei/Ordner angemault.

    Die User sind alle in der Gruppe „Domain-Benutzer“ und in einer neuen Gruppe mit dem Namen „Schüler“.
    Wenn ich zum Test den Domain-Admin mit rein mache, dann funktioniert alles, das will ich aber natürlich nicht ;o)

    Wenn nur die Gruppe „Domain-Benutzer“ vorhanden ist, dann kommt auch der Fehler (siehe oben)!

    Der User hat auf den Profil Ordner am Server Vollzugriff. Es werden nämlich auch noch folgende Inhalte auf den Server kopiert:
    Vorlagen (Leerer Ordner)
    NTUSER.DAT
    NTUSER.DAT.LOG
    Ntuser.ini
    Ntuser.pol

    Die OU ist wie folgt aufgebaut:
    -> Domain
    --> Schüler
    ---> KlasseXY

    Hat hier jemand eine Idee, wo der Fehler liegen kann?

    Viele Grüße
    Porschi

    Montag, 28. September 2009 11:07

Antworten

  • Hallo Andreas,

    habe den Fehler gefunden und gelöst. ;o)
    Aber wieso diese komische Fehlermeldung gekommen ist, kann ich mir nicht erklären.

    Zur Lösung:
    Da es sich hier ja um eine Schule handelt und einmal im Jahr einige Zugänge kommen und auch wieder gehen, habe ich zur besseren Verwaltung   in der Freigabe die Klassen-Ordner erstellt in dem die User Accounts geschrieben wurden.
    Um zu vermeiden, dass z.B. ein Schüler etwas an den Klassen Ordnern ändert oder sie gar löscht, hatte ich in den Klassen-Ordnern die NTFS Berechtigung „Jeder“ gelöscht. Es hatten somit nur Admins und Lehrer "direkten" Zugriff auf diesen Klassen-Ordner. Erst im Klassen-Ordner selbst, wo die User ihren Ordner haben wurde dem User wieder Vollzugriff gewährt!

    Was ich nicht so ganz verstehe ist, warum er z.B. ohne Probleme die Daten wie Ntuser.ini, NTUSER.DAT usw. schreiben kann und sogar beim abmelden noch den Ordner „Vorlagen“ erstellen kann, aber nicht mehr die dort enthaltenden Dateien.

    Wünschenswert währe auch eine andere Fehlermeldung wie „Zugriff verweigert“, da ja keine Datei überschreiben wird sondern sie nur nicht erstellt werden kann.

    Egal, nachdem ich jetzt wieder allen den Zugriff auf die Klassen Ordner erlaubt hat, scheint es jetzt ohne Fehler zu funktionieren (getestet per VPN Einwahl von zuhause).

    Bei der ganzen Testerei ist mir allerdings noch ein anderer Fehler aufgefallen. Vielleicht hat dafür ja auch noch jemand eine Lösung.

    Und zwar habe ich per Gruppenrichtlinie den Usern den Flash-Player zugewiesen.

    Beim Login Fenster kommt auch der Hinweis „Flash-Player wird installiert“. Das wird allerdings nicht erfolgreich durchgeführt. Laut Logs kommt es dort zu ein Rechte Problem wo so etwas wie „Zugriff verweigert, da nicht als Admin angemeldet“ kommt. Wie kann ich den der Richtlinie Admin Rechte einräumen ohne dem User die Rechte zu geben?

    Konfig wurde wie hier beschreiben durchgeführt:
    http://support.microsoft.com/kb/324750/de

    Viele Grüße schon mal

    Porschi

    • Als Antwort markiert Porschi Freitag, 2. Oktober 2009 12:25
    Mittwoch, 30. September 2009 06:09

Alle Antworten

  • Hallo Porschi,

    bei servergespeicherten Profilien, darf die Zwischenspeicherung (Offlinie) nicht aktiviert sein, was aber standardmäßig passiert
    wenn Du die Freigabe anlegst. Bitte Freigabe "Profile$" überprüfen und Offline deaktivieren.

    http://support.microsoft.com/kb/287566/en-us

    Gruß Ralph Andreas Altermann
    Montag, 28. September 2009 12:28
  • Hallo Andreas,

    schon mal danke für deine schnelle Antwort!

    Leider war aber bei der Freigabe schon die Option "Dateien oder Programme der Freigabe nicht offline verfügbar machen" aktiv.
    Vielleicht noch eine andere Idee?

    Gruß
    Porschi Benutzermedaillen Benutzermedaillen Benutzermedaillen Benutzermedaillen Benutzermedaillen
    Dienstag, 29. September 2009 06:08
  • Hi Porschi,

    habt Ihr vorher an den Clients am Profil geschraubt ? (Default User)
    Funktioniert es zumindest mit einem jungfräulichen Profil ?
    Habt Ihr ggf. Schutzsoftware am Laufen, wie PC-Wächter oder Antivirenschutz ?
    Welche Daten/Dateien liegen ggf. noch im Order "....\Unterhaltungsmedien" ?
    (Erweitere Ansicht)
    Welche GPOs sind konfiguriert hinsichtl. der Profile ?
    Sind die Profile mandatory ?
    Gruß Ralph Andreas Altermann
    Dienstag, 29. September 2009 07:21
  • Hallo Andreas,

    habe den Fehler gefunden und gelöst. ;o)
    Aber wieso diese komische Fehlermeldung gekommen ist, kann ich mir nicht erklären.

    Zur Lösung:
    Da es sich hier ja um eine Schule handelt und einmal im Jahr einige Zugänge kommen und auch wieder gehen, habe ich zur besseren Verwaltung   in der Freigabe die Klassen-Ordner erstellt in dem die User Accounts geschrieben wurden.
    Um zu vermeiden, dass z.B. ein Schüler etwas an den Klassen Ordnern ändert oder sie gar löscht, hatte ich in den Klassen-Ordnern die NTFS Berechtigung „Jeder“ gelöscht. Es hatten somit nur Admins und Lehrer "direkten" Zugriff auf diesen Klassen-Ordner. Erst im Klassen-Ordner selbst, wo die User ihren Ordner haben wurde dem User wieder Vollzugriff gewährt!

    Was ich nicht so ganz verstehe ist, warum er z.B. ohne Probleme die Daten wie Ntuser.ini, NTUSER.DAT usw. schreiben kann und sogar beim abmelden noch den Ordner „Vorlagen“ erstellen kann, aber nicht mehr die dort enthaltenden Dateien.

    Wünschenswert währe auch eine andere Fehlermeldung wie „Zugriff verweigert“, da ja keine Datei überschreiben wird sondern sie nur nicht erstellt werden kann.

    Egal, nachdem ich jetzt wieder allen den Zugriff auf die Klassen Ordner erlaubt hat, scheint es jetzt ohne Fehler zu funktionieren (getestet per VPN Einwahl von zuhause).

    Bei der ganzen Testerei ist mir allerdings noch ein anderer Fehler aufgefallen. Vielleicht hat dafür ja auch noch jemand eine Lösung.

    Und zwar habe ich per Gruppenrichtlinie den Usern den Flash-Player zugewiesen.

    Beim Login Fenster kommt auch der Hinweis „Flash-Player wird installiert“. Das wird allerdings nicht erfolgreich durchgeführt. Laut Logs kommt es dort zu ein Rechte Problem wo so etwas wie „Zugriff verweigert, da nicht als Admin angemeldet“ kommt. Wie kann ich den der Richtlinie Admin Rechte einräumen ohne dem User die Rechte zu geben?

    Konfig wurde wie hier beschreiben durchgeführt:
    http://support.microsoft.com/kb/324750/de

    Viele Grüße schon mal

    Porschi

    • Als Antwort markiert Porschi Freitag, 2. Oktober 2009 12:25
    Mittwoch, 30. September 2009 06:09
  • Hallo Porschi,

    >Aber wieso diese komische Fehlermeldung gekommen ist, kann ich mir nicht erklären.
    Ja die Wege des Herrn sind manchmal seltsam.

    Dank für das Feedback. Evtl. reicht ja anstatt Vollzugriff für "Jeder" nur "Ändern", aber dazu benötigt man doch noch mehr
    Details.

    Betr. Flashplayer
    Kannst Du ihn denn manuell installieren ? Es kann u. U. an einem defektem Registryeintrag liegen, den müsste Du aber mit
    RegMon von Sysinternals, sorry von MS , selbst rausfinden.  Kann Dir aber hier helfen, habe den Key nur nicht mehr im Kopf
    bzw. vergessen zu dokumentieren.
    Gruß Ralph Andreas Altermann
    Mittwoch, 30. September 2009 07:29
  • So, da bin ich auch schon wieder!

    Problem mit der Anmeldung ist wohl doch noch nicht so ganz abgeschlossen.
    Haben jetzt mal einen Schüler an den Client anmelden lassen, um es auch dort zu testen.
    User kann sich zwar erfolgreich an und abmelden. Es kommt auch keinerlei Fehlermeldung. Allerdings wird das Profil nicht "Servergespeichert" erstellt sondern Lokal??
    Es kann auch nicht der Typ von Lokal auf Servergespeichert geändert werden, da diese funktion deaktiviert ist.

    Problem scheint allerdings nicht jeder User zu haben??!
    Es gibt nämlich auch Schüler, die auf diesem getesteten Client ein Servergespeichertes Profil haben.
    An der Gruppenrichtlinie kann es theoretisch auch nicht liegen, da alle Schüler die gleiche haben.

    Beim Thema Flashplayer.
    Auch manuell kann nicht installiert werden, da keine berechtigung vorhanden sind (hätte mich auch gewundert ;o)

    Jetzt brauche ich noch mal ein paar Ideen.

    Gruß
    Porschi
     
    Mittwoch, 30. September 2009 11:00
  • Hallo Porschi,

    leider lässt sich IMHO der Flashplayer nur mit administrativen Rechten installieren, da er tief in die Registry will.

    Betr. Deines o.g. User:
    Hat dieser User denn auch auf seinen Eigenschaften im AD den Profilpfad eingetragen ?
    Gruß Ralph Andreas Altermann
    Mittwoch, 30. September 2009 11:15
  • Hi Andreas,

    mit den nicht geladenen Profilen war wohl ein Fehlalarm von meinem Kollegen. Habe mir gestern mal ein paar Rechner angeschaut und dort waren alle Profile Servergespeichert bis auf wenige Accounts. Die waren aber alle schon älter und wer weiß, was da los war. Die aktuellen scheinen alle Servergespeichert zu werden.

    Zum Thema mit den Installieren per Gruppenrichtlinie.
    Ich habe auch mal andere Programme getestet wie z.B. den Adobe Reader und Firefox. Die MSI Pakete gehen aber auch nicht. Laut Logs wird die Installation immer verweigert, vermutlich weil die Installation mit den Rechten des Users ausgeführt wird.
    Gibt es den keine Richtlinie, womit ich dem Zugewiesenen MSI Paket die Install-Recht einzuräumen kann?

    Viele Grüße
    Porschi

    Donnerstag, 1. Oktober 2009 11:19
  • Hi Porschi,

    kann es sein, dass du die MSI-Pakete über die Benutzer-Einstellungen verteilen willst? Das klappt natürlich nicht, wenn diese nicht in der Gruppe der lokalen Admins sind. Du musst es in deinen Fall über die Machinen-Einstellungen machen.

    Gruß
    Martin
    Freitag, 2. Oktober 2009 06:25
  • Upps, ist das so?
    Werde das mal die Tage testen.

    Werden die Zuweisungen über die Computerkonfiguration auch auf Benutzer Ebene gemacht?
    Hintergrund ist nämlich, dass z.B. die Schüler der Klasse 5 auch die Lernsoftware für die 5te Klasse bekommen sollen und die von der 10ten halt die von der 10ten Klasse!

    Gruß
    Porschi

    Freitag, 2. Oktober 2009 12:24
  • Hallo Porschi,

    >Werden die Zuweisungen über die Computerkonfiguration auch auf Benutzer Ebene gemacht?
    Nein, allgemein Computer für Computer, User für User.
    Du mußt nur darauf achten, das die Computer (einfacher Fall) in einer OU sind und Du hier eine
    entsprechende GruRiLi verlinkst.

    >Hintergrund ist nämlich, dass z.B. die Schüler der Klasse 5 auch die Lernsoftware für die 5te Klasse bekommen sollen und die von der 10ten halt die von der 10ten >Klasse!

    Das wirst Du so mit Boardmitteln nicht sogut realisieren können, da per GPO ausgerollte Software standardmäßig auf dem Computer bleibt und im
    Einzelfall - wenn aus der GPO-Verwaltung herausgenommen - ( z.B. Office) erst wieder deinstalliert wird. Weiteres Problem ist für Dich, das mit jeder
    Anmeldung erst die Programme installiert werden müssen (Zeitfaktor). Evtl. hilft es Dir im ersten Schritt alle benötigten Software zu installieren und
    den Zugriff über Berechtigungen zu steuern. (RiLi für Softwareeinschränkungen)
    Da Du W2008 im Einsatz hast, wäre das Thema RemoteApp bzw. RemoteWeb evt. eine interessante Alternative. 


    Gruß Ralph Andreas Altermann
    Dienstag, 6. Oktober 2009 11:26