none
Remote Desktop Verbindung über Verbindungsbroker RRS feed

  • Frage

  • Hallo zusammen,

    ich habe 4 Server 2019 aufgesetzt, RDP aktiviert und in die Domäne genommen.

    Einer davon fungiert als Verbindungsbroker, nicht als Sitzungshost. Dieser hat den Namen RDS01. Dort habe ich die 3 übrigen Sitzungshosts im Server Manager hinzugefügt, die RDS Dienste installiert und eine neue Sammlung erstellt: rds.domain.local

    In der Registry auf dem Verbindungsbroker habe ich unter HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\ClusterSettings eine neue Zeichenfolge (SZ) DefaultTsvUrl angelegt mit Wert: tsv://MS Terminal Services Plugin.1.rds.domain.local

    Im DNS Server verweise ich den Eintrag rds.domain.local auf die IP Adresse des Verbindungsbrokers.

    Auf einem Test PC (Windows 10) habe ich eine neue .rdp Datei mit Verbindungsziel rds.domain.local erstellt, wenn ich diese jedoch verbinden will kommt die Fehlermeldung:

    Für den Computer kann keine Verbindung mit dem Remotecomputer hergestellt werden, da die in der RDP-Datei angegebenen Einstellungen nicht vom Verbindungsbroker überprüft werden konnten.

    Ich finde zu dem Fehler nichts im Internet. Hat jemand eine Idee woran das liegt? Mit dem Verbindungsbroker selbst kann ich mich jetzt nur noch über mstsc /admin verbinden.


    • Bearbeitet InfoCN Montag, 6. Juli 2020 08:35
    Montag, 6. Juli 2020 08:35

Antworten

  • Moin,

    die .RDP-Dateien kann man sehr schön mit RDWeb erstellen, und dann haben die auch aller Angaben drin, die man braucht. Die Zertifikate müssen zwingend stimmen, und die Clients müssen ihnen vertrauen - sowohl im Sinne von PKI als auch im Sinne der RDP-Signierung.


    Evgenij Smirnov

    http://evgenij.smirnov.de

    • Als Antwort markiert InfoCN Montag, 6. Juli 2020 09:14
    Montag, 6. Juli 2020 08:40
  • Mit der Datei von RDWeb hats funktioniert. So bin ich darauf gekommen, dass in meiner selbst erstellen .rdp Datei mit Notepad ein Eintrag hinzugefügt werden muss: loadbalanceinfo:s:tsv://MS Terminal Services Plugin.1.rdsdomainlocal

    Man beachte, dass hier die Punkte fehlen müssen, sonst geht es nicht (auf dem Verbindungsbroker müssen diese in der Registry übrigens vorhanden sein).

    Die Zertifikate sind der Verbindung erstmal egal, die sind noch nicht vertrauenswürdig aber es klappt jetzt trotzdem. Besten Dank!

    • Als Antwort markiert InfoCN Montag, 6. Juli 2020 09:14
    Montag, 6. Juli 2020 09:14

Alle Antworten

  • Moin,

    die .RDP-Dateien kann man sehr schön mit RDWeb erstellen, und dann haben die auch aller Angaben drin, die man braucht. Die Zertifikate müssen zwingend stimmen, und die Clients müssen ihnen vertrauen - sowohl im Sinne von PKI als auch im Sinne der RDP-Signierung.


    Evgenij Smirnov

    http://evgenij.smirnov.de

    • Als Antwort markiert InfoCN Montag, 6. Juli 2020 09:14
    Montag, 6. Juli 2020 08:40
  • Mit der Datei von RDWeb hats funktioniert. So bin ich darauf gekommen, dass in meiner selbst erstellen .rdp Datei mit Notepad ein Eintrag hinzugefügt werden muss: loadbalanceinfo:s:tsv://MS Terminal Services Plugin.1.rdsdomainlocal

    Man beachte, dass hier die Punkte fehlen müssen, sonst geht es nicht (auf dem Verbindungsbroker müssen diese in der Registry übrigens vorhanden sein).

    Die Zertifikate sind der Verbindung erstmal egal, die sind noch nicht vertrauenswürdig aber es klappt jetzt trotzdem. Besten Dank!

    • Als Antwort markiert InfoCN Montag, 6. Juli 2020 09:14
    Montag, 6. Juli 2020 09:14