none
Error beim deployen eines Berichts in SSRS RRS feed

  • Frage

  • Ich habe einen SQL Server installiert (2016)  und möchte nun einen SSRS- Bericht deployen, es gibt  leider eine Fehlermeldung:

    Es konnte keine Verbindung mit dem Berichtsserver 'http://localhost/ReportServer' hergestellt werden.
    Überprüfen Sie, ob die TargetServerURL-Eigenschaft gültig ist und ob Sie die erforderlichen Berechtigungen
    zum Herstellen einer Verbindung mit dem Berichtsserver besitzen

    Es konnte keine Verbindung hergestellt werden, da der Zielcomputer die Verbindung verweigerte 127.0.0.1:80 (System)

    Der Dienst für SSRS (MSSQLSERVER) wird ausgeführt.

    "localhost" für SSAS und Datenbank wird erkannt und ausgeführt.

    Was könnte noch fehlen, wo lege ich die TagetServerURL-Eigenschaft fest ?

    Danke

    Montag, 27. Februar 2017 17:34

Antworten

  • Bisher hat es bei mir überall mit localhost funktioniert. Wenn es mal nicht geht, hat das eher nichts mit dem SQL Server Reporting Services zu tun, sondern eher mit den Subsystemen, wie Proxy- oder Browsereinstellungen.

    Z.B. wird zuweilen empfohlen, die SSRS URL in den Browser-Einstellungen zu den "vertrauenswürdige Sites" ("Trusted Sites") hinzuzufügen, siehe Konfigurieren eines Berichtsservers im einheitlichen Modus für die lokale Verwaltung (SSRS) 
    => "Fügen Sie Reporting Services -URLs zu vertrauenswürdigen Websites hinzu"


    Olaf Helper

    [ Blog] [ Xing] [ MVP]


    Donnerstag, 2. März 2017 06:21
  • Es hat geklappt, alles war Ok! , das Problem war die "schreibweise"!

    Die Target Server URL habe ich wie folgt eingegeben : http://localhost/ReportServer

    Auch wenn ich Internet Explorer aufgerufen habe, hatte ich "localhost" eingegeben. Bekam die Fehlermeldung "Seite nicht gefunden"

    Ich habe alle "localhost"-Eintragungen durch die IP-Adresse ersetzt, und es ging auf einmal, ich konnte dann auf die URL Reports (mit dem Einstellungen) , das Deployment hat auch gleich geklappt.

    Mir bleibt aber die Frage, warum localhost nicht verstanden wird. Normalerweise die lokale Server können mit diesem "alias" gefunden werden (by default). Ist das bei den SQL Server anders ? Muss man extra die IP-Adresse auf localhost umbenennen ?

    Danke auf jeden Fall für deine Hilfe.

    Mittwoch, 1. März 2017 17:34

Alle Antworten

  • Hallo,

    als erstes solltest Du mal im Reporting Services Configuration Manager (Native Mode) alle Einstellungen kontrollieren.

    Hattest Du den schon die ganzen Berechtigungen für Deinen Account eingerichtet; nach Installation hat erst mal grundsätzlich keiner ausser den lokalen Administrator irgendeine Berechtigung? Falls nicht, lokal den Internet Explorer mit "Als Administrator ausführen" starten und dann die Report Manager URL = http://localhost/Reports  aufrufen, dort kannst Du oben rechts unter den "Einstellungen" die Berechtigungen auf Serverebene vergeben.

    Die TagetServerURL-Eigenschaft kannst Du in den Projekteigenschaften einstellen (Rechte-Maus aufs Projekt => Eigenschaften), das steht im Standard aber schon auf Localhost.


    Olaf Helper

    [ Blog] [ Xing] [ MVP]

    Dienstag, 28. Februar 2017 06:52
  • Hallo,

    da ich alles in meinem laptop installiert habe und ich bin der einzige User, habe ich nicht darann gedach einen anderen Account einzurichten. Ich habe den "Konfiguration Manager für Reporting services" geprüft:

    Dienstkonto: Integriertes Konto verwenden --> lokales System (vorher war dort virtuelles Dienstkonto, habe auch mit der Option "anderes Konto verwenden" versucht (mit meinem Windows Kennung) hat aber auch nicht geklappt).

    Webdienst-URL: Virtuelles Verzeichnis: ReportServer        

    URLs: http://localhost:80/ReportServer    Beim cklicken hier wird folgende Fehlermeldung angezeigt:

    "Konfigurationsfehler beim Berichtserver: (rsServerConfigurationError)

    SQL Server Reporting Services"

    Beim clicken dieser URL über Internet Explorer (administrator) eine andere Fehlermeldung: "Die Seite kann nicht angezeigt werden"

    Webportal : Vituelles Verzeichnis: Reports      URLs http://localhost:80/Reports    

    Auch hier wird eine Fehlermeldung gezeigt: "Service Unavailable     HTTP Error 503: the service is unavailable"

    Wenn ich der einzige User bin (und daher auch admin?) wie sollte am besten mein Account konfiguriert sein? kann ich weiter meine Windows Kennung benutzen oder soll ich einen anderen user für die Reporting Services anlegen?

    Danke

    Dienstag, 28. Februar 2017 22:16
  • und daher auch admin?

    Nein, bist Du nicht. Selbst wenn Dein Account in der lokalen Admin-Gruppe bist, arbeitest Du immer als ganz normaler Benutzer mit eingeschränkten Rechten. Erst wenn Du wie ich extra schrieb ein Programm mit "Als Admin ausführen" aufrufst, arbeitest Du mit erweiterten Rechten.

    Von Konten hinzufügen oder ändern hatte ich nichts geschrieben, bitte mein Post aufmerksam lesen, ggf. auch zweimal. Ändere das Konto wieder zurück und gehe noch mal alle Punkte im SSRS Konfigurationsmanager durch, siehe Link den ich zuvor gepostet hatte.


    Olaf Helper

    [ Blog] [ Xing] [ MVP]

    Mittwoch, 1. März 2017 06:38
  • Ok, das mit dem Admin ist klar, aber wenn ich Internet Explorer mit "Als Administrator ausführen" starte:

    bekomme ich immer noch : "Die Seite kann nicht angezeigt werden", also rechts unten sind auch keine Einstellungen.

    Das Problem liegt bestimmt wo anders.

    Mittwoch, 1. März 2017 16:12
  • Es hat geklappt, alles war Ok! , das Problem war die "schreibweise"!

    Die Target Server URL habe ich wie folgt eingegeben : http://localhost/ReportServer

    Auch wenn ich Internet Explorer aufgerufen habe, hatte ich "localhost" eingegeben. Bekam die Fehlermeldung "Seite nicht gefunden"

    Ich habe alle "localhost"-Eintragungen durch die IP-Adresse ersetzt, und es ging auf einmal, ich konnte dann auf die URL Reports (mit dem Einstellungen) , das Deployment hat auch gleich geklappt.

    Mir bleibt aber die Frage, warum localhost nicht verstanden wird. Normalerweise die lokale Server können mit diesem "alias" gefunden werden (by default). Ist das bei den SQL Server anders ? Muss man extra die IP-Adresse auf localhost umbenennen ?

    Danke auf jeden Fall für deine Hilfe.

    Mittwoch, 1. März 2017 17:34
  • Bisher hat es bei mir überall mit localhost funktioniert. Wenn es mal nicht geht, hat das eher nichts mit dem SQL Server Reporting Services zu tun, sondern eher mit den Subsystemen, wie Proxy- oder Browsereinstellungen.

    Z.B. wird zuweilen empfohlen, die SSRS URL in den Browser-Einstellungen zu den "vertrauenswürdige Sites" ("Trusted Sites") hinzuzufügen, siehe Konfigurieren eines Berichtsservers im einheitlichen Modus für die lokale Verwaltung (SSRS) 
    => "Fügen Sie Reporting Services -URLs zu vertrauenswürdigen Websites hinzu"


    Olaf Helper

    [ Blog] [ Xing] [ MVP]


    Donnerstag, 2. März 2017 06:21