none
neues Zertifikat auf Server, aber alter Name wird gefordert RRS feed

  • Frage

  • Hallo,

    im Zuge einer Firmenübernahme hat sich der SMTP-Domänenname geändert (der Name der AD-Domäne ist unverändert geblieben).

    Das neue Zertifikat wurde auf dem Exchange Server 2013 (CU11) eingepsielt, die Dienste SMTP, IIS, POP3 und IMAP4 dem neuen Zertifikatz zugewiesen. Auf dem internen DNS wurde die neue Zone als Split-DNS mit den benötigten A- und MX-Einträgen angelegt.

    Zudem wurde die neue Domäne als Standard-Domäne definiert und die Adress-Richtlinie entsprechend angepasst.

    Das neue Zertifikat wird auch von Server verwendet, nur erhalten Outlook-Benutzer nun eine Fehlermeldung, da weiterhin der alte FQDN erwartet, aber das neue Zertifikat vom Server ausgwegeben wird.

    An welcher Stelle muss ich noch Anpassungen vornehmen, damit das neue Zertifikat sauber angewendet, und die Outlook-Benutzer ohne Zertifikatsfehler auf den Server zugrteifen können ?

    Vielen Dank bereits im Voraus.

    Grüße

    Tobias

    Montag, 14. März 2016 09:21

Antworten

  • Moin,

    den SCP ändert man via Set-ClientAccessServer, Parameter "autodiscoverserviceinternaluri":

    https://technet.microsoft.com/de-de/library/bb125157%28v=exchg.160%29.aspx


    Gruesse aus Berlin schickt Robert - MVP Office Servers and Services (Exchange Server)

    Montag, 14. März 2016 13:15

Alle Antworten

  • Hallo,

    ich denke, dass das Problem wohl im Attribut "ServiceBindingInformation" des ServiceConnectionPoints im Active Directory zu finden ist.

    Ist es ratsam diesen mittels ADSIEdit zu ändern, oder gibt es hierzu einen eleganteren/sichereren Weg ?

    Grüße

    Tobias

    Montag, 14. März 2016 10:53
  • Moin,

    den SCP ändert man via Set-ClientAccessServer, Parameter "autodiscoverserviceinternaluri":

    https://technet.microsoft.com/de-de/library/bb125157%28v=exchg.160%29.aspx


    Gruesse aus Berlin schickt Robert - MVP Office Servers and Services (Exchange Server)

    Montag, 14. März 2016 13:15
  • Hallo Robert,

    vielen Dank für die Antwort.

    Habe es mittels Exchange Management-Shell umgesetzt, aber leider funktioniert es nur teilweise, sprich einige Clients erhalten keine Zertifikatsfehler mehr, andere schon.

    Ich probiere mal eine Neu-Erstellung der betreffenden Outlook-Profile und gebe eine Rückmeldung, was dabei herausgekommen ist.

    Trotzdem nochmals ein dickes Dankeschön.

    Grüße

    Tobias

    Dienstag, 15. März 2016 13:21
  • Sind das externe oder interne Clients?

    Gruesse aus Berlin schickt Robert - MVP Office Servers and Services (Exchange Server)

    Dienstag, 15. März 2016 13:38
  • Es sind interne Clients, die an das AD angebunden sind.
    Dienstag, 15. März 2016 13:40
  • Dann sollte "Reparieren..." bei den Exchange Konto Einstellungen ausreichen.

    Gruesse aus Berlin schickt Robert - MVP Office Servers and Services (Exchange Server)

    Dienstag, 15. März 2016 13:45
  • Ok, Danke.
    Dienstag, 15. März 2016 13:52